Problems with rack #8

Closed
ckoepp opened this Issue Jul 6, 2012 · 1 comment

Projects

None yet

2 participants

@ckoepp

If I try to start juvia via thin I get an error related to the version of rack.

>> Writing PID to /var/run/thin/juvia.0.pid
>> Changing process privilege to juvia:juvia
>> Using rack adapter
>> Exiting!
/usr/lib/ruby/gems/1.9.1/gems/bundler-1.1.4/lib/bundler/runtime.rb:31:in `block in setup': You have already activated rack 1.4.1, but your Gemfile requires rack 1.3.6. Using bundle exec may solve this. (Gem::LoadError)
        from /usr/lib/ruby/gems/1.9.1/gems/bundler-1.1.4/lib/bundler/runtime.rb:17:in `setup'
        from /usr/lib/ruby/gems/1.9.1/gems/bundler-1.1.4/lib/bundler.rb:107:in `setup'
        from /usr/lib/ruby/gems/1.9.1/gems/bundler-1.1.4/lib/bundler/setup.rb:17:in `<top (required)>'
        from /usr/local/lib/site_ruby/1.9.1/rubygems/custom_require.rb:60:in `require'
        from /usr/local/lib/site_ruby/1.9.1/rubygems/custom_require.rb:60:in `rescue in require'
        from /usr/local/lib/site_ruby/1.9.1/rubygems/custom_require.rb:35:in `require'
        from /web/comments.how2doit.de/juvia/config/boot.rb:6:in `<top (required)>'
        from /usr/local/lib/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
        from /usr/local/lib/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
        from /web/comments.how2doit.de/juvia/config/application.rb:3:in `<top (required)>'
        from /usr/local/lib/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
        from /usr/local/lib/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
        from /web/comments.how2doit.de/juvia/config/environment.rb:2:in `<top (required)>'
        from /usr/local/lib/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
        from /usr/local/lib/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
        from /web/comments.how2doit.de/juvia/config.ru:3:in `block in <main>'
        from /usr/lib/ruby/gems/1.9.1/gems/rack-1.4.1/lib/rack/builder.rb:51:in `instance_eval'
        from /usr/lib/ruby/gems/1.9.1/gems/rack-1.4.1/lib/rack/builder.rb:51:in `initialize'
        from /web/comments.how2doit.de/juvia/config.ru:1:in `new'
        from /web/comments.how2doit.de/juvia/config.ru:1:in `<main>'
        from /usr/lib/ruby/gems/1.9.1/gems/thin-1.3.1/lib/rack/adapter/loader.rb:36:in `eval'
        from /usr/lib/ruby/gems/1.9.1/gems/thin-1.3.1/lib/rack/adapter/loader.rb:36:in `load'
        from /usr/lib/ruby/gems/1.9.1/gems/thin-1.3.1/lib/rack/adapter/loader.rb:45:in `for'
        from /usr/lib/ruby/gems/1.9.1/gems/thin-1.3.1/lib/thin/controllers/controller.rb:169:in `load_adapter'
        from /usr/lib/ruby/gems/1.9.1/gems/thin-1.3.1/lib/thin/controllers/controller.rb:73:in `start'
        from /usr/lib/ruby/gems/1.9.1/gems/thin-1.3.1/lib/thin/runner.rb:185:in `run_command'
        from /usr/lib/ruby/gems/1.9.1/gems/thin-1.3.1/lib/thin/runner.rb:151:in `run!'
        from /usr/lib/ruby/gems/1.9.1/gems/thin-1.3.1/bin/thin:6:in `<top (required)>'
        from /usr/bin/thin:23:in `load'
        from /usr/bin/thin:23:in `<main>'

I already installed both versions of rack

 gem list | grep rack
rack (1.4.1, 1.3.6)
rack-cache (1.2)
rack-openid (1.3.1)
rack-protection (1.2.0)
rack-ssl (1.3.2)
rack-test (0.6.1)

It should be easy to simply use the newest rack - so could you update the Gemfile and the source so that they're able to work with current versions of rack?

@FooBarWidget
Phusion B.V. member

You're using Thin wrong. You're supposed to add your app server to the Gemfile and run it with 'bundle exec'.

Anyway, with Phusion Passenger you don't have this problem at all. ;)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment