Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 373 lines (300 sloc) 17.125 kb
1857301 @FooBarWidget Bump version number to 2.2.15 and update NEWS.
FooBarWidget authored
1 Release 2.2.15
2 --------------
3
4 * [Apache] Fixed incorrect temp dir cleanup by passenger-status
5 On some systems, running passenger-status could print the following
6 message:
7
8 *** Cleaning stale folder /tmp/passenger.1234
9
10 ...after which Phusion Passenger breaks because that directory is
11 necessary for it to function properly. The cause of this problem
12 has been found and has been fixed.
e795d48 @FooBarWidget Don't be too strict on client Content-Length, it could be wrong because ...
FooBarWidget authored
13 * [Apache] Fixed some upload handling problems
14 Previous versions of Phusion Passenger check whether the size of
15 the received upload data matches the contents of the Content-Length
16 header as received by the client. It turns out that there could
17 be a mismatch e.g. because of mod_deflate input compression, so
18 we can't trust Content-Length anyway and we're being too strict.
19 The check has now been removed.
2265239 @FooBarWidget Install Nginx 0.7.67 and PCRE 8.02 by default.
FooBarWidget authored
20 * [Nginx] Fixed compilation issues with Nginx >= 0.7.66
e973b93 @FooBarWidget Fix compilation issues with Nginx 0.7.66 and make that version the defau...
FooBarWidget authored
21 Thanks to Potamianos Gregory for reporting this issue. Issue #500.
2265239 @FooBarWidget Install Nginx 0.7.67 and PCRE 8.02 by default.
FooBarWidget authored
22 * [Nginx] Default Nginx version changed to 0.7.67
e973b93 @FooBarWidget Fix compilation issues with Nginx 0.7.66 and make that version the defau...
FooBarWidget authored
23 The previous default version was 0.7.65.
946dc2e @FooBarWidget Don't preload popular libraries, it conflicts with Bundler.
FooBarWidget authored
24 * Fixed more Bundler problems
25 Previous versions of Phusion Passenger would preload some popular
26 libraries such as mysql and sqlite3 in order to utilize copy-on-write
27 optimizations better. However this behavior conflicts with Bundler
28 so we've removed it.
1857301 @FooBarWidget Bump version number to 2.2.15 and update NEWS.
FooBarWidget authored
29
30
9c17d46 @FooBarWidget Update NEWS and bump version to 2.2.14
FooBarWidget authored
31 Release 2.2.14
32 --------------
33
34 * Added support for Rubinius
35 Patch contributed by Evan Phoenix.
7413b57 @FooBarWidget Update NEWS.
FooBarWidget authored
36 * Fixed a mistake in the SIGQUIT backtrace message.
37 Patch contributed by Christoffer Sawicki.
73f59cd @FooBarWidget Increase Nginx HelperServer thread stack space on FreeBSD.
FooBarWidget authored
38 * [Nginx] Fix a localtime() crash on FreeBSD
39 This was caused by insufficient stack space for threads. Issue #499.
9c17d46 @FooBarWidget Update NEWS and bump version to 2.2.14
FooBarWidget authored
40
41
30296ca @FooBarWidget Update NEWS, bump version to 2.2.13.
FooBarWidget authored
42 Release 2.2.13
43 --------------
44
45 * Fixed some Rails 3 compatibility issues that were recently introduced.
46 * Fixed a typo that causes config/setup_load_paths.rb not to be loaded
47 correctly.
48
49
38db2e2 @FooBarWidget Bump version to 2.2.12 and update NEWS.
FooBarWidget authored
50 Release 2.2.12
51 --------------
52
53 * Improved Bundler support.
54 Previous versions might not be able to correctly load gems bundled
3fc6071 @FooBarWidget Document Bundler support
FooBarWidget authored
55 by Bundler. We've also documented how our Bundler support works and
56 how to override our support if you need special behavior.
57 Please refer to the Phusion Passenger Users Guide, section
58 "Bundler support".
775e220 @FooBarWidget Fix Nginx "passenger_user_switching off" permission problems: issue #458...
FooBarWidget authored
59 * Worked around some user account handling bugs in Ruby. Issue #192.
5a4d113 @FooBarWidget Update NEWS
FooBarWidget authored
60 * Fixed some Ruby 1.9 tempfile.rb compatibility problems.
73ee6b0 @FooBarWidget Fixed some compilation problems on some ARM Linux platforms.
FooBarWidget authored
61 * Fixed some compilation problems on some ARM Linux platforms.
94f3aa8 @FooBarWidget Suppress bogus error messages when mod_xsendfile is being used
FooBarWidget authored
62 * [Apache] Suppress bogus mod_xsendfile-related error messages.
63 When mod_xsendfile is being used, Phusion Passenger might print
64 bogus error messages like "EPIPE" or "Apache stopped forwarding
65 the backend's response" to the log file. These messages are
66 normal, are harmless and can be safely ignored, but they pollute
67 the log file. So in this release we've added code to suppress
6b39c23 @FooBarWidget Note mod_xsendfile issue number.
FooBarWidget authored
68 these messages when mod_xsendfile is being used. Issue #474.
775e220 @FooBarWidget Fix Nginx "passenger_user_switching off" permission problems: issue #458...
FooBarWidget authored
69 * [Nginx] Fixed "passenger_user_switching off" permission problems
70 If Nginx is running as root and passenger_user_switching is turned
71 off, then Phusion Passenger would fail to initialize because of
72 a permission problem. This has been fixed. Issue #458.
745938a @FooBarWidget Fix Nginx >= 0.8.38 support. Thanks Sergey A. Osokin
FooBarWidget authored
73 * [Nginx] Nginx >= 0.8.38 is now supported.
c271480 @FooBarWidget Default to installing Nginx 0.7.65
FooBarWidget authored
74 Thanks to Sergey A. Osokin for reporting the problem.
75 * [Nginx] passenger-install-nginx-module upgraded
76 It now defaults to installing Nginx 0.7.65 instead of 0.7.64.
38db2e2 @FooBarWidget Bump version to 2.2.12 and update NEWS.
FooBarWidget authored
77
78
119309e @FooBarWidget Update NEWS and bump version to 2.2.11.
FooBarWidget authored
79 Release 2.2.11
80 --------------
81
82 * This release fixes a regression that appeared in 2.2.10 which only
83 affects Apache. When under high load, Apache might freeze and stop
84 responding to requests. It is caused by a race conditions which is
85 why it escaped our last release testing.
86
87 This problem does not affect Nginx; you only have to upgrade if
88 you're using Apache.
89
90 http://groups.google.com/group/phusion-passenger/t/d5bb2f17c8446ea0
91
92
e07dfa0 @FooBarWidget Fix some compilation problems on newer GCC versions. Issue #430.
FooBarWidget authored
93 Release 2.2.10
94 --------------
95
96 * Fixed some Bundler compatibility problems.
97 * Fixed some file descriptor passing problems, which previously
98 could lead to mysterious crashes.
99 * Fixed some compilation problems on newer GCC versions. Issue #430.
84a4bc0 @FooBarWidget Update NEWS.
FooBarWidget authored
100 * Support #size method in rack.input.
e07dfa0 @FooBarWidget Fix some compilation problems on newer GCC versions. Issue #430.
FooBarWidget authored
101
8ec272d @FooBarWidget ...
FooBarWidget authored
102
00e0cbc @FooBarWidget Update NEWS.
FooBarWidget authored
103 Release 2.2.9
104 -------------
105
106 * Fixed compatibility with Rails 3.
107 Actually, previous Phusion Passenger releases were already compatible
108 with Rails 3, depending on the spawn method that would be invoked. Here's
109 the story:
110
111 Since Phusion Passenger 2.2.8, when the file config.ru exists, Phusion
112 Passenger will treat the app as a Rack app, not as a Rails app. This is
113 in contrast to earlier versions which gave Rails detection more priority
114 than Rack detection. Phusion Passenger loads Rack apps and Rails apps in
115 different ways. The Rails loader was not compatible with Rails 3, which
116 is what we've fixed in this release.
117
118 That said, a Rails 3 app would have worked out-of-the-box on Phusion
119 Passenger 2.2.8 as well because Rails 3 apps include a config.ru file
120 by default, causing Phusion Passenger 2.2.8 to use the Rack loader.
121 Earlier versions of Phusion Passenger would just completely bail out
122 because they'd use the Rails loader.
123
c674aab @FooBarWidget Document some more Rails 3 caveats.
FooBarWidget authored
124 That said, with 2.2.9 there are still some caveats:
125 - Smart spawning (the mechanism with which REE's 33% memory reduction
126 is implemented) is *not* supported for Rack apps. This means that if
127 you want to utilize smart spawning with Rails 3, then you should
128 remove your config.ru file.
129 - Rails 3 depends on Rack 1.1.0. You must have Rack 1.1.0 installed as
130 a gem, even if you've bundled it with the gem bundler. This is because
131 Phusion Passenger itself depends on Rack.
132
133 Both of these caveats are temporary. We have plans to solve both of these
134 properly in the future.
4a0e6ab @FooBarWidget Document what's up with gem bundler compatibility.
FooBarWidget authored
135 * What's up with the Gem Bundler?
136 There has been some reports that Phusion Passenger is not compatible with
137 Yehuda Katz's gem bundler (http://github.com/wycats/bundler). This might
138 have been true for an earlier version of the gem bundler, but the latest
139 version seems to work fine. Please note that you need to insert the
140 following snippet in config/preinitializer.rb, as instructed by the gem
141 bundler's README:
142
143 require "#{RAILS_ROOT}/vendor/gems/environment"
144
145 The Rails::Boot monkey patching code as posted at
146 http://yehudakatz.com/2009/11/03/using-the-new-gem-bundler-today/
147 does not seem to be required anymore.
97db507 @FooBarWidget Afer forking, correctly clear ActiveRecord connections other than the de...
FooBarWidget authored
148 * Fixed support for ActiveRecord subclasses that connect to another database.
149 ActiveRecord subclasses that connect to a database other than the default
150 one did not have their connection correctly cleared after forking.
151 This can result in weird errors along the lines of "Lost connection to
152 MySQL server during query". Issue #429.
00e0cbc @FooBarWidget Update NEWS.
FooBarWidget authored
153 * [Nginx] Fixed PCRE URL.
154 passenger-install-nginx-module downloads PCRE 7.8 if PCRE is not already
155 installed. However PCRE 7.8 has been removed from their FTP server,
156 so we've updated the URL to point to the latest version, 8.0.
157
158
adad4c6 @FooBarWidget Add OpenSSL as required dependency for Nginx (fixes issue #422). Update ...
FooBarWidget authored
159 Release 2.2.8
160 -------------
161
162 * [Nginx] Fixed some signal handling problems.
163 Restarting Nginx on OS X with SIGHUP can sometimes take a long time or
164 even fail completely. This is because of some signal handling problems,
165 which have now been fixed.
166 * [Nginx] Added OpenSSL as dependency.
167 OpenSSL is required in order to install Nginx, but this was not checked
168 by passenger-install-nginx-module. As a result,
169 passenger-install-nginx-module fails on e.g. out-of-the-box Ubuntu
170 installations until the user manually installs OpenSSL. Issue #422.
fd82697 @loe Ensure the current URI subject to internal redirects and rewrites is use...
loe authored
171 * [Nginx] Fixed support for internal redirects and subrequests.
172 It is now possible to, for example, point X-Accel-Redirects to Phusion
173 Passenger-served URLs. Patch contributed by W. Andrew Loe III: issue #433.
247a254 @FooBarWidget Fixed crash caused by GnuTLS: issue #391.
FooBarWidget authored
174 * [Apache] Fixed a GnuTLS compatibility issue.
175 mod_gnutls can cause Phusion Passenger to crash because of an unchecked
176 NULL pointer. This problem has now been fixed: issue #391.
78beaf7 @FooBarWidget Fix thread creation on Intel Itanium. Fixes issue #427.
FooBarWidget authored
177 * Fixed thread creation issue on Intel Itanium platforms.
178 This fixes issue #427.
4880487 @FooBarWidget Fixed compilation problems on Linux running on the Renesas SH4 CPU: issu...
FooBarWidget authored
179 * Fixed compilation problems on Linux running on the Renesas SH4 CPU.
180 Patch contributed by iwamatsu: issue #428.
681c216 @FooBarWidget Unvendor Rack and add a workaround for the Ruby 1.9.1 tempfile bug. Fixe...
FooBarWidget authored
181 * The Rack library has been unvendored.
182 The original reason for vendoring was to work around broken Rails
183 applications that explicitly specify Rack as a gem dependency. We've
184 found a better workaround that does not require vendoring Rack.
1a8408f @FooBarWidget Update NEWS.
FooBarWidget authored
185 This also fixes a compatibility problem with Rails 3, because Rails
186 3 depends on a newer Rack version than the one we had vendored.
681c216 @FooBarWidget Unvendor Rack and add a workaround for the Ruby 1.9.1 tempfile bug. Fixe...
FooBarWidget authored
187 Issue #432.
188 * Fixed compatibility with Ruby 1.9.1 patchlevel >= 152
189 Ruby 1.9.1 patchlevel >= 152 has a bug in its tempfile library. If you've
190 seen an error message along the lines of
191
192 *** Exception IOError in Passenger RequestHandler (closed stream)
193
194 then this is a Ruby bug at work. This bug has been fixed in Ruby 1.9.2,
195 but Ruby 1.9.1 still contains this bug. We've added a workaround so that
196 the bug is not triggered with this Ruby version. Issue #432.
adad4c6 @FooBarWidget Add OpenSSL as required dependency for Nginx (fixes issue #422). Update ...
FooBarWidget authored
197
198
979bf12 @FooBarWidget Oops, remove debugging code.
FooBarWidget authored
199 Release 2.2.7
200 -------------
201
202 * Removed forgotten debugging code in passenger-install-apache2-module,
203 which caused it not to compile anything.
204
205
5f3ac2b @FooBarWidget Fix compilation on Solaris: PTHREAD_STACK_MIN might not be a constant, s...
FooBarWidget authored
206 Release 2.2.6
207 -------------
208
5372bdb @FooBarWidget Prevent the Phusion Passenger temp dir from being deleted by /tmp cleane...
FooBarWidget authored
209 * Some /tmp cleaner programs such as tmpwatch try to remove subdirectories
210 in /tmp/passenger.xxx after a while because they think those
211 subdirectories are unused. This could cause Phusion Passenger to
212 malfunction, requiring a web server restart. Measures have now been
213 taken to prevent those tmp cleaner programs from removing anything
214 in /tmp/passenger.xxx. Issue #365.
6418797 @FooBarWidget Update NEWS, bump version number to 2.2.6.
FooBarWidget authored
215 * When autodetecting the application type, Rack is now given more priority
216 than Rails. This allows one to drop a config.ru file in a Rails directory
217 and have it detected as a Rack application instead of a Rails application.
218 Patch contributed by Sam Pohlenz: issue #338.
053150e @FooBarWidget Increase default socket backlog to 1024, SOMAXCONN is usually 128 which ...
FooBarWidget authored
219 * The default socket backlog has been increased from 'SOMAXCONN' (which
220 is 128 on most platforms) to 1024. This should fix most
221 'helper_server.sock failed: Resource temporarily unavailable'
222 errors.
6418797 @FooBarWidget Update NEWS, bump version number to 2.2.6.
FooBarWidget authored
223 * Fixed compilation problems on Solaris. Issue #369 and issue #379.
224 * Fixed crashes on PowerPC.
9444db6 @FooBarWidget Fix a Ruby 1.9 compatibility issue: require stringio in utils.rb. Fixes ...
FooBarWidget authored
225 * Some Ruby 1.9 compatibility fixes. Issue #398.
5967ed7 @FooBarWidget Autodetect Mandriva Linux. Fixes issue #357.
FooBarWidget authored
226 * The installer now displays correct dependency installation instructions
227 for Mandriva Linux.
50750b1 @FooBarWidget Allow specifying the location of apxs2 and apr-config through command li...
FooBarWidget authored
228 * [Apache] The location of the 'apxs' and 'apr-config' commands can now
229 also be passed to the installer through the --apxs-path and
230 --apr-config-path parameters, in addition to the $APXS2 and $APR_CONFIG
231 environment variables. Issue #3.
6418797 @FooBarWidget Update NEWS, bump version number to 2.2.6.
FooBarWidget authored
232 * [Nginx] Various problems that only occur on 64-bit platforms have been fixed.
1f4d88b @FooBarWidget Update NEWS.
FooBarWidget authored
233 * [Nginx] The installer now installs Nginx 0.7.64 by default.
5f3ac2b @FooBarWidget Fix compilation on Solaris: PTHREAD_STACK_MIN might not be a constant, s...
FooBarWidget authored
234
235
7215630 @FooBarWidget Write some release notes.
FooBarWidget authored
236 Release 2.2.5
237 -------------
238
24cc3fa @FooBarWidget Continue writing release notes
FooBarWidget authored
239 * [Apache] Small file uploads are now buffered; fixes potential DoS attack
e66494d @FooBarWidget Update NEWS
FooBarWidget authored
240 Phusion Passenger buffers large file uploads to temp files so that it
24cc3fa @FooBarWidget Continue writing release notes
FooBarWidget authored
241 doesn't block applications while an upload is in progress, but it sent
242 small uploads directly to the application without buffering it. This could
243 result in a potential DoS attack: the client can send many small, incomplete
244 file uploads to the server, and this would block all application processes
245 until a timeout occurs. In order to solve this problem, Phusion Passenger
e66494d @FooBarWidget Update NEWS
FooBarWidget authored
246 now buffers small file uploads in memory. Bug #356.
24cc3fa @FooBarWidget Continue writing release notes
FooBarWidget authored
247
caa9fd7 @FooBarWidget Fix support for mod_rewrite passthrough rules (issue #230) and fix some ...
FooBarWidget authored
248 * [Apache] Fixed support for mod_rewrite passthrough rules
e66494d @FooBarWidget Update NEWS
FooBarWidget authored
249 Mod_rewrite passthrough rules were not properly supported because of a bug
caa9fd7 @FooBarWidget Fix support for mod_rewrite passthrough rules (issue #230) and fix some ...
FooBarWidget authored
250 fix for supporting encoded slashes (%2f) in URLs. Unfortunately, due to
251 bugs/limitations in Apache, we can support either encoded slashes or
252 mod_rewrite passthrough rules, but not both; supporting one will break the
253 other.
254
255 Support for mod_rewrite passthrough rules is now enabled by default; that
256 is, support for encoded slashes is disabled by default. A new configuration
257 option, "PassengerAllowEncodedSlashes", has been added. Turning this option
258 on will enable support for encoded slashes and disable support for
259 mod_rewrite passthrough rules.
260
261 Issue #113 and issue #230.
262
e66494d @FooBarWidget Update NEWS
FooBarWidget authored
263 * [Apache] Added a configuration option for resolving symlinks in the document root path
264 Phusion Passenger 2.2.0 and higher no longer resolves symlinks in
24cc3fa @FooBarWidget Continue writing release notes
FooBarWidget authored
265 the document root path in order to properly support Capistrano-style
266 directory structures. The exact behavior is documented in the Users Guide,
267 section "How Phusion Passenger detects whether a virtual host is a web
268 application".
269
270 However, some people relied on the old behavior. A new configuration option,
271 PassengerResolveSymlinksInDocumentRoot, has been added to allow reverting
272 back to the old behavior.
273
281c020 @FooBarWidget Update NEWS
FooBarWidget authored
274 Patch contributed by Locaweb (http://www.locaweb.com.br/).
275
24cc3fa @FooBarWidget Continue writing release notes
FooBarWidget authored
276 * [Apache] mod_env variables are now also passed through CGI environment headers
277 Prior to version 2.2.3, environment variables set by mod_env are passed to
278 the application as CGI environment headers, not through Ruby's ENV variable.
279 In the last release we introduced support for setting ENV environment
280 variables with mod_env, and got rid of the code for setting CGI environment
281 headers. It turns out that some people relied on the old behavior, we so now
282 environment variables set with mod_env are set in both ENV and in the CGI
283 environment.
284
285 Fixes bug #335.
286
287 * [Apache] Fixed compilation problems on some Linux systems with older versions of Apache
288 If you used to see compilation errors like this:
289
290 ext/apache2/Configuration.cpp:554: error: expected primary-expression before '.' token
291
292 then this version should compile properly.
293
e66494d @FooBarWidget Update NEWS
FooBarWidget authored
294 * [Apache] Fixed I/O timeouts for communication with backend processes
295 Got rid of the code for enforcing I/O timeouts when reading from or writing to
7ec85d7 @FooBarWidget Update release notes
FooBarWidget authored
296 a backend process. This caused more problems than it solved.
297
7215630 @FooBarWidget Write some release notes.
FooBarWidget authored
298 * [Nginx] Support for streaming responses (e.g. Comet or HTTP push)
299 Buffering of backend responses is now disabled. This fixes support for
300 streaming responses, something which the Apache version has supported
301 for a while now. One can generate streaming responses in Ruby on Rails
302 like this:
303
304 render :text => lambda { |response, output|
305 10_000.times do |i|
306 output.write("hello #{i}!\n")
307 end
308 }
309
41160df @FooBarWidget Nginx installer: install 0.7.61 by default.
FooBarWidget authored
310 * [Nginx] Installer now installs Nginx 0.7.61 by default
311 Previously it installed 0.6.37 by default.
312
9e62b29 @FooBarWidget passenger-install-nginx-module: correctly pass --extra-configure-flags f...
FooBarWidget authored
313 * [Nginx] Fixed the installer's --extra-configure-flags flag when combined with --auto-download
314 Arguments passed to --extra-configure-flags were not being passed to the
315 Nginx configure script when --auto-download is given. This has been
316 fixed: bug #349.
317
9ff0e2a @FooBarWidget passenger-install-apache2-module: do not unnecessarily donwload PCRE; mi...
FooBarWidget authored
318 * [Nginx] Fixed unnecessary download of PCRE
319 The installer now checks whether PCRE is installed in /opt/local (e.g.
320 MacPorts) as well before concluding that it isn't installed and going ahead
321 with downloading PCRE.
322
7215630 @FooBarWidget Write some release notes.
FooBarWidget authored
323 * Fixed STDERR capturing
324 While spawning an application, Phusion Passenger captures any output written
325 to STDERR so that it can show them later if the application failed to start.
326 This turns out to be much more difficult than expected, with all kinds of
327 corner cases that can mess up this feature.
24cc3fa @FooBarWidget Continue writing release notes
FooBarWidget authored
328
7215630 @FooBarWidget Write some release notes.
FooBarWidget authored
329 For example, if the Rails log file is not writable, then this can cause
330 Rails to crash with a bizarre and unhelpful error message whenever it tries
331 to write to STDERR:
332
333 /!\ FAILSAFE /!\ Thu Aug 20 14:58:39 +1000 2009
334 Status: 500 Internal Server Error
335 undefined method `[]' for nil:NilClass
336
337 Some applications reopen STDERR to a log file. This didn't work.
338
339 Of all of these problems have been fixed now. (Bug #332)
340
24cc3fa @FooBarWidget Continue writing release notes
FooBarWidget authored
341 * Fixed some bugs in application sources preloading
342 Rails >= 2.2 already preloads the application sources, in which case Phusion
343 Passenger wasn't supposed to perform it's own preloading, but the Rails
344 >= 2.2 detection code was bugged. This has been fixed.
7215630 @FooBarWidget Write some release notes.
FooBarWidget authored
345
24cc3fa @FooBarWidget Continue writing release notes
FooBarWidget authored
346 Rails < 2.2 doesn't preload the application sources by itself, but there
347 should be a certain order with which the sources are preloaded, otherwise
348 preloading could fail in some applications. We now enforce a specific load
349 order: first models, then controllers, then helpers.
c878017 @FooBarWidget Fix compilation problems with some Linux systems with older versions of ...
FooBarWidget authored
350
24cc3fa @FooBarWidget Continue writing release notes
FooBarWidget authored
351 Bug #359.
352
caa9fd7 @FooBarWidget Fix support for mod_rewrite passthrough rules (issue #230) and fix some ...
FooBarWidget authored
353 * Fixed a few bugs in WSGI compliance
354 PATH_INFO is supposed to be set to the request URI, but without the query
355 string and without the base URI. This has been fixed: bug #360.
356
ac777e5 @FooBarWidget Fix some Ruby 1.9-specific crashes caused by encoding issues. Bug #364.
FooBarWidget authored
357 * Fixed some Ruby 1.9-specific crashes caused by encoding issues. Bug #354.
281c020 @FooBarWidget Update NEWS
FooBarWidget authored
358 * Fixed loading of config/environment.rb on Ruby 1.9.2, because Ruby 1.9.2
359 no longer has "." in the default load path. Patch by metaljastix, issue #368.
24cc3fa @FooBarWidget Continue writing release notes
FooBarWidget authored
360 * The Users Guide for Apache now mentions something about correct permissions
361 for application directories.
7215630 @FooBarWidget Write some release notes.
FooBarWidget authored
362 * Fixed compilation problems on IA-64 (bug #118). We also reduced the stack
363 sizes for the threads by half, so Phusion Passenger should use even less
364 virtual memory now.
312b5e1 @FooBarWidget Fix compilation problems on Linux systems with ARM CPU.
FooBarWidget authored
365 * Fixed compilation problems on Linux systems with ARM CPU.
7215630 @FooBarWidget Write some release notes.
FooBarWidget authored
366 * Fixed a few compatibility problems with 64-bit OpenBSD.
367 * Fixed a few typos and minor bugs.
368
369
370 Older releases
371 --------------
5f3ac2b @FooBarWidget Fix compilation on Solaris: PTHREAD_STACK_MIN might not be a constant, s...
FooBarWidget authored
372 Please consult the blog posts on http://blog.phusion.nl/ for the information about older releases.
Something went wrong with that request. Please try again.