Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 623 lines (516 sloc) 29.135 kB
9b2c42f @FooBarWidget Update NEWS
FooBarWidget authored
1 Release 3.0.10
2 --------------
3
4 * [Nginx] Dropped support for Nginx versions older than 1.0.0
5 * [Nginx] Fixed support for Nginx 1.1.8.
6 * [Nginx] New option passenger_max_requests
7 This is equivalent to the PassengerMaxRequests option in the Apache
8 version: Phusion Passenger will automatically shutdown a worker process
9 once it has processed the specified number of requests.
10 Contributed by Paul Kmiec.
11 * [Apache] New option PassengerBufferResponse
12 The Apache version did not buffer responses. This could block the Ruby
13 worker process in case of slow clients. We now enable response buffering
14 by default. It can be turned off through this option. Feature contributed
15 by Ryo Onodera.
16 * Fixed remaining Ruby 1.9.3 compatibility problems
17 We already supported Ruby 1.9.3 since 3.0.8, but due to bugs in Ruby
18 1.9.3's build system Phusion Passenger would fail to detect Ruby 1.9.3
19 features on some systems. Fixes issue #714.
6401566 @FooBarWidget Fix a typo in NEWS
FooBarWidget authored
20 * Fixed a bug in PassengerPreStart
9b2c42f @FooBarWidget Update NEWS
FooBarWidget authored
21 A regression was introduced in 3.0.8, causing the prespawn script to
22 connect to the host name instead of to 127.0.0.1. Fix contributed by
23 Andy Allan.
24 * Fixed various compilation problems.
25 * Fixed some Ruby 1.9 encoding problems.
26 * Fixed some Ruby 1.9.3 deprecation warnings.
27
28
b367914 @FooBarWidget Update NEWS.
FooBarWidget authored
29 Release 3.0.9
30 -------------
31
32 * [Nginx] Fixed a NULL pointer crash that occurs on HTTP/1.0 requests
33 when the Host header isn't given.
34 * Fixed deprecation warnings on RubyGems >= 1.6.
35 * Improved Union Station support stability.
36
37
8a0fd40 @FooBarWidget Update NEWS.
FooBarWidget authored
38 Release 3.0.8
39 -------------
40
41 * [Nginx] Upgraded preferred Nginx version to 1.0.5.
42 * [Nginx] Fixed various compilation problems on various platforms.
43 * [Nginx] We now ensure that SERVER_NAME is equal to HTTP_HOST without the port part.
44 This is needed for Rack compliance. By default Nginx sets SERVER_NAME to
45 whatever is specified in the server_name directive, but that's not necessarily
46 the correct value. This fixes, for example, the use of the 'map' statement
47 in config.ru.
48 * [Nginx] Added the options passenger_buffer_size, passenger_buffers and passenger_busy_buffers_size.
49 These options are similar to proxy_module's similarly named options. You can
50 use these to e.g. increase the maximum header size limit.
51 * [Nginx] passenger_pre_start now supports virtual hosts that listen on Unix domain sockets.
52 * [Apache] Fixed the pcre.h compilation problem.
53 * [Standalone] Fixed 'passenger stop'.
54 It didn't work properly because it kept waiting for 'tail' to exit.
55 We now properly terminate 'tail' as well.
56 * Fixed compatibility with Rake 0.9.
57 * Fixed various Ruby 1.9 compatibility issues.
58 * Various documentation improvements.
59 * New Union Station filter language features.
60 It now supports status codes and response times.
61 Please refer to https://engage.unionstationapp.com/help#filtering
62 for more information.
63
64
33964ce @FooBarWidget Update NEWS
FooBarWidget authored
65 Release 3.0.7
66 -------------
67
68 * Fixed a bug passenger-install-apache2-module. It could crash on
69 some systems due to a typo in the code.
70 * Upgraded preferred Nginx version to 1.0.0.
71 * Phusion Passenger Standalone now pre-starts application processes
72 at startup instead of doing that at the first request.
73 * When sending data to Union Station, the HTTP status code is now also
74 logged.
75 * Various Union Station-related stability improvements.
76 * The Linux OOM killer was previously erroneously disabled for all
77 Phusion Passenger processes, including application processes. The
78 intention was to only disable it for the Watchdog. This has been
79 fixed, and the Watchdog is now the only process for which the OOM
80 killer is disabled.
81 * Fixed some compilation problems on OpenBSD.
82 * Due to a typo, the dependency on file-tail was not entirely removed
83 in 3.0.6. This has now been fixed.
84
85
d697d9f @FooBarWidget Update NEWS and bump version to 3.0.6.
FooBarWidget authored
86 Release 3.0.6
87 -------------
88
89 * Fixed various compilation problems such as XCode 4 support and OpenBSD support.
90 * Fixed various Union Station-related stability issues.
91 * Fixed an issue with host name detection on certain platforms.
92 * Improved error logging in various parts.
93 * The dependency on the file-tail library has been removed.
94 * During installation, check whether /tmp is mounted with 'noexec'.
95 Phusion Passenger's installer relies on /tmp *not* being mounted
96 with 'noexec'. If it is then the installer will now show a helpful
97 error message instead of bailing out in a confusing manner. Users
98 can now tell the installer to use a different directory for storing
99 temporary files by customizing the $TMPDIR environment variable.
100 * Phusion Passenger Standalone can now run Rackup files that are not named 'config.ru'.
101 The filename can be passed through the command line using the -R option.
102
103
c4d41e7 @FooBarWidget Update NEWS.
FooBarWidget authored
104 Release 3.0.5
105 -------------
106
6d413ea @FooBarWidget Rename PassengerAnalytics/passenger_analytics to UnionStationSupport/…
FooBarWidget authored
107 * [Apache] Fixed Union Station process statistics collection
108 Union Station users that are using Apache may notice that no process
109 information show up in Union Station. This is because of a bug in
110 Phusion Passenger's Apache version, which has now been fixed.
111 * [Apache] PassengerAnalytics has been renamed to UnionStationSupport
112 This option has been renamed for consistency reasons.
113 * [Nginx] passenger_analytics has been renamed to union_station_support
114 This option has been renamed for consistency reasons.
65bc50e @FooBarWidget Fix typo.
FooBarWidget authored
115 * Fixed Union Station data sending on older libcurl versions
c4d41e7 @FooBarWidget Update NEWS.
FooBarWidget authored
116 Some Union Station users have reported that their data don't show up.
117 Upon investigation this turned out to be a compatibility with older
118 libcurl versions. Affected systems include all RHEL 5 based systems,
119 such as RHEL 5.5 and CentOS 5.5. We've now fixed compatibility
120 with older libcurl versions.
7e7aa94 @FooBarWidget Update NEWS about Union Station filter language support.
FooBarWidget authored
121 * Added support for the Union Station filter language
122 This language can be used to limit the kind of data that's sent to
123 Union Station. Please read
124 https://engage.unionstationapp.com/help#filtering for details.
c4d41e7 @FooBarWidget Update NEWS.
FooBarWidget authored
125 * Fixed a PassengerMaxPoolSize/passenger_max_pool_size violation bug
126 People who host a lot of different applications on Phusion Passenger
127 may notice that it sometimes spawns more processes than is allowed
128 by PassengerMaxPoolSize/passenger_max_pool_size. This has been fixed.
129
130
4e1e3b8 @FooBarWidget Add release notes for 3.0.4.
FooBarWidget authored
131 Release 3.0.4
132 -------------
133
134 * [Apache] Changed mod_dir workaround hook priority
135 Phusion Passenger temporarily disables mod_dir on all Phusion
136 Passenger-handled requests in order to avoid conflicts. In order to do this
137 it registers some Apache hooks with the APR_HOOK_MIDDLE priority, but it
138 turned out that this breaks some other modules like mod_python. The hook
139 priority has been changed to APR_HOOK_LAST to match mod_dir's hook
140 priorities. Issue reported by Jay Freeman.
141 * Added support for Union Station: http://www.unionstationapp.com/
142 * Some error messages have been improved.
143
144
9962c3a @FooBarWidget Update NEWS and bump version to 3.0.3.
FooBarWidget authored
145 Release 3.0.3
146 -------------
147
148 * [Nginx] Preferred Nginx version upgraded to 0.8.54
149 The previous preferred version was 0.8.53.
150 * PATH_INFO and REQUEST_URI now contain the original escaped URI
151 Phusion Passenger passes the URI, as reported by Apache/Nginx, to
152 application processes through the PATH_INFO and REQUEST_URI variables.
153 These variables are supposed to contain the original, unescaped URI, e.g.
154 /clubs/%C3%BC. Both Apache and Nginx thought that it would be a good idea
155 to unescape the URI before passing it to modules like Phusion Passenger,
156 thereby causing PATH_INFO and REQUEST_URI to contain the unescaped URI,
157 e.g. /clubs/ü. This causes all sorts of encoding problems. We now manually
158 re-escape the URI when setting PATH_INFO and REQUEST_URI. Issue #404.
159 * The installer no longer detects directories as potential commands
160 Previously the installer would look in $PATH for everything that's
161 executable, including directories. If one has /usr/lib in $PATH
162 and a directory /usr/lib/gcc exists then the installer would recognize
163 /usr/lib/gcc as the compiler. We now explicitly check whether the item
164 is also a file.
165 * PseudoIO now responds to #to_io
166 Phusion Passenger sets STDERR to a PseudoIO object in order to capture
167 anything written to STDERR during application startup. This breaks
168 some libraries which expect STDERR to respond to #to_io. This has now
169 been fixed. Issue #607.
170 * Fixed various other minor bugs
171 See the git commit log for details.
172
173
5b30a81 @FooBarWidget Update NEWS.
FooBarWidget authored
174 Release 3.0.2
175 -------------
176
177 * [Nginx] Fixed compilation problems
178 The Nginx compilation process was broken due to not correctly reverting
179 the working directory of the Nginx configure script. This has been fixed:
180 issue #595.
60e4cca @FooBarWidget [Nginx] Fix crash if passenger_root refers to a nonexistant directory.
FooBarWidget authored
181 * [Nginx] Fixed crash if passenger_root refers to a nonexistant directory
182 Issue #599.
5b30a81 @FooBarWidget Update NEWS.
FooBarWidget authored
183 * Fixed compilation problems on NetBSD
184 There was a typo in a NetBSD-specific fcntl() call. It also turns out that
185 NetBSD doesn't support some ISO C99 math functions like llroundl(); this
186 has been worked around by using other functions. Issue #593.
9a81106 @FooBarWidget Fixed file descriptor closing issues on FreeBSD: issue #597.
FooBarWidget authored
187 * Fixed file descriptor closing issues on FreeBSD
188 Phusion Passenger child processes didn't correct close file descriptors
189 on FreeBSD because it queries /dev/fd to do that. On FreeBSD /dev/fd
190 only returns meaningful results if fdescfs is mounted, which it isn't
191 by default. Issue #597.
5b30a81 @FooBarWidget Update NEWS.
FooBarWidget authored
192
193
c665f9f @FooBarWidget Update NEWS.
FooBarWidget authored
194 Release 3.0.1
195 -------------
196
ccef2aa @FooBarWidget Introduce a release mode which can compile Phusion Passenger more qui…
FooBarWidget authored
197 * MUCH faster compilation
198 We've applied code aggregation techniques, allowing Phusion Passenger
199 to be compiled much quicker now. For example, compiling the Nginx
d0b8b61 @FooBarWidget Document Apache module compilation speedup.
FooBarWidget authored
200 component (not Nginx itself) on a MacBook Pro now takes only 29
201 seconds instead of 51 seconds, an improvement of 75%! Compiling the
202 Apache module on a slower Dell Inspiron now takes 39 seconds instead of
203 1 minute 22 seconds, or 110% faster!
c665f9f @FooBarWidget Update NEWS.
FooBarWidget authored
204 * Fixed malfunction after web server restart
205 On Linux systems that have a non-standard filesystem on /tmp, Phusion
206 Passenger could malfunction after restarting the web server because of
207 a bug that's only triggered on certain filesystems. Issue #569.
208 * Boost upgraded to version 1.44.0.
209 We were on 1.42.0.
210 * Much improved startup error messages
211 Phusion Passenger performs many extensive checks during startup to ensure
212 integrity. However the error message in some situation could be vague.
213 These startup error messages have now been improved dramatically, so that
214 if something goes wrong during startup you will now more likely know why.
215 * Curl < 7.12.1 is now supported
216 The previous version fails to compile with Curl versions earlier than
534950b @FooBarWidget Fix a potential compilation warning and update NEWS.
FooBarWidget authored
217 7.12.1. Issue #556.
c665f9f @FooBarWidget Update NEWS.
FooBarWidget authored
218 * passenger-make-enterprisey fixed
219 This is the command that people can run after donating. It allows people
220 to slightly modify Phusion Passenger's display name as a joke. In 3.0.0 it
221 was broken because of a typo. This has been fixed.
51bf666 @FooBarWidget Get rid of passenger-stress-test.
FooBarWidget authored
222 * Removed passenger-stress-test
223 This tool was used during the early life of Phusion Passenger for stress
224 testing websites. Its performance has never been very good and there are
225 much better tools for stress testing, so this tool has now been removed.
c665f9f @FooBarWidget Update NEWS.
FooBarWidget authored
226 * [Apache] RailsEnv and RackEnv configuration options are now equivalent
227 In previous versions, RailsEnv only had effect on Rails 1 and Rails 2 apps
228 while RackEnv only had effect on Rack apps. Because Rails 3 apps are
229 considered Rack apps, setting RailsEnv had no effect on Rails 3 apps.
230 Because this is confusing to users, we've now made RailsEnv and RackEnv
534950b @FooBarWidget Fix a potential compilation warning and update NEWS.
FooBarWidget authored
231 equivalent. Issue #579.
c665f9f @FooBarWidget Update NEWS.
FooBarWidget authored
232 * [Nginx] Fixed compilation problems on systems with unpowerful shells
0999e3d @FooBarWidget Fix typo.
FooBarWidget authored
233 Most notably Solaris. Its default shell does not support some basic
c665f9f @FooBarWidget Update NEWS.
FooBarWidget authored
234 constructs that we used in the Nginx configure script.
235 * [Nginx] Upgraded default Nginx version to to 0.8.53
236 The previous default was 0.8.52.
5e7722b @FooBarWidget passenger_enabled now only accepts 'on' or 'off' values.
FooBarWidget authored
237 * [Nginx] passenger_enabled now only accepts 'on' or 'off' values
238 Previously it would recognize any value not equal to 'on' as meaning
239 'off'. This caused confusion among users who thought they could also
240 specify 'true', so we now throw a proper error if the value is
241 unrecognized. Fixes issue #583.
c665f9f @FooBarWidget Update NEWS.
FooBarWidget authored
242
243
8243d6d @FooBarWidget Update NEWS
FooBarWidget authored
244 Release 3.0.0
245 -------------
f75f12f @FooBarWidget Bump version to 2.9.4 and update NEWS.
FooBarWidget authored
246
3d6f5ef @FooBarWidget Update NEWS
FooBarWidget authored
247 This is a major release with many changes. Please read our blog for details.
9e15dbd @FooBarWidget Begin porting passenger-status to the new infrastructure.
FooBarWidget authored
248
20005e1 @FooBarWidget Merge branch 'master' into refactoring
FooBarWidget authored
249
1857301 @FooBarWidget Bump version number to 2.2.15 and update NEWS.
FooBarWidget authored
250 Release 2.2.15
251 --------------
252
253 * [Apache] Fixed incorrect temp dir cleanup by passenger-status
254 On some systems, running passenger-status could print the following
255 message:
256
257 *** Cleaning stale folder /tmp/passenger.1234
258
259 ...after which Phusion Passenger breaks because that directory is
260 necessary for it to function properly. The cause of this problem
261 has been found and has been fixed.
e795d48 @FooBarWidget Don't be too strict on client Content-Length, it could be wrong becau…
FooBarWidget authored
262 * [Apache] Fixed some upload handling problems
263 Previous versions of Phusion Passenger check whether the size of
264 the received upload data matches the contents of the Content-Length
265 header as received by the client. It turns out that there could
266 be a mismatch e.g. because of mod_deflate input compression, so
267 we can't trust Content-Length anyway and we're being too strict.
268 The check has now been removed.
2265239 @FooBarWidget Install Nginx 0.7.67 and PCRE 8.02 by default.
FooBarWidget authored
269 * [Nginx] Fixed compilation issues with Nginx >= 0.7.66
e973b93 @FooBarWidget Fix compilation issues with Nginx 0.7.66 and make that version the de…
FooBarWidget authored
270 Thanks to Potamianos Gregory for reporting this issue. Issue #500.
2265239 @FooBarWidget Install Nginx 0.7.67 and PCRE 8.02 by default.
FooBarWidget authored
271 * [Nginx] Default Nginx version changed to 0.7.67
e973b93 @FooBarWidget Fix compilation issues with Nginx 0.7.66 and make that version the de…
FooBarWidget authored
272 The previous default version was 0.7.65.
946dc2e @FooBarWidget Don't preload popular libraries, it conflicts with Bundler.
FooBarWidget authored
273 * Fixed more Bundler problems
274 Previous versions of Phusion Passenger would preload some popular
275 libraries such as mysql and sqlite3 in order to utilize copy-on-write
276 optimizations better. However this behavior conflicts with Bundler
277 so we've removed it.
1857301 @FooBarWidget Bump version number to 2.2.15 and update NEWS.
FooBarWidget authored
278
279
9c17d46 @FooBarWidget Update NEWS and bump version to 2.2.14
FooBarWidget authored
280 Release 2.2.14
281 --------------
282
283 * Added support for Rubinius
284 Patch contributed by Evan Phoenix.
7413b57 @FooBarWidget Update NEWS.
FooBarWidget authored
285 * Fixed a mistake in the SIGQUIT backtrace message.
286 Patch contributed by Christoffer Sawicki.
73f59cd @FooBarWidget Increase Nginx HelperServer thread stack space on FreeBSD.
FooBarWidget authored
287 * [Nginx] Fix a localtime() crash on FreeBSD
288 This was caused by insufficient stack space for threads. Issue #499.
9c17d46 @FooBarWidget Update NEWS and bump version to 2.2.14
FooBarWidget authored
289
290
30296ca @FooBarWidget Update NEWS, bump version to 2.2.13.
FooBarWidget authored
291 Release 2.2.13
292 --------------
293
294 * Fixed some Rails 3 compatibility issues that were recently introduced.
295 * Fixed a typo that causes config/setup_load_paths.rb not to be loaded
296 correctly.
297
298
38db2e2 @FooBarWidget Bump version to 2.2.12 and update NEWS.
FooBarWidget authored
299 Release 2.2.12
300 --------------
301
302 * Improved Bundler support.
303 Previous versions might not be able to correctly load gems bundled
3fc6071 @FooBarWidget Document Bundler support
FooBarWidget authored
304 by Bundler. We've also documented how our Bundler support works and
305 how to override our support if you need special behavior.
306 Please refer to the Phusion Passenger Users Guide, section
307 "Bundler support".
775e220 @FooBarWidget Fix Nginx "passenger_user_switching off" permission problems: issue #…
FooBarWidget authored
308 * Worked around some user account handling bugs in Ruby. Issue #192.
5a4d113 @FooBarWidget Update NEWS
FooBarWidget authored
309 * Fixed some Ruby 1.9 tempfile.rb compatibility problems.
73ee6b0 @FooBarWidget Fixed some compilation problems on some ARM Linux platforms.
FooBarWidget authored
310 * Fixed some compilation problems on some ARM Linux platforms.
94f3aa8 @FooBarWidget Suppress bogus error messages when mod_xsendfile is being used
FooBarWidget authored
311 * [Apache] Suppress bogus mod_xsendfile-related error messages.
312 When mod_xsendfile is being used, Phusion Passenger might print
313 bogus error messages like "EPIPE" or "Apache stopped forwarding
314 the backend's response" to the log file. These messages are
315 normal, are harmless and can be safely ignored, but they pollute
316 the log file. So in this release we've added code to suppress
6b39c23 @FooBarWidget Note mod_xsendfile issue number.
FooBarWidget authored
317 these messages when mod_xsendfile is being used. Issue #474.
775e220 @FooBarWidget Fix Nginx "passenger_user_switching off" permission problems: issue #…
FooBarWidget authored
318 * [Nginx] Fixed "passenger_user_switching off" permission problems
319 If Nginx is running as root and passenger_user_switching is turned
320 off, then Phusion Passenger would fail to initialize because of
321 a permission problem. This has been fixed. Issue #458.
745938a @FooBarWidget Fix Nginx >= 0.8.38 support. Thanks Sergey A. Osokin
FooBarWidget authored
322 * [Nginx] Nginx >= 0.8.38 is now supported.
c271480 @FooBarWidget Default to installing Nginx 0.7.65
FooBarWidget authored
323 Thanks to Sergey A. Osokin for reporting the problem.
324 * [Nginx] passenger-install-nginx-module upgraded
325 It now defaults to installing Nginx 0.7.65 instead of 0.7.64.
38db2e2 @FooBarWidget Bump version to 2.2.12 and update NEWS.
FooBarWidget authored
326
327
119309e @FooBarWidget Update NEWS and bump version to 2.2.11.
FooBarWidget authored
328 Release 2.2.11
329 --------------
330
331 * This release fixes a regression that appeared in 2.2.10 which only
332 affects Apache. When under high load, Apache might freeze and stop
6d961e7 @FooBarWidget Merge branch 'master' into refactoring
FooBarWidget authored
333 responding to requests. It is caused by a race condition which is
119309e @FooBarWidget Update NEWS and bump version to 2.2.11.
FooBarWidget authored
334 why it escaped our last release testing.
335
336 This problem does not affect Nginx; you only have to upgrade if
337 you're using Apache.
338
339 http://groups.google.com/group/phusion-passenger/t/d5bb2f17c8446ea0
340
341
e07dfa0 @FooBarWidget Fix some compilation problems on newer GCC versions. Issue #430.
FooBarWidget authored
342 Release 2.2.10
343 --------------
344
345 * Fixed some Bundler compatibility problems.
346 * Fixed some file descriptor passing problems, which previously
347 could lead to mysterious crashes.
348 * Fixed some compilation problems on newer GCC versions. Issue #430.
84a4bc0 @FooBarWidget Update NEWS.
FooBarWidget authored
349 * Support #size method in rack.input.
e07dfa0 @FooBarWidget Fix some compilation problems on newer GCC versions. Issue #430.
FooBarWidget authored
350
351
2853379 @FooBarWidget Merge branch 'master' into refactoring
FooBarWidget authored
352
00e0cbc @FooBarWidget Update NEWS.
FooBarWidget authored
353 Release 2.2.9
354 -------------
355
356 * Fixed compatibility with Rails 3.
357 Actually, previous Phusion Passenger releases were already compatible
358 with Rails 3, depending on the spawn method that would be invoked. Here's
359 the story:
360
361 Since Phusion Passenger 2.2.8, when the file config.ru exists, Phusion
362 Passenger will treat the app as a Rack app, not as a Rails app. This is
363 in contrast to earlier versions which gave Rails detection more priority
364 than Rack detection. Phusion Passenger loads Rack apps and Rails apps in
365 different ways. The Rails loader was not compatible with Rails 3, which
366 is what we've fixed in this release.
367
368 That said, a Rails 3 app would have worked out-of-the-box on Phusion
369 Passenger 2.2.8 as well because Rails 3 apps include a config.ru file
370 by default, causing Phusion Passenger 2.2.8 to use the Rack loader.
371 Earlier versions of Phusion Passenger would just completely bail out
372 because they'd use the Rails loader.
373
c674aab @FooBarWidget Document some more Rails 3 caveats.
FooBarWidget authored
374 That said, with 2.2.9 there are still some caveats:
375 - Smart spawning (the mechanism with which REE's 33% memory reduction
376 is implemented) is *not* supported for Rack apps. This means that if
377 you want to utilize smart spawning with Rails 3, then you should
378 remove your config.ru file.
379 - Rails 3 depends on Rack 1.1.0. You must have Rack 1.1.0 installed as
380 a gem, even if you've bundled it with the gem bundler. This is because
381 Phusion Passenger itself depends on Rack.
382
383 Both of these caveats are temporary. We have plans to solve both of these
384 properly in the future.
4a0e6ab @FooBarWidget Document what's up with gem bundler compatibility.
FooBarWidget authored
385 * What's up with the Gem Bundler?
386 There has been some reports that Phusion Passenger is not compatible with
387 Yehuda Katz's gem bundler (http://github.com/wycats/bundler). This might
388 have been true for an earlier version of the gem bundler, but the latest
389 version seems to work fine. Please note that you need to insert the
390 following snippet in config/preinitializer.rb, as instructed by the gem
391 bundler's README:
392
393 require "#{RAILS_ROOT}/vendor/gems/environment"
394
395 The Rails::Boot monkey patching code as posted at
396 http://yehudakatz.com/2009/11/03/using-the-new-gem-bundler-today/
397 does not seem to be required anymore.
97db507 @FooBarWidget Afer forking, correctly clear ActiveRecord connections other than the…
FooBarWidget authored
398 * Fixed support for ActiveRecord subclasses that connect to another database.
399 ActiveRecord subclasses that connect to a database other than the default
400 one did not have their connection correctly cleared after forking.
401 This can result in weird errors along the lines of "Lost connection to
402 MySQL server during query". Issue #429.
00e0cbc @FooBarWidget Update NEWS.
FooBarWidget authored
403 * [Nginx] Fixed PCRE URL.
404 passenger-install-nginx-module downloads PCRE 7.8 if PCRE is not already
405 installed. However PCRE 7.8 has been removed from their FTP server,
406 so we've updated the URL to point to the latest version, 8.0.
407
408
adad4c6 @FooBarWidget Add OpenSSL as required dependency for Nginx (fixes issue #422). Upda…
FooBarWidget authored
409 Release 2.2.8
410 -------------
411
412 * [Nginx] Fixed some signal handling problems.
413 Restarting Nginx on OS X with SIGHUP can sometimes take a long time or
414 even fail completely. This is because of some signal handling problems,
415 which have now been fixed.
416 * [Nginx] Added OpenSSL as dependency.
417 OpenSSL is required in order to install Nginx, but this was not checked
418 by passenger-install-nginx-module. As a result,
419 passenger-install-nginx-module fails on e.g. out-of-the-box Ubuntu
420 installations until the user manually installs OpenSSL. Issue #422.
fd82697 @loe Ensure the current URI subject to internal redirects and rewrites is …
loe authored
421 * [Nginx] Fixed support for internal redirects and subrequests.
422 It is now possible to, for example, point X-Accel-Redirects to Phusion
423 Passenger-served URLs. Patch contributed by W. Andrew Loe III: issue #433.
247a254 @FooBarWidget Fixed crash caused by GnuTLS: issue #391.
FooBarWidget authored
424 * [Apache] Fixed a GnuTLS compatibility issue.
425 mod_gnutls can cause Phusion Passenger to crash because of an unchecked
426 NULL pointer. This problem has now been fixed: issue #391.
78beaf7 @FooBarWidget Fix thread creation on Intel Itanium. Fixes issue #427.
FooBarWidget authored
427 * Fixed thread creation issue on Intel Itanium platforms.
428 This fixes issue #427.
4880487 @FooBarWidget Fixed compilation problems on Linux running on the Renesas SH4 CPU: i…
FooBarWidget authored
429 * Fixed compilation problems on Linux running on the Renesas SH4 CPU.
430 Patch contributed by iwamatsu: issue #428.
681c216 @FooBarWidget Unvendor Rack and add a workaround for the Ruby 1.9.1 tempfile bug. F…
FooBarWidget authored
431 * The Rack library has been unvendored.
432 The original reason for vendoring was to work around broken Rails
433 applications that explicitly specify Rack as a gem dependency. We've
434 found a better workaround that does not require vendoring Rack.
1a8408f @FooBarWidget Update NEWS.
FooBarWidget authored
435 This also fixes a compatibility problem with Rails 3, because Rails
436 3 depends on a newer Rack version than the one we had vendored.
681c216 @FooBarWidget Unvendor Rack and add a workaround for the Ruby 1.9.1 tempfile bug. F…
FooBarWidget authored
437 Issue #432.
438 * Fixed compatibility with Ruby 1.9.1 patchlevel >= 152
439 Ruby 1.9.1 patchlevel >= 152 has a bug in its tempfile library. If you've
440 seen an error message along the lines of
441
442 *** Exception IOError in Passenger RequestHandler (closed stream)
443
444 then this is a Ruby bug at work. This bug has been fixed in Ruby 1.9.2,
445 but Ruby 1.9.1 still contains this bug. We've added a workaround so that
446 the bug is not triggered with this Ruby version. Issue #432.
adad4c6 @FooBarWidget Add OpenSSL as required dependency for Nginx (fixes issue #422). Upda…
FooBarWidget authored
447
448
979bf12 @FooBarWidget Oops, remove debugging code.
FooBarWidget authored
449 Release 2.2.7
450 -------------
451
452 * Removed forgotten debugging code in passenger-install-apache2-module,
453 which caused it not to compile anything.
454
455
5f3ac2b @FooBarWidget Fix compilation on Solaris: PTHREAD_STACK_MIN might not be a constant…
FooBarWidget authored
456 Release 2.2.6
457 -------------
458
5372bdb @FooBarWidget Prevent the Phusion Passenger temp dir from being deleted by /tmp cle…
FooBarWidget authored
459 * Some /tmp cleaner programs such as tmpwatch try to remove subdirectories
460 in /tmp/passenger.xxx after a while because they think those
461 subdirectories are unused. This could cause Phusion Passenger to
462 malfunction, requiring a web server restart. Measures have now been
463 taken to prevent those tmp cleaner programs from removing anything
464 in /tmp/passenger.xxx. Issue #365.
6418797 @FooBarWidget Update NEWS, bump version number to 2.2.6.
FooBarWidget authored
465 * When autodetecting the application type, Rack is now given more priority
466 than Rails. This allows one to drop a config.ru file in a Rails directory
467 and have it detected as a Rack application instead of a Rails application.
468 Patch contributed by Sam Pohlenz: issue #338.
053150e @FooBarWidget Increase default socket backlog to 1024, SOMAXCONN is usually 128 whi…
FooBarWidget authored
469 * The default socket backlog has been increased from 'SOMAXCONN' (which
470 is 128 on most platforms) to 1024. This should fix most
471 'helper_server.sock failed: Resource temporarily unavailable'
472 errors.
6418797 @FooBarWidget Update NEWS, bump version number to 2.2.6.
FooBarWidget authored
473 * Fixed compilation problems on Solaris. Issue #369 and issue #379.
474 * Fixed crashes on PowerPC.
9444db6 @FooBarWidget Fix a Ruby 1.9 compatibility issue: require stringio in utils.rb. Fix…
FooBarWidget authored
475 * Some Ruby 1.9 compatibility fixes. Issue #398.
5967ed7 @FooBarWidget Autodetect Mandriva Linux. Fixes issue #357.
FooBarWidget authored
476 * The installer now displays correct dependency installation instructions
477 for Mandriva Linux.
50750b1 @FooBarWidget Allow specifying the location of apxs2 and apr-config through command…
FooBarWidget authored
478 * [Apache] The location of the 'apxs' and 'apr-config' commands can now
479 also be passed to the installer through the --apxs-path and
480 --apr-config-path parameters, in addition to the $APXS2 and $APR_CONFIG
481 environment variables. Issue #3.
6418797 @FooBarWidget Update NEWS, bump version number to 2.2.6.
FooBarWidget authored
482 * [Nginx] Various problems that only occur on 64-bit platforms have been fixed.
1f4d88b @FooBarWidget Update NEWS.
FooBarWidget authored
483 * [Nginx] The installer now installs Nginx 0.7.64 by default.
5f3ac2b @FooBarWidget Fix compilation on Solaris: PTHREAD_STACK_MIN might not be a constant…
FooBarWidget authored
484
485
7215630 @FooBarWidget Write some release notes.
FooBarWidget authored
486 Release 2.2.5
487 -------------
488
24cc3fa @FooBarWidget Continue writing release notes
FooBarWidget authored
489 * [Apache] Small file uploads are now buffered; fixes potential DoS attack
e66494d @FooBarWidget Update NEWS
FooBarWidget authored
490 Phusion Passenger buffers large file uploads to temp files so that it
24cc3fa @FooBarWidget Continue writing release notes
FooBarWidget authored
491 doesn't block applications while an upload is in progress, but it sent
492 small uploads directly to the application without buffering it. This could
493 result in a potential DoS attack: the client can send many small, incomplete
494 file uploads to the server, and this would block all application processes
495 until a timeout occurs. In order to solve this problem, Phusion Passenger
e66494d @FooBarWidget Update NEWS
FooBarWidget authored
496 now buffers small file uploads in memory. Bug #356.
24cc3fa @FooBarWidget Continue writing release notes
FooBarWidget authored
497
caa9fd7 @FooBarWidget Fix support for mod_rewrite passthrough rules (issue #230) and fix so…
FooBarWidget authored
498 * [Apache] Fixed support for mod_rewrite passthrough rules
e66494d @FooBarWidget Update NEWS
FooBarWidget authored
499 Mod_rewrite passthrough rules were not properly supported because of a bug
caa9fd7 @FooBarWidget Fix support for mod_rewrite passthrough rules (issue #230) and fix so…
FooBarWidget authored
500 fix for supporting encoded slashes (%2f) in URLs. Unfortunately, due to
501 bugs/limitations in Apache, we can support either encoded slashes or
502 mod_rewrite passthrough rules, but not both; supporting one will break the
503 other.
504
505 Support for mod_rewrite passthrough rules is now enabled by default; that
506 is, support for encoded slashes is disabled by default. A new configuration
507 option, "PassengerAllowEncodedSlashes", has been added. Turning this option
508 on will enable support for encoded slashes and disable support for
509 mod_rewrite passthrough rules.
510
511 Issue #113 and issue #230.
512
e66494d @FooBarWidget Update NEWS
FooBarWidget authored
513 * [Apache] Added a configuration option for resolving symlinks in the document root path
514 Phusion Passenger 2.2.0 and higher no longer resolves symlinks in
24cc3fa @FooBarWidget Continue writing release notes
FooBarWidget authored
515 the document root path in order to properly support Capistrano-style
516 directory structures. The exact behavior is documented in the Users Guide,
517 section "How Phusion Passenger detects whether a virtual host is a web
518 application".
519
520 However, some people relied on the old behavior. A new configuration option,
521 PassengerResolveSymlinksInDocumentRoot, has been added to allow reverting
522 back to the old behavior.
523
281c020 @FooBarWidget Update NEWS
FooBarWidget authored
524 Patch contributed by Locaweb (http://www.locaweb.com.br/).
525
24cc3fa @FooBarWidget Continue writing release notes
FooBarWidget authored
526 * [Apache] mod_env variables are now also passed through CGI environment headers
527 Prior to version 2.2.3, environment variables set by mod_env are passed to
528 the application as CGI environment headers, not through Ruby's ENV variable.
529 In the last release we introduced support for setting ENV environment
530 variables with mod_env, and got rid of the code for setting CGI environment
531 headers. It turns out that some people relied on the old behavior, we so now
532 environment variables set with mod_env are set in both ENV and in the CGI
533 environment.
534
535 Fixes bug #335.
536
537 * [Apache] Fixed compilation problems on some Linux systems with older versions of Apache
538 If you used to see compilation errors like this:
539
540 ext/apache2/Configuration.cpp:554: error: expected primary-expression before '.' token
541
542 then this version should compile properly.
543
e66494d @FooBarWidget Update NEWS
FooBarWidget authored
544 * [Apache] Fixed I/O timeouts for communication with backend processes
545 Got rid of the code for enforcing I/O timeouts when reading from or writing to
7ec85d7 @FooBarWidget Update release notes
FooBarWidget authored
546 a backend process. This caused more problems than it solved.
547
7215630 @FooBarWidget Write some release notes.
FooBarWidget authored
548 * [Nginx] Support for streaming responses (e.g. Comet or HTTP push)
549 Buffering of backend responses is now disabled. This fixes support for
550 streaming responses, something which the Apache version has supported
551 for a while now. One can generate streaming responses in Ruby on Rails
552 like this:
553
554 render :text => lambda { |response, output|
555 10_000.times do |i|
556 output.write("hello #{i}!\n")
557 end
558 }
559
41160df @FooBarWidget Nginx installer: install 0.7.61 by default.
FooBarWidget authored
560 * [Nginx] Installer now installs Nginx 0.7.61 by default
561 Previously it installed 0.6.37 by default.
562
9e62b29 @FooBarWidget passenger-install-nginx-module: correctly pass --extra-configure-flag…
FooBarWidget authored
563 * [Nginx] Fixed the installer's --extra-configure-flags flag when combined with --auto-download
564 Arguments passed to --extra-configure-flags were not being passed to the
565 Nginx configure script when --auto-download is given. This has been
566 fixed: bug #349.
567
9ff0e2a @FooBarWidget passenger-install-apache2-module: do not unnecessarily donwload PCRE;…
FooBarWidget authored
568 * [Nginx] Fixed unnecessary download of PCRE
569 The installer now checks whether PCRE is installed in /opt/local (e.g.
570 MacPorts) as well before concluding that it isn't installed and going ahead
571 with downloading PCRE.
572
7215630 @FooBarWidget Write some release notes.
FooBarWidget authored
573 * Fixed STDERR capturing
574 While spawning an application, Phusion Passenger captures any output written
575 to STDERR so that it can show them later if the application failed to start.
576 This turns out to be much more difficult than expected, with all kinds of
577 corner cases that can mess up this feature.
24cc3fa @FooBarWidget Continue writing release notes
FooBarWidget authored
578
7215630 @FooBarWidget Write some release notes.
FooBarWidget authored
579 For example, if the Rails log file is not writable, then this can cause
580 Rails to crash with a bizarre and unhelpful error message whenever it tries
581 to write to STDERR:
582
583 /!\ FAILSAFE /!\ Thu Aug 20 14:58:39 +1000 2009
584 Status: 500 Internal Server Error
585 undefined method `[]' for nil:NilClass
586
587 Some applications reopen STDERR to a log file. This didn't work.
588
589 Of all of these problems have been fixed now. (Bug #332)
590
24cc3fa @FooBarWidget Continue writing release notes
FooBarWidget authored
591 * Fixed some bugs in application sources preloading
592 Rails >= 2.2 already preloads the application sources, in which case Phusion
593 Passenger wasn't supposed to perform it's own preloading, but the Rails
594 >= 2.2 detection code was bugged. This has been fixed.
7215630 @FooBarWidget Write some release notes.
FooBarWidget authored
595
24cc3fa @FooBarWidget Continue writing release notes
FooBarWidget authored
596 Rails < 2.2 doesn't preload the application sources by itself, but there
597 should be a certain order with which the sources are preloaded, otherwise
598 preloading could fail in some applications. We now enforce a specific load
599 order: first models, then controllers, then helpers.
c878017 @FooBarWidget Fix compilation problems with some Linux systems with older versions …
FooBarWidget authored
600
24cc3fa @FooBarWidget Continue writing release notes
FooBarWidget authored
601 Bug #359.
602
caa9fd7 @FooBarWidget Fix support for mod_rewrite passthrough rules (issue #230) and fix so…
FooBarWidget authored
603 * Fixed a few bugs in WSGI compliance
604 PATH_INFO is supposed to be set to the request URI, but without the query
605 string and without the base URI. This has been fixed: bug #360.
606
ac777e5 @FooBarWidget Fix some Ruby 1.9-specific crashes caused by encoding issues. Bug #364.
FooBarWidget authored
607 * Fixed some Ruby 1.9-specific crashes caused by encoding issues. Bug #354.
281c020 @FooBarWidget Update NEWS
FooBarWidget authored
608 * Fixed loading of config/environment.rb on Ruby 1.9.2, because Ruby 1.9.2
609 no longer has "." in the default load path. Patch by metaljastix, issue #368.
24cc3fa @FooBarWidget Continue writing release notes
FooBarWidget authored
610 * The Users Guide for Apache now mentions something about correct permissions
611 for application directories.
7215630 @FooBarWidget Write some release notes.
FooBarWidget authored
612 * Fixed compilation problems on IA-64 (bug #118). We also reduced the stack
613 sizes for the threads by half, so Phusion Passenger should use even less
614 virtual memory now.
312b5e1 @FooBarWidget Fix compilation problems on Linux systems with ARM CPU.
FooBarWidget authored
615 * Fixed compilation problems on Linux systems with ARM CPU.
7215630 @FooBarWidget Write some release notes.
FooBarWidget authored
616 * Fixed a few compatibility problems with 64-bit OpenBSD.
617 * Fixed a few typos and minor bugs.
618
619
620 Older releases
621 --------------
9e15dbd @FooBarWidget Begin porting passenger-status to the new infrastructure.
FooBarWidget authored
622 Please consult the blog posts on http://blog.phusion.nl/ for the information about older releases.
Something went wrong with that request. Please try again.