Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 641 lines (528 sloc) 29.665 kB
7031b2d @FooBarWidget Fix compatibility with Nginx < 1.0.10.
FooBarWidget authored
1 Release 3.0.12
2 --------------
3
4 * Fixed compatibility with Nginx < 1.0.10.
5
6
7b054dc @FooBarWidget Bump version to 3.0.11 and update NEWS.
FooBarWidget authored
7 Release 3.0.11
8 --------------
9
10 * Fixed a compilation problem on platforms without alloca.h, such as FreeBSD 7.
ff9f2b8 @FooBarWidget Fix a typo
FooBarWidget authored
11 * Improved performance and solved some warnings on Xen systems by compiling
1e9aee4 @FooBarWidget Update NEWS
FooBarWidget authored
12 with `-mno-tls-direct-seg-refs`. Patch contributed by Michał Pokrywka.
7b054dc @FooBarWidget Bump version to 3.0.11 and update NEWS.
FooBarWidget authored
13
14
9b2c42f @FooBarWidget Update NEWS
FooBarWidget authored
15 Release 3.0.10
16 --------------
17
18 * [Nginx] Dropped support for Nginx versions older than 1.0.0
b6e4cd1 @FooBarWidget Update NEWS
FooBarWidget authored
19 * [Nginx] Fixed support for Nginx 1.1.4+
20 * [Nginx, Standalone] Upgraded default Nginx version to 1.0.10
21 The previously default version was 1.0.5.
9b2c42f @FooBarWidget Update NEWS
FooBarWidget authored
22 * [Nginx] New option passenger_max_requests
23 This is equivalent to the PassengerMaxRequests option in the Apache
24 version: Phusion Passenger will automatically shutdown a worker process
25 once it has processed the specified number of requests.
26 Contributed by Paul Kmiec.
27 * [Apache] New option PassengerBufferResponse
28 The Apache version did not buffer responses. This could block the Ruby
29 worker process in case of slow clients. We now enable response buffering
30 by default. It can be turned off through this option. Feature contributed
31 by Ryo Onodera.
32 * Fixed remaining Ruby 1.9.3 compatibility problems
33 We already supported Ruby 1.9.3 since 3.0.8, but due to bugs in Ruby
34 1.9.3's build system Phusion Passenger would fail to detect Ruby 1.9.3
35 features on some systems. Fixes issue #714.
6401566 @FooBarWidget Fix a typo in NEWS
FooBarWidget authored
36 * Fixed a bug in PassengerPreStart
9b2c42f @FooBarWidget Update NEWS
FooBarWidget authored
37 A regression was introduced in 3.0.8, causing the prespawn script to
38 connect to the host name instead of to 127.0.0.1. Fix contributed by
39 Andy Allan.
6d972a6 @FooBarWidget Update NEWS
FooBarWidget authored
40 * Fixed compatibility with GCC 4.6
41 Affected systems include Ubuntu 11.10.
9b2c42f @FooBarWidget Update NEWS
FooBarWidget authored
42 * Fixed various compilation problems.
43 * Fixed some Ruby 1.9 encoding problems.
44 * Fixed some Ruby 1.9.3 deprecation warnings.
45
46
b367914 @FooBarWidget Update NEWS.
FooBarWidget authored
47 Release 3.0.9
48 -------------
49
50 * [Nginx] Fixed a NULL pointer crash that occurs on HTTP/1.0 requests
51 when the Host header isn't given.
52 * Fixed deprecation warnings on RubyGems >= 1.6.
53 * Improved Union Station support stability.
54
55
8a0fd40 @FooBarWidget Update NEWS.
FooBarWidget authored
56 Release 3.0.8
57 -------------
58
59 * [Nginx] Upgraded preferred Nginx version to 1.0.5.
60 * [Nginx] Fixed various compilation problems on various platforms.
61 * [Nginx] We now ensure that SERVER_NAME is equal to HTTP_HOST without the port part.
62 This is needed for Rack compliance. By default Nginx sets SERVER_NAME to
63 whatever is specified in the server_name directive, but that's not necessarily
64 the correct value. This fixes, for example, the use of the 'map' statement
65 in config.ru.
66 * [Nginx] Added the options passenger_buffer_size, passenger_buffers and passenger_busy_buffers_size.
67 These options are similar to proxy_module's similarly named options. You can
68 use these to e.g. increase the maximum header size limit.
69 * [Nginx] passenger_pre_start now supports virtual hosts that listen on Unix domain sockets.
70 * [Apache] Fixed the pcre.h compilation problem.
71 * [Standalone] Fixed 'passenger stop'.
72 It didn't work properly because it kept waiting for 'tail' to exit.
73 We now properly terminate 'tail' as well.
74 * Fixed compatibility with Rake 0.9.
75 * Fixed various Ruby 1.9 compatibility issues.
76 * Various documentation improvements.
77 * New Union Station filter language features.
78 It now supports status codes and response times.
79 Please refer to https://engage.unionstationapp.com/help#filtering
80 for more information.
81
82
33964ce @FooBarWidget Update NEWS
FooBarWidget authored
83 Release 3.0.7
84 -------------
85
86 * Fixed a bug passenger-install-apache2-module. It could crash on
87 some systems due to a typo in the code.
88 * Upgraded preferred Nginx version to 1.0.0.
89 * Phusion Passenger Standalone now pre-starts application processes
90 at startup instead of doing that at the first request.
91 * When sending data to Union Station, the HTTP status code is now also
92 logged.
93 * Various Union Station-related stability improvements.
94 * The Linux OOM killer was previously erroneously disabled for all
95 Phusion Passenger processes, including application processes. The
96 intention was to only disable it for the Watchdog. This has been
97 fixed, and the Watchdog is now the only process for which the OOM
98 killer is disabled.
99 * Fixed some compilation problems on OpenBSD.
100 * Due to a typo, the dependency on file-tail was not entirely removed
101 in 3.0.6. This has now been fixed.
102
103
d697d9f @FooBarWidget Update NEWS and bump version to 3.0.6.
FooBarWidget authored
104 Release 3.0.6
105 -------------
106
107 * Fixed various compilation problems such as XCode 4 support and OpenBSD support.
108 * Fixed various Union Station-related stability issues.
109 * Fixed an issue with host name detection on certain platforms.
110 * Improved error logging in various parts.
111 * The dependency on the file-tail library has been removed.
112 * During installation, check whether /tmp is mounted with 'noexec'.
113 Phusion Passenger's installer relies on /tmp *not* being mounted
114 with 'noexec'. If it is then the installer will now show a helpful
115 error message instead of bailing out in a confusing manner. Users
116 can now tell the installer to use a different directory for storing
117 temporary files by customizing the $TMPDIR environment variable.
118 * Phusion Passenger Standalone can now run Rackup files that are not named 'config.ru'.
119 The filename can be passed through the command line using the -R option.
120
121
c4d41e7 @FooBarWidget Update NEWS.
FooBarWidget authored
122 Release 3.0.5
123 -------------
124
6d413ea @FooBarWidget Rename PassengerAnalytics/passenger_analytics to UnionStationSupport/…
FooBarWidget authored
125 * [Apache] Fixed Union Station process statistics collection
126 Union Station users that are using Apache may notice that no process
127 information show up in Union Station. This is because of a bug in
128 Phusion Passenger's Apache version, which has now been fixed.
129 * [Apache] PassengerAnalytics has been renamed to UnionStationSupport
130 This option has been renamed for consistency reasons.
131 * [Nginx] passenger_analytics has been renamed to union_station_support
132 This option has been renamed for consistency reasons.
65bc50e @FooBarWidget Fix typo.
FooBarWidget authored
133 * Fixed Union Station data sending on older libcurl versions
c4d41e7 @FooBarWidget Update NEWS.
FooBarWidget authored
134 Some Union Station users have reported that their data don't show up.
135 Upon investigation this turned out to be a compatibility with older
136 libcurl versions. Affected systems include all RHEL 5 based systems,
137 such as RHEL 5.5 and CentOS 5.5. We've now fixed compatibility
138 with older libcurl versions.
7e7aa94 @FooBarWidget Update NEWS about Union Station filter language support.
FooBarWidget authored
139 * Added support for the Union Station filter language
140 This language can be used to limit the kind of data that's sent to
141 Union Station. Please read
142 https://engage.unionstationapp.com/help#filtering for details.
c4d41e7 @FooBarWidget Update NEWS.
FooBarWidget authored
143 * Fixed a PassengerMaxPoolSize/passenger_max_pool_size violation bug
144 People who host a lot of different applications on Phusion Passenger
145 may notice that it sometimes spawns more processes than is allowed
146 by PassengerMaxPoolSize/passenger_max_pool_size. This has been fixed.
147
148
4e1e3b8 @FooBarWidget Add release notes for 3.0.4.
FooBarWidget authored
149 Release 3.0.4
150 -------------
151
152 * [Apache] Changed mod_dir workaround hook priority
153 Phusion Passenger temporarily disables mod_dir on all Phusion
154 Passenger-handled requests in order to avoid conflicts. In order to do this
155 it registers some Apache hooks with the APR_HOOK_MIDDLE priority, but it
156 turned out that this breaks some other modules like mod_python. The hook
157 priority has been changed to APR_HOOK_LAST to match mod_dir's hook
158 priorities. Issue reported by Jay Freeman.
159 * Added support for Union Station: http://www.unionstationapp.com/
160 * Some error messages have been improved.
161
162
9962c3a @FooBarWidget Update NEWS and bump version to 3.0.3.
FooBarWidget authored
163 Release 3.0.3
164 -------------
165
166 * [Nginx] Preferred Nginx version upgraded to 0.8.54
167 The previous preferred version was 0.8.53.
168 * PATH_INFO and REQUEST_URI now contain the original escaped URI
169 Phusion Passenger passes the URI, as reported by Apache/Nginx, to
170 application processes through the PATH_INFO and REQUEST_URI variables.
171 These variables are supposed to contain the original, unescaped URI, e.g.
172 /clubs/%C3%BC. Both Apache and Nginx thought that it would be a good idea
173 to unescape the URI before passing it to modules like Phusion Passenger,
174 thereby causing PATH_INFO and REQUEST_URI to contain the unescaped URI,
175 e.g. /clubs/ü. This causes all sorts of encoding problems. We now manually
176 re-escape the URI when setting PATH_INFO and REQUEST_URI. Issue #404.
177 * The installer no longer detects directories as potential commands
178 Previously the installer would look in $PATH for everything that's
179 executable, including directories. If one has /usr/lib in $PATH
180 and a directory /usr/lib/gcc exists then the installer would recognize
181 /usr/lib/gcc as the compiler. We now explicitly check whether the item
182 is also a file.
183 * PseudoIO now responds to #to_io
184 Phusion Passenger sets STDERR to a PseudoIO object in order to capture
185 anything written to STDERR during application startup. This breaks
186 some libraries which expect STDERR to respond to #to_io. This has now
187 been fixed. Issue #607.
188 * Fixed various other minor bugs
189 See the git commit log for details.
190
191
5b30a81 @FooBarWidget Update NEWS.
FooBarWidget authored
192 Release 3.0.2
193 -------------
194
195 * [Nginx] Fixed compilation problems
196 The Nginx compilation process was broken due to not correctly reverting
197 the working directory of the Nginx configure script. This has been fixed:
198 issue #595.
60e4cca @FooBarWidget [Nginx] Fix crash if passenger_root refers to a nonexistant directory.
FooBarWidget authored
199 * [Nginx] Fixed crash if passenger_root refers to a nonexistant directory
200 Issue #599.
5b30a81 @FooBarWidget Update NEWS.
FooBarWidget authored
201 * Fixed compilation problems on NetBSD
202 There was a typo in a NetBSD-specific fcntl() call. It also turns out that
203 NetBSD doesn't support some ISO C99 math functions like llroundl(); this
204 has been worked around by using other functions. Issue #593.
9a81106 @FooBarWidget Fixed file descriptor closing issues on FreeBSD: issue #597.
FooBarWidget authored
205 * Fixed file descriptor closing issues on FreeBSD
206 Phusion Passenger child processes didn't correct close file descriptors
207 on FreeBSD because it queries /dev/fd to do that. On FreeBSD /dev/fd
208 only returns meaningful results if fdescfs is mounted, which it isn't
209 by default. Issue #597.
5b30a81 @FooBarWidget Update NEWS.
FooBarWidget authored
210
211
c665f9f @FooBarWidget Update NEWS.
FooBarWidget authored
212 Release 3.0.1
213 -------------
214
ccef2aa @FooBarWidget Introduce a release mode which can compile Phusion Passenger more qui…
FooBarWidget authored
215 * MUCH faster compilation
216 We've applied code aggregation techniques, allowing Phusion Passenger
217 to be compiled much quicker now. For example, compiling the Nginx
d0b8b61 @FooBarWidget Document Apache module compilation speedup.
FooBarWidget authored
218 component (not Nginx itself) on a MacBook Pro now takes only 29
219 seconds instead of 51 seconds, an improvement of 75%! Compiling the
220 Apache module on a slower Dell Inspiron now takes 39 seconds instead of
221 1 minute 22 seconds, or 110% faster!
c665f9f @FooBarWidget Update NEWS.
FooBarWidget authored
222 * Fixed malfunction after web server restart
223 On Linux systems that have a non-standard filesystem on /tmp, Phusion
224 Passenger could malfunction after restarting the web server because of
225 a bug that's only triggered on certain filesystems. Issue #569.
226 * Boost upgraded to version 1.44.0.
227 We were on 1.42.0.
228 * Much improved startup error messages
229 Phusion Passenger performs many extensive checks during startup to ensure
230 integrity. However the error message in some situation could be vague.
231 These startup error messages have now been improved dramatically, so that
232 if something goes wrong during startup you will now more likely know why.
233 * Curl < 7.12.1 is now supported
234 The previous version fails to compile with Curl versions earlier than
534950b @FooBarWidget Fix a potential compilation warning and update NEWS.
FooBarWidget authored
235 7.12.1. Issue #556.
c665f9f @FooBarWidget Update NEWS.
FooBarWidget authored
236 * passenger-make-enterprisey fixed
237 This is the command that people can run after donating. It allows people
238 to slightly modify Phusion Passenger's display name as a joke. In 3.0.0 it
239 was broken because of a typo. This has been fixed.
51bf666 @FooBarWidget Get rid of passenger-stress-test.
FooBarWidget authored
240 * Removed passenger-stress-test
241 This tool was used during the early life of Phusion Passenger for stress
242 testing websites. Its performance has never been very good and there are
243 much better tools for stress testing, so this tool has now been removed.
c665f9f @FooBarWidget Update NEWS.
FooBarWidget authored
244 * [Apache] RailsEnv and RackEnv configuration options are now equivalent
245 In previous versions, RailsEnv only had effect on Rails 1 and Rails 2 apps
246 while RackEnv only had effect on Rack apps. Because Rails 3 apps are
247 considered Rack apps, setting RailsEnv had no effect on Rails 3 apps.
248 Because this is confusing to users, we've now made RailsEnv and RackEnv
534950b @FooBarWidget Fix a potential compilation warning and update NEWS.
FooBarWidget authored
249 equivalent. Issue #579.
c665f9f @FooBarWidget Update NEWS.
FooBarWidget authored
250 * [Nginx] Fixed compilation problems on systems with unpowerful shells
0999e3d @FooBarWidget Fix typo.
FooBarWidget authored
251 Most notably Solaris. Its default shell does not support some basic
c665f9f @FooBarWidget Update NEWS.
FooBarWidget authored
252 constructs that we used in the Nginx configure script.
253 * [Nginx] Upgraded default Nginx version to to 0.8.53
254 The previous default was 0.8.52.
5e7722b @FooBarWidget passenger_enabled now only accepts 'on' or 'off' values.
FooBarWidget authored
255 * [Nginx] passenger_enabled now only accepts 'on' or 'off' values
256 Previously it would recognize any value not equal to 'on' as meaning
257 'off'. This caused confusion among users who thought they could also
258 specify 'true', so we now throw a proper error if the value is
259 unrecognized. Fixes issue #583.
c665f9f @FooBarWidget Update NEWS.
FooBarWidget authored
260
261
8243d6d @FooBarWidget Update NEWS
FooBarWidget authored
262 Release 3.0.0
263 -------------
f75f12f @FooBarWidget Bump version to 2.9.4 and update NEWS.
FooBarWidget authored
264
3d6f5ef @FooBarWidget Update NEWS
FooBarWidget authored
265 This is a major release with many changes. Please read our blog for details.
9e15dbd @FooBarWidget Begin porting passenger-status to the new infrastructure.
FooBarWidget authored
266
20005e1 @FooBarWidget Merge branch 'master' into refactoring
FooBarWidget authored
267
1857301 @FooBarWidget Bump version number to 2.2.15 and update NEWS.
FooBarWidget authored
268 Release 2.2.15
269 --------------
270
271 * [Apache] Fixed incorrect temp dir cleanup by passenger-status
272 On some systems, running passenger-status could print the following
273 message:
274
275 *** Cleaning stale folder /tmp/passenger.1234
276
277 ...after which Phusion Passenger breaks because that directory is
278 necessary for it to function properly. The cause of this problem
279 has been found and has been fixed.
e795d48 @FooBarWidget Don't be too strict on client Content-Length, it could be wrong becau…
FooBarWidget authored
280 * [Apache] Fixed some upload handling problems
281 Previous versions of Phusion Passenger check whether the size of
282 the received upload data matches the contents of the Content-Length
283 header as received by the client. It turns out that there could
284 be a mismatch e.g. because of mod_deflate input compression, so
285 we can't trust Content-Length anyway and we're being too strict.
286 The check has now been removed.
2265239 @FooBarWidget Install Nginx 0.7.67 and PCRE 8.02 by default.
FooBarWidget authored
287 * [Nginx] Fixed compilation issues with Nginx >= 0.7.66
e973b93 @FooBarWidget Fix compilation issues with Nginx 0.7.66 and make that version the de…
FooBarWidget authored
288 Thanks to Potamianos Gregory for reporting this issue. Issue #500.
2265239 @FooBarWidget Install Nginx 0.7.67 and PCRE 8.02 by default.
FooBarWidget authored
289 * [Nginx] Default Nginx version changed to 0.7.67
e973b93 @FooBarWidget Fix compilation issues with Nginx 0.7.66 and make that version the de…
FooBarWidget authored
290 The previous default version was 0.7.65.
946dc2e @FooBarWidget Don't preload popular libraries, it conflicts with Bundler.
FooBarWidget authored
291 * Fixed more Bundler problems
292 Previous versions of Phusion Passenger would preload some popular
293 libraries such as mysql and sqlite3 in order to utilize copy-on-write
294 optimizations better. However this behavior conflicts with Bundler
295 so we've removed it.
1857301 @FooBarWidget Bump version number to 2.2.15 and update NEWS.
FooBarWidget authored
296
297
9c17d46 @FooBarWidget Update NEWS and bump version to 2.2.14
FooBarWidget authored
298 Release 2.2.14
299 --------------
300
301 * Added support for Rubinius
302 Patch contributed by Evan Phoenix.
7413b57 @FooBarWidget Update NEWS.
FooBarWidget authored
303 * Fixed a mistake in the SIGQUIT backtrace message.
304 Patch contributed by Christoffer Sawicki.
73f59cd @FooBarWidget Increase Nginx HelperServer thread stack space on FreeBSD.
FooBarWidget authored
305 * [Nginx] Fix a localtime() crash on FreeBSD
306 This was caused by insufficient stack space for threads. Issue #499.
9c17d46 @FooBarWidget Update NEWS and bump version to 2.2.14
FooBarWidget authored
307
308
30296ca @FooBarWidget Update NEWS, bump version to 2.2.13.
FooBarWidget authored
309 Release 2.2.13
310 --------------
311
312 * Fixed some Rails 3 compatibility issues that were recently introduced.
313 * Fixed a typo that causes config/setup_load_paths.rb not to be loaded
314 correctly.
315
316
38db2e2 @FooBarWidget Bump version to 2.2.12 and update NEWS.
FooBarWidget authored
317 Release 2.2.12
318 --------------
319
320 * Improved Bundler support.
321 Previous versions might not be able to correctly load gems bundled
3fc6071 @FooBarWidget Document Bundler support
FooBarWidget authored
322 by Bundler. We've also documented how our Bundler support works and
323 how to override our support if you need special behavior.
324 Please refer to the Phusion Passenger Users Guide, section
325 "Bundler support".
775e220 @FooBarWidget Fix Nginx "passenger_user_switching off" permission problems: issue #…
FooBarWidget authored
326 * Worked around some user account handling bugs in Ruby. Issue #192.
5a4d113 @FooBarWidget Update NEWS
FooBarWidget authored
327 * Fixed some Ruby 1.9 tempfile.rb compatibility problems.
73ee6b0 @FooBarWidget Fixed some compilation problems on some ARM Linux platforms.
FooBarWidget authored
328 * Fixed some compilation problems on some ARM Linux platforms.
94f3aa8 @FooBarWidget Suppress bogus error messages when mod_xsendfile is being used
FooBarWidget authored
329 * [Apache] Suppress bogus mod_xsendfile-related error messages.
330 When mod_xsendfile is being used, Phusion Passenger might print
331 bogus error messages like "EPIPE" or "Apache stopped forwarding
332 the backend's response" to the log file. These messages are
333 normal, are harmless and can be safely ignored, but they pollute
334 the log file. So in this release we've added code to suppress
6b39c23 @FooBarWidget Note mod_xsendfile issue number.
FooBarWidget authored
335 these messages when mod_xsendfile is being used. Issue #474.
775e220 @FooBarWidget Fix Nginx "passenger_user_switching off" permission problems: issue #…
FooBarWidget authored
336 * [Nginx] Fixed "passenger_user_switching off" permission problems
337 If Nginx is running as root and passenger_user_switching is turned
338 off, then Phusion Passenger would fail to initialize because of
339 a permission problem. This has been fixed. Issue #458.
745938a @FooBarWidget Fix Nginx >= 0.8.38 support. Thanks Sergey A. Osokin
FooBarWidget authored
340 * [Nginx] Nginx >= 0.8.38 is now supported.
c271480 @FooBarWidget Default to installing Nginx 0.7.65
FooBarWidget authored
341 Thanks to Sergey A. Osokin for reporting the problem.
342 * [Nginx] passenger-install-nginx-module upgraded
343 It now defaults to installing Nginx 0.7.65 instead of 0.7.64.
38db2e2 @FooBarWidget Bump version to 2.2.12 and update NEWS.
FooBarWidget authored
344
345
119309e @FooBarWidget Update NEWS and bump version to 2.2.11.
FooBarWidget authored
346 Release 2.2.11
347 --------------
348
349 * This release fixes a regression that appeared in 2.2.10 which only
350 affects Apache. When under high load, Apache might freeze and stop
6d961e7 @FooBarWidget Merge branch 'master' into refactoring
FooBarWidget authored
351 responding to requests. It is caused by a race condition which is
119309e @FooBarWidget Update NEWS and bump version to 2.2.11.
FooBarWidget authored
352 why it escaped our last release testing.
353
354 This problem does not affect Nginx; you only have to upgrade if
355 you're using Apache.
356
357 http://groups.google.com/group/phusion-passenger/t/d5bb2f17c8446ea0
358
359
e07dfa0 @FooBarWidget Fix some compilation problems on newer GCC versions. Issue #430.
FooBarWidget authored
360 Release 2.2.10
361 --------------
362
363 * Fixed some Bundler compatibility problems.
364 * Fixed some file descriptor passing problems, which previously
365 could lead to mysterious crashes.
366 * Fixed some compilation problems on newer GCC versions. Issue #430.
84a4bc0 @FooBarWidget Update NEWS.
FooBarWidget authored
367 * Support #size method in rack.input.
e07dfa0 @FooBarWidget Fix some compilation problems on newer GCC versions. Issue #430.
FooBarWidget authored
368
369
2853379 @FooBarWidget Merge branch 'master' into refactoring
FooBarWidget authored
370
00e0cbc @FooBarWidget Update NEWS.
FooBarWidget authored
371 Release 2.2.9
372 -------------
373
374 * Fixed compatibility with Rails 3.
375 Actually, previous Phusion Passenger releases were already compatible
376 with Rails 3, depending on the spawn method that would be invoked. Here's
377 the story:
378
379 Since Phusion Passenger 2.2.8, when the file config.ru exists, Phusion
380 Passenger will treat the app as a Rack app, not as a Rails app. This is
381 in contrast to earlier versions which gave Rails detection more priority
382 than Rack detection. Phusion Passenger loads Rack apps and Rails apps in
383 different ways. The Rails loader was not compatible with Rails 3, which
384 is what we've fixed in this release.
385
386 That said, a Rails 3 app would have worked out-of-the-box on Phusion
387 Passenger 2.2.8 as well because Rails 3 apps include a config.ru file
388 by default, causing Phusion Passenger 2.2.8 to use the Rack loader.
389 Earlier versions of Phusion Passenger would just completely bail out
390 because they'd use the Rails loader.
391
c674aab @FooBarWidget Document some more Rails 3 caveats.
FooBarWidget authored
392 That said, with 2.2.9 there are still some caveats:
393 - Smart spawning (the mechanism with which REE's 33% memory reduction
394 is implemented) is *not* supported for Rack apps. This means that if
395 you want to utilize smart spawning with Rails 3, then you should
396 remove your config.ru file.
397 - Rails 3 depends on Rack 1.1.0. You must have Rack 1.1.0 installed as
398 a gem, even if you've bundled it with the gem bundler. This is because
399 Phusion Passenger itself depends on Rack.
400
401 Both of these caveats are temporary. We have plans to solve both of these
402 properly in the future.
4a0e6ab @FooBarWidget Document what's up with gem bundler compatibility.
FooBarWidget authored
403 * What's up with the Gem Bundler?
404 There has been some reports that Phusion Passenger is not compatible with
405 Yehuda Katz's gem bundler (http://github.com/wycats/bundler). This might
406 have been true for an earlier version of the gem bundler, but the latest
407 version seems to work fine. Please note that you need to insert the
408 following snippet in config/preinitializer.rb, as instructed by the gem
409 bundler's README:
410
411 require "#{RAILS_ROOT}/vendor/gems/environment"
412
413 The Rails::Boot monkey patching code as posted at
414 http://yehudakatz.com/2009/11/03/using-the-new-gem-bundler-today/
415 does not seem to be required anymore.
97db507 @FooBarWidget Afer forking, correctly clear ActiveRecord connections other than the…
FooBarWidget authored
416 * Fixed support for ActiveRecord subclasses that connect to another database.
417 ActiveRecord subclasses that connect to a database other than the default
418 one did not have their connection correctly cleared after forking.
419 This can result in weird errors along the lines of "Lost connection to
420 MySQL server during query". Issue #429.
00e0cbc @FooBarWidget Update NEWS.
FooBarWidget authored
421 * [Nginx] Fixed PCRE URL.
422 passenger-install-nginx-module downloads PCRE 7.8 if PCRE is not already
423 installed. However PCRE 7.8 has been removed from their FTP server,
424 so we've updated the URL to point to the latest version, 8.0.
425
426
adad4c6 @FooBarWidget Add OpenSSL as required dependency for Nginx (fixes issue #422). Upda…
FooBarWidget authored
427 Release 2.2.8
428 -------------
429
430 * [Nginx] Fixed some signal handling problems.
431 Restarting Nginx on OS X with SIGHUP can sometimes take a long time or
432 even fail completely. This is because of some signal handling problems,
433 which have now been fixed.
434 * [Nginx] Added OpenSSL as dependency.
435 OpenSSL is required in order to install Nginx, but this was not checked
436 by passenger-install-nginx-module. As a result,
437 passenger-install-nginx-module fails on e.g. out-of-the-box Ubuntu
438 installations until the user manually installs OpenSSL. Issue #422.
fd82697 @loe Ensure the current URI subject to internal redirects and rewrites is …
loe authored
439 * [Nginx] Fixed support for internal redirects and subrequests.
440 It is now possible to, for example, point X-Accel-Redirects to Phusion
441 Passenger-served URLs. Patch contributed by W. Andrew Loe III: issue #433.
247a254 @FooBarWidget Fixed crash caused by GnuTLS: issue #391.
FooBarWidget authored
442 * [Apache] Fixed a GnuTLS compatibility issue.
443 mod_gnutls can cause Phusion Passenger to crash because of an unchecked
444 NULL pointer. This problem has now been fixed: issue #391.
78beaf7 @FooBarWidget Fix thread creation on Intel Itanium. Fixes issue #427.
FooBarWidget authored
445 * Fixed thread creation issue on Intel Itanium platforms.
446 This fixes issue #427.
4880487 @FooBarWidget Fixed compilation problems on Linux running on the Renesas SH4 CPU: i…
FooBarWidget authored
447 * Fixed compilation problems on Linux running on the Renesas SH4 CPU.
448 Patch contributed by iwamatsu: issue #428.
681c216 @FooBarWidget Unvendor Rack and add a workaround for the Ruby 1.9.1 tempfile bug. F…
FooBarWidget authored
449 * The Rack library has been unvendored.
450 The original reason for vendoring was to work around broken Rails
451 applications that explicitly specify Rack as a gem dependency. We've
452 found a better workaround that does not require vendoring Rack.
1a8408f @FooBarWidget Update NEWS.
FooBarWidget authored
453 This also fixes a compatibility problem with Rails 3, because Rails
454 3 depends on a newer Rack version than the one we had vendored.
681c216 @FooBarWidget Unvendor Rack and add a workaround for the Ruby 1.9.1 tempfile bug. F…
FooBarWidget authored
455 Issue #432.
456 * Fixed compatibility with Ruby 1.9.1 patchlevel >= 152
457 Ruby 1.9.1 patchlevel >= 152 has a bug in its tempfile library. If you've
458 seen an error message along the lines of
459
460 *** Exception IOError in Passenger RequestHandler (closed stream)
461
462 then this is a Ruby bug at work. This bug has been fixed in Ruby 1.9.2,
463 but Ruby 1.9.1 still contains this bug. We've added a workaround so that
464 the bug is not triggered with this Ruby version. Issue #432.
adad4c6 @FooBarWidget Add OpenSSL as required dependency for Nginx (fixes issue #422). Upda…
FooBarWidget authored
465
466
979bf12 @FooBarWidget Oops, remove debugging code.
FooBarWidget authored
467 Release 2.2.7
468 -------------
469
470 * Removed forgotten debugging code in passenger-install-apache2-module,
471 which caused it not to compile anything.
472
473
5f3ac2b @FooBarWidget Fix compilation on Solaris: PTHREAD_STACK_MIN might not be a constant…
FooBarWidget authored
474 Release 2.2.6
475 -------------
476
5372bdb @FooBarWidget Prevent the Phusion Passenger temp dir from being deleted by /tmp cle…
FooBarWidget authored
477 * Some /tmp cleaner programs such as tmpwatch try to remove subdirectories
478 in /tmp/passenger.xxx after a while because they think those
479 subdirectories are unused. This could cause Phusion Passenger to
480 malfunction, requiring a web server restart. Measures have now been
481 taken to prevent those tmp cleaner programs from removing anything
482 in /tmp/passenger.xxx. Issue #365.
6418797 @FooBarWidget Update NEWS, bump version number to 2.2.6.
FooBarWidget authored
483 * When autodetecting the application type, Rack is now given more priority
484 than Rails. This allows one to drop a config.ru file in a Rails directory
485 and have it detected as a Rack application instead of a Rails application.
486 Patch contributed by Sam Pohlenz: issue #338.
053150e @FooBarWidget Increase default socket backlog to 1024, SOMAXCONN is usually 128 whi…
FooBarWidget authored
487 * The default socket backlog has been increased from 'SOMAXCONN' (which
488 is 128 on most platforms) to 1024. This should fix most
489 'helper_server.sock failed: Resource temporarily unavailable'
490 errors.
6418797 @FooBarWidget Update NEWS, bump version number to 2.2.6.
FooBarWidget authored
491 * Fixed compilation problems on Solaris. Issue #369 and issue #379.
492 * Fixed crashes on PowerPC.
9444db6 @FooBarWidget Fix a Ruby 1.9 compatibility issue: require stringio in utils.rb. Fix…
FooBarWidget authored
493 * Some Ruby 1.9 compatibility fixes. Issue #398.
5967ed7 @FooBarWidget Autodetect Mandriva Linux. Fixes issue #357.
FooBarWidget authored
494 * The installer now displays correct dependency installation instructions
495 for Mandriva Linux.
50750b1 @FooBarWidget Allow specifying the location of apxs2 and apr-config through command…
FooBarWidget authored
496 * [Apache] The location of the 'apxs' and 'apr-config' commands can now
497 also be passed to the installer through the --apxs-path and
498 --apr-config-path parameters, in addition to the $APXS2 and $APR_CONFIG
499 environment variables. Issue #3.
6418797 @FooBarWidget Update NEWS, bump version number to 2.2.6.
FooBarWidget authored
500 * [Nginx] Various problems that only occur on 64-bit platforms have been fixed.
1f4d88b @FooBarWidget Update NEWS.
FooBarWidget authored
501 * [Nginx] The installer now installs Nginx 0.7.64 by default.
5f3ac2b @FooBarWidget Fix compilation on Solaris: PTHREAD_STACK_MIN might not be a constant…
FooBarWidget authored
502
503
7215630 @FooBarWidget Write some release notes.
FooBarWidget authored
504 Release 2.2.5
505 -------------
506
24cc3fa @FooBarWidget Continue writing release notes
FooBarWidget authored
507 * [Apache] Small file uploads are now buffered; fixes potential DoS attack
e66494d @FooBarWidget Update NEWS
FooBarWidget authored
508 Phusion Passenger buffers large file uploads to temp files so that it
24cc3fa @FooBarWidget Continue writing release notes
FooBarWidget authored
509 doesn't block applications while an upload is in progress, but it sent
510 small uploads directly to the application without buffering it. This could
511 result in a potential DoS attack: the client can send many small, incomplete
512 file uploads to the server, and this would block all application processes
513 until a timeout occurs. In order to solve this problem, Phusion Passenger
e66494d @FooBarWidget Update NEWS
FooBarWidget authored
514 now buffers small file uploads in memory. Bug #356.
24cc3fa @FooBarWidget Continue writing release notes
FooBarWidget authored
515
caa9fd7 @FooBarWidget Fix support for mod_rewrite passthrough rules (issue #230) and fix so…
FooBarWidget authored
516 * [Apache] Fixed support for mod_rewrite passthrough rules
e66494d @FooBarWidget Update NEWS
FooBarWidget authored
517 Mod_rewrite passthrough rules were not properly supported because of a bug
caa9fd7 @FooBarWidget Fix support for mod_rewrite passthrough rules (issue #230) and fix so…
FooBarWidget authored
518 fix for supporting encoded slashes (%2f) in URLs. Unfortunately, due to
519 bugs/limitations in Apache, we can support either encoded slashes or
520 mod_rewrite passthrough rules, but not both; supporting one will break the
521 other.
522
523 Support for mod_rewrite passthrough rules is now enabled by default; that
524 is, support for encoded slashes is disabled by default. A new configuration
525 option, "PassengerAllowEncodedSlashes", has been added. Turning this option
526 on will enable support for encoded slashes and disable support for
527 mod_rewrite passthrough rules.
528
529 Issue #113 and issue #230.
530
e66494d @FooBarWidget Update NEWS
FooBarWidget authored
531 * [Apache] Added a configuration option for resolving symlinks in the document root path
532 Phusion Passenger 2.2.0 and higher no longer resolves symlinks in
24cc3fa @FooBarWidget Continue writing release notes
FooBarWidget authored
533 the document root path in order to properly support Capistrano-style
534 directory structures. The exact behavior is documented in the Users Guide,
535 section "How Phusion Passenger detects whether a virtual host is a web
536 application".
537
538 However, some people relied on the old behavior. A new configuration option,
539 PassengerResolveSymlinksInDocumentRoot, has been added to allow reverting
540 back to the old behavior.
541
281c020 @FooBarWidget Update NEWS
FooBarWidget authored
542 Patch contributed by Locaweb (http://www.locaweb.com.br/).
543
24cc3fa @FooBarWidget Continue writing release notes
FooBarWidget authored
544 * [Apache] mod_env variables are now also passed through CGI environment headers
545 Prior to version 2.2.3, environment variables set by mod_env are passed to
546 the application as CGI environment headers, not through Ruby's ENV variable.
547 In the last release we introduced support for setting ENV environment
548 variables with mod_env, and got rid of the code for setting CGI environment
549 headers. It turns out that some people relied on the old behavior, we so now
550 environment variables set with mod_env are set in both ENV and in the CGI
551 environment.
552
553 Fixes bug #335.
554
555 * [Apache] Fixed compilation problems on some Linux systems with older versions of Apache
556 If you used to see compilation errors like this:
557
558 ext/apache2/Configuration.cpp:554: error: expected primary-expression before '.' token
559
560 then this version should compile properly.
561
e66494d @FooBarWidget Update NEWS
FooBarWidget authored
562 * [Apache] Fixed I/O timeouts for communication with backend processes
563 Got rid of the code for enforcing I/O timeouts when reading from or writing to
7ec85d7 @FooBarWidget Update release notes
FooBarWidget authored
564 a backend process. This caused more problems than it solved.
565
7215630 @FooBarWidget Write some release notes.
FooBarWidget authored
566 * [Nginx] Support for streaming responses (e.g. Comet or HTTP push)
567 Buffering of backend responses is now disabled. This fixes support for
568 streaming responses, something which the Apache version has supported
569 for a while now. One can generate streaming responses in Ruby on Rails
570 like this:
571
572 render :text => lambda { |response, output|
573 10_000.times do |i|
574 output.write("hello #{i}!\n")
575 end
576 }
577
41160df @FooBarWidget Nginx installer: install 0.7.61 by default.
FooBarWidget authored
578 * [Nginx] Installer now installs Nginx 0.7.61 by default
579 Previously it installed 0.6.37 by default.
580
9e62b29 @FooBarWidget passenger-install-nginx-module: correctly pass --extra-configure-flag…
FooBarWidget authored
581 * [Nginx] Fixed the installer's --extra-configure-flags flag when combined with --auto-download
582 Arguments passed to --extra-configure-flags were not being passed to the
583 Nginx configure script when --auto-download is given. This has been
584 fixed: bug #349.
585
9ff0e2a @FooBarWidget passenger-install-apache2-module: do not unnecessarily donwload PCRE;…
FooBarWidget authored
586 * [Nginx] Fixed unnecessary download of PCRE
587 The installer now checks whether PCRE is installed in /opt/local (e.g.
588 MacPorts) as well before concluding that it isn't installed and going ahead
589 with downloading PCRE.
590
7215630 @FooBarWidget Write some release notes.
FooBarWidget authored
591 * Fixed STDERR capturing
592 While spawning an application, Phusion Passenger captures any output written
593 to STDERR so that it can show them later if the application failed to start.
594 This turns out to be much more difficult than expected, with all kinds of
595 corner cases that can mess up this feature.
24cc3fa @FooBarWidget Continue writing release notes
FooBarWidget authored
596
7215630 @FooBarWidget Write some release notes.
FooBarWidget authored
597 For example, if the Rails log file is not writable, then this can cause
598 Rails to crash with a bizarre and unhelpful error message whenever it tries
599 to write to STDERR:
600
601 /!\ FAILSAFE /!\ Thu Aug 20 14:58:39 +1000 2009
602 Status: 500 Internal Server Error
603 undefined method `[]' for nil:NilClass
604
605 Some applications reopen STDERR to a log file. This didn't work.
606
607 Of all of these problems have been fixed now. (Bug #332)
608
24cc3fa @FooBarWidget Continue writing release notes
FooBarWidget authored
609 * Fixed some bugs in application sources preloading
610 Rails >= 2.2 already preloads the application sources, in which case Phusion
611 Passenger wasn't supposed to perform it's own preloading, but the Rails
612 >= 2.2 detection code was bugged. This has been fixed.
7215630 @FooBarWidget Write some release notes.
FooBarWidget authored
613
24cc3fa @FooBarWidget Continue writing release notes
FooBarWidget authored
614 Rails < 2.2 doesn't preload the application sources by itself, but there
615 should be a certain order with which the sources are preloaded, otherwise
616 preloading could fail in some applications. We now enforce a specific load
617 order: first models, then controllers, then helpers.
c878017 @FooBarWidget Fix compilation problems with some Linux systems with older versions …
FooBarWidget authored
618
24cc3fa @FooBarWidget Continue writing release notes
FooBarWidget authored
619 Bug #359.
620
caa9fd7 @FooBarWidget Fix support for mod_rewrite passthrough rules (issue #230) and fix so…
FooBarWidget authored
621 * Fixed a few bugs in WSGI compliance
622 PATH_INFO is supposed to be set to the request URI, but without the query
623 string and without the base URI. This has been fixed: bug #360.
624
ac777e5 @FooBarWidget Fix some Ruby 1.9-specific crashes caused by encoding issues. Bug #364.
FooBarWidget authored
625 * Fixed some Ruby 1.9-specific crashes caused by encoding issues. Bug #354.
281c020 @FooBarWidget Update NEWS
FooBarWidget authored
626 * Fixed loading of config/environment.rb on Ruby 1.9.2, because Ruby 1.9.2
627 no longer has "." in the default load path. Patch by metaljastix, issue #368.
24cc3fa @FooBarWidget Continue writing release notes
FooBarWidget authored
628 * The Users Guide for Apache now mentions something about correct permissions
629 for application directories.
7215630 @FooBarWidget Write some release notes.
FooBarWidget authored
630 * Fixed compilation problems on IA-64 (bug #118). We also reduced the stack
631 sizes for the threads by half, so Phusion Passenger should use even less
632 virtual memory now.
312b5e1 @FooBarWidget Fix compilation problems on Linux systems with ARM CPU.
FooBarWidget authored
633 * Fixed compilation problems on Linux systems with ARM CPU.
7215630 @FooBarWidget Write some release notes.
FooBarWidget authored
634 * Fixed a few compatibility problems with 64-bit OpenBSD.
635 * Fixed a few typos and minor bugs.
636
637
638 Older releases
639 --------------
9e15dbd @FooBarWidget Begin porting passenger-status to the new infrastructure.
FooBarWidget authored
640 Please consult the blog posts on http://blog.phusion.nl/ for the information about older releases.
Something went wrong with that request. Please try again.