Permalink
Browse files

Change post-install Ruby warning message. Installer: check for depend…

…encies even when natively packaged.
  • Loading branch information...
1 parent 9618fae commit 0337f4f4b88f5067f218b3df64707d60058a59dd @FooBarWidget FooBarWidget committed May 11, 2008
Showing with 7 additions and 2 deletions.
  1. +6 −1 bin/passenger-install-apache2-module
  2. +1 −1 debian/postinst
@@ -49,6 +49,7 @@ class Installer
def start
if natively_packaged?
+ check_dependencies || exit(1)
show_apache2_config_snippets
show_deployment_example
exit
@@ -112,7 +113,11 @@ private
color_puts "<red>Some required software is not installed.</red>"
color_puts "But don't worry, this installer will tell you how to install them.\n"
color_puts "<b>Press Enter to continue, or Ctrl-C to abort.</b>"
- wait
+ if natively_packaged?
+ wait(10)
+ else
+ wait
+ end
line
color_puts "<banner>Installation instructions for required software</banner>"
View
@@ -19,6 +19,6 @@ if ruby -e ''; then
fi
else
echo "********* NOTE ***********"
- echo "Please install Ruby and RubyGems. Passenger needs them."
+ echo "Ruby doesn't seem to be installed. Please install Ruby and RubyGems, because Passenger needs them."
fi
exit 0

0 comments on commit 0337f4f

Please sign in to comment.