Browse files

Install Nginx 0.7.67 and PCRE 8.02 by default.

  • Loading branch information...
1 parent 946dc2e commit 22652390fdaae486b2dca61b21fa385cfa288651 @FooBarWidget FooBarWidget committed Jun 24, 2010
Showing with 5 additions and 5 deletions.
  1. +2 −2 NEWS
  2. +3 −3 bin/passenger-install-nginx-module
View
4 NEWS
@@ -17,9 +17,9 @@ Release 2.2.15
be a mismatch e.g. because of mod_deflate input compression, so
we can't trust Content-Length anyway and we're being too strict.
The check has now been removed.
- * [Nginx] Fixed compilation issues with Nginx 0.7.66
+ * [Nginx] Fixed compilation issues with Nginx >= 0.7.66
Thanks to Potamianos Gregory for reporting this issue. Issue #500.
- * [Nginx] Default Nginx version changed to 0.7.66
+ * [Nginx] Default Nginx version changed to 0.7.67
The previous default version was 0.7.65.
* Fixed more Bundler problems
Previous versions of Phusion Passenger would preload some popular
View
6 bin/passenger-install-nginx-module
@@ -36,7 +36,7 @@ include PlatformInfo
class Installer < PhusionPassenger::AbstractInstaller
include PhusionPassenger
- NGINX_VERSION = "0.7.66"
+ NGINX_VERSION = "0.7.67"
def dependencies
result = [
@@ -149,8 +149,8 @@ private
new_screen
color_puts "<banner>PCRE (required by Nginx) not installed, downloading it...</banner>"
- basename = "pcre-8.00.tar.gz"
- dirname = "pcre-8.00"
+ basename = "pcre-8.02.tar.gz"
+ dirname = "pcre-8.02"
url = "ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/#{basename}"
File.unlink("/tmp/#{basename}") rescue nil
FileUtils.rm_rf("/tmp/#{dirname}")

1 comment on commit 2265239

@moonshine

pcre 8.10 is out fixing more bugs, please bump

Please sign in to comment.