Permalink
Browse files

Upgrade preferred Nginx version to 1.0.5 and compile Nginx with -Wno-…

…error in order to avoid many non-fatal compilation problems.
  • Loading branch information...
1 parent e83d4cf commit 31a99337717604efe20f911b52b162cd2a0cb890 @FooBarWidget FooBarWidget committed Aug 2, 2011
@@ -390,7 +390,9 @@ private
end
def build_nginx_configure_command(prefix, extra_configure_flags = nil)
- command = "sh ./configure --prefix='#{prefix}' --with-http_ssl_module "
+ command = "sh ./configure --prefix='#{prefix}' "
+ command << "--with-http_ssl_module "
+ command << "--with-cc-opt='-Wno-error' "
if @pcre_source_dir
command << "--with-pcre='#{@pcre_source_dir}' "
elsif !pcre_is_installed?
View
@@ -27,7 +27,7 @@ module PhusionPassenger
# Phusion Passenger version number. Don't forget to edit ext/common/Constants.h too.
VERSION_STRING = '3.0.7'
- PREFERRED_NGINX_VERSION = '1.0.2'
+ PREFERRED_NGINX_VERSION = '1.0.5'
PREFERRED_PCRE_VERSION = '8.12'
STANDALONE_INTERFACE_VERSION = 1
@@ -437,6 +437,7 @@ def install_nginx_from_source(source_dir)
# work around the problem by configure Nginx with prefix
# /tmp.
command = "sh ./configure --prefix=/tmp " <<
+ "--with-cc-opt='-Wno-error' " <<
"--without-pcre " <<
"--without-http_rewrite_module " <<
"--without-http_fastcgi_module " <<

0 comments on commit 31a9933

Please sign in to comment.