Permalink
Browse files

When installing RPMs, specify the exact package version

  • Loading branch information...
1 parent fa20047 commit caf19ef641f9ed0ffed1b59442e8b4f7708d0d69 @FooBarWidget FooBarWidget committed Jan 2, 2014
@@ -334,7 +334,7 @@ private
sh! "sudo apt-get install #{DEB_APACHE_MODULE_PACKAGE}"
return true
when 'rpm'
- sh! "sudo yum install #{RPM_APACHE_MODULE_PACKAGE}"
+ sh! "sudo yum install #{RPM_APACHE_MODULE_PACKAGE}-#{VERSION_STRING}"
return true
else
puts "<red>The #{PROGRAM_NAME} Apache module package is not installed.</red>"
@@ -197,7 +197,7 @@ def compile_and_load
STDERR.puts " so that #{PhusionPassenger::PROGRAM_NAME} can compile one on the next run."
when 'rpm'
STDERR.puts " This library provides various optimized routines that make"
- STDERR.puts " #{PhusionPassenger::PROGRAM_NAME} faster. Please run 'sudo yum install #{PhusionPassenger::RPM_DEV_PACKAGE}'"
+ STDERR.puts " #{PhusionPassenger::PROGRAM_NAME} faster. Please run 'sudo yum install #{PhusionPassenger::RPM_DEV_PACKAGE}-#{PhusionPassenger::VERSION_STRING}'"
STDERR.puts " so that #{PhusionPassenger::PROGRAM_NAME} can compile one on the next run."
else
STDERR.puts " #{PhusionPassenger::PROGRAM_NAME} can compile one, but an extra package must be installed"
@@ -421,7 +421,7 @@ def check_nginx_module_sources_available
when "deb"
command = "sudo sh -c 'apt-get update && apt-get install #{DEB_DEV_PACKAGE}'"
when "rpm"
- command = "sudo yum install #{RPM_DEV_PACKAGE}"
+ command = "sudo yum install #{RPM_DEV_PACKAGE}-#{VERSION_STRING}"
end
if command
if STDIN.tty?

0 comments on commit caf19ef

Please sign in to comment.