Permalink
Browse files

Fix compilation issues with Nginx 0.7.66 and make that version the de…

…fault.
  • Loading branch information...
1 parent 1857301 commit e973b93e8998edbbb4c6958c75db6c16c9aee915 @FooBarWidget FooBarWidget committed Jun 11, 2010
Showing with 7 additions and 2 deletions.
  1. +4 −0 NEWS
  2. +1 −1 bin/passenger-install-nginx-module
  3. +2 −1 ext/nginx/StaticContentHandler.c
View
4 NEWS
@@ -10,6 +10,10 @@ Release 2.2.15
...after which Phusion Passenger breaks because that directory is
necessary for it to function properly. The cause of this problem
has been found and has been fixed.
+ * [Nginx] Fixed compilation issues with Nginx 0.7.66
+ Thanks to Potamianos Gregory for reporting this issue. Issue #500.
+ * [Nginx] Default Nginx version changed to 0.7.66
+ The previous default version was 0.7.65.
Release 2.2.14
@@ -36,7 +36,7 @@ include PlatformInfo
class Installer < PhusionPassenger::AbstractInstaller
include PhusionPassenger
- NGINX_VERSION = "0.7.65"
+ NGINX_VERSION = "0.7.66"
def dependencies
result = [
@@ -67,7 +67,8 @@ passenger_static_content_handler(ngx_http_request_t *r, ngx_str_t *filename)
return NGX_DECLINED;
}
- #if NGINX_VERSION_NUM < 8038
+ #if (PASSENGER_NGINX_MINOR_VERSION == 8 && PASSENGER_NGINX_MICRO_VERSION < 38) || \
+ (PASSENGER_NGINX_MINOR_VERSION == 7 && PASSENGER_NGINX_MICRO_VERSION < 66)
if (r->zero_in_uri) {
return NGX_DECLINED;
}

0 comments on commit e973b93

Please sign in to comment.