New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Remove 'passenger package-runtime' command #1133

Closed
FooBarWidget opened this Issue May 29, 2014 · 1 comment

Comments

Projects
None yet
1 participant
@FooBarWidget
Member

FooBarWidget commented May 29, 2014

From jkincl on December 20, 2013 16:59:26

What steps will reproduce the problem? 1. run passenger package-runtime What is the expected output? What do you see instead? Output I get:

passenger package-runtime

rm -rf /root/passenger-standalone/4.0.29/support-x86_64-linux
rm -rf /root/passenger-standalone/4.0.29/nginx-1.4.4-x86_64-linux
/opt/ruby/versions/1.9.3-p392/lib/ruby/gems/1.9.1/gems/passenger-4.0.29/lib/phusion_passenger/standalone/runtime_installer.rb:88:in initialize': :lib_dir must be given (ArgumentError) from /opt/ruby/versions/1.9.3-p392/lib/ruby/gems/1.9.1/gems/passenger-4.0.29/lib/phusion_passenger/standalone/package_runtime_command.rb:64:innew'
from /opt/ruby/versions/1.9.3-p392/lib/ruby/gems/1.9.1/gems/passenger-4.0.29/lib/phusion_passenger/standalone/package_runtime_command.rb:64:in run' from /opt/ruby/versions/1.9.3-p392/lib/ruby/gems/1.9.1/gems/passenger-4.0.29/lib/phusion_passenger/standalone/main.rb:92:inrun_command'
from /opt/ruby/versions/1.9.3-p392/lib/ruby/gems/1.9.1/gems/passenger-4.0.29/lib/phusion_passenger/standalone/main.rb:62:in run!' from /opt/ruby/versions/1.9.3-p392/lib/ruby/gems/1.9.1/gems/passenger-4.0.29/lib/phusion_passenger/standalone/main.rb:39:inrun!'
from /opt/ruby/versions/1.9.3-p392/lib/ruby/gems/1.9.1/gems/passenger-4.0.29/bin/passenger:36:in <top (required)>' from /opt/ruby/versions/1.9.3-p392/bin/passenger:23:inload'
from /opt/ruby/versions/1.9.3-p392/bin/passenger:23:in `

' What version of Phusion Passenger are you using? Which version of Rails? On what operating system? - rbenv

  • ruby installed in /opt/ruby/versions/1.9.3-p392
  • passenger 4.0.29 gem installed
  • RHEL 6.4 Please provide any additional information below.

Original issue: http://code.google.com/p/phusion-passenger/issues/detail?id=1034

@FooBarWidget FooBarWidget changed the title from passenger package-runtime fails to Remove 'passenger package-runtime' command May 29, 2014

@FooBarWidget

This comment has been minimized.

Show comment
Hide comment
@FooBarWidget

FooBarWidget May 29, 2014

Member

The 'passenger package-runtime' command is useless now that we have passenger_autobuilder. It should be removed.

Member

FooBarWidget commented May 29, 2014

The 'passenger package-runtime' command is useless now that we have passenger_autobuilder. It should be removed.

@FooBarWidget FooBarWidget modified the milestones: 4.0.45, 4.0.46 May 29, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment