Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

bundle exec rails server does not work on rails 4.1.9 + mongoid 4.0.2 #1768

Closed
danarnold opened this issue Mar 10, 2016 · 2 comments

Comments

Projects
None yet
3 participants
@danarnold
Copy link

commented Mar 10, 2016

bundle exec passenger start works fine.

bundle exec rails server gives the following error:

/home/dan/.rvm/gems/ruby-2.2.3@project/gems/mongoid-4.0.2/lib/mongoid/railtie.rb:110:in `block in <class:Railtie>': undefined method `on_event' for PhusionPassenger:Module (NoMethodError)

Looking at the mongoid source for that line, you can see that they call .on_event. My guess is that the code that ties Passenger into rails for using rails server loads things differently than the actual passenger command, causing .on_event to not be defined at that point in loading, and that is the reason for this not working.

@OnixGH

This comment has been minimized.

Copy link
Contributor

commented Mar 10, 2016

Thanks for the report, our preliminary conclusion is the same, we'll schedule this one.

@OnixGH OnixGH added this to the 5.0.27 milestone Mar 22, 2016

OnixGH pushed a commit that referenced this issue Mar 30, 2016

Daniel Knoppel (Phusion)

@OnixGH OnixGH closed this in a96055f Apr 4, 2016

@OnixGH OnixGH modified the milestones: 5.0.28, 5.0.27 Apr 7, 2016

@OnixGH OnixGH reopened this Apr 7, 2016

@OnixGH

This comment has been minimized.

Copy link
Contributor

commented Apr 7, 2016

fcf173e was missing to complete the fix.

@OnixGH OnixGH closed this Jun 17, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.