New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Ubuntu 18.04 packages fail to install #2122

Closed
FooBarWidget opened this Issue Sep 20, 2018 · 2 comments

Comments

Projects
None yet
4 participants
@FooBarWidget
Member

FooBarWidget commented Sep 20, 2018

We should release the next version asap and rebuild our packages.

The following packages have unmet dependencies:
 libnginx-mod-http-passenger : Depends: nginx-common (= 1.14.0-0ubuntu1) but 1.14.0-0ubuntu1.1 is to be installed
E: Unable to correct problems, you have held broken packages.
@tmb

This comment has been minimized.

Show comment
Hide comment
@tmb

tmb Sep 20, 2018

Having the same issue on Ubuntu 18.04.01 LTS

tmb commented Sep 20, 2018

Having the same issue on Ubuntu 18.04.01 LTS

@hamiltonc

This comment has been minimized.

Show comment
Hide comment
@hamiltonc

hamiltonc Sep 20, 2018

As a workaround while they rebuild passenger, you can install the old version with:

sudo apt install \
libnginx-mod-http-auth-pam=1.14.0-0ubuntu1 \
libnginx-mod-http-cache-purge=1.14.0-0ubuntu1 \
libnginx-mod-http-dav-ext=1.14.0-0ubuntu1 \
libnginx-mod-http-echo=1.14.0-0ubuntu1 \
libnginx-mod-http-fancyindex=1.14.0-0ubuntu1 \
libnginx-mod-http-geoip=1.14.0-0ubuntu1 \
libnginx-mod-http-headers-more-filter=1.14.0-0ubuntu1 \
libnginx-mod-http-image-filter=1.14.0-0ubuntu1 \
libnginx-mod-http-lua=1.14.0-0ubuntu1 \
libnginx-mod-http-ndk=1.14.0-0ubuntu1 \
libnginx-mod-http-perl=1.14.0-0ubuntu1 \
libnginx-mod-http-subs-filter=1.14.0-0ubuntu1 \
libnginx-mod-http-uploadprogress=1.14.0-0ubuntu1 \
libnginx-mod-http-upstream-fair=1.14.0-0ubuntu1 \
libnginx-mod-http-xslt-filter=1.14.0-0ubuntu1 \
libnginx-mod-mail=1.14.0-0ubuntu1 \
libnginx-mod-nchan=1.14.0-0ubuntu1 \
libnginx-mod-stream=1.14.0-0ubuntu1 \
nginx-common=1.14.0-0ubuntu1 \
nginx-core=1.14.0-0ubuntu1 \
nginx=1.14.0-0ubuntu1

You will have to uninstall the new version before trying the command above.

hamiltonc commented Sep 20, 2018

As a workaround while they rebuild passenger, you can install the old version with:

sudo apt install \
libnginx-mod-http-auth-pam=1.14.0-0ubuntu1 \
libnginx-mod-http-cache-purge=1.14.0-0ubuntu1 \
libnginx-mod-http-dav-ext=1.14.0-0ubuntu1 \
libnginx-mod-http-echo=1.14.0-0ubuntu1 \
libnginx-mod-http-fancyindex=1.14.0-0ubuntu1 \
libnginx-mod-http-geoip=1.14.0-0ubuntu1 \
libnginx-mod-http-headers-more-filter=1.14.0-0ubuntu1 \
libnginx-mod-http-image-filter=1.14.0-0ubuntu1 \
libnginx-mod-http-lua=1.14.0-0ubuntu1 \
libnginx-mod-http-ndk=1.14.0-0ubuntu1 \
libnginx-mod-http-perl=1.14.0-0ubuntu1 \
libnginx-mod-http-subs-filter=1.14.0-0ubuntu1 \
libnginx-mod-http-uploadprogress=1.14.0-0ubuntu1 \
libnginx-mod-http-upstream-fair=1.14.0-0ubuntu1 \
libnginx-mod-http-xslt-filter=1.14.0-0ubuntu1 \
libnginx-mod-mail=1.14.0-0ubuntu1 \
libnginx-mod-nchan=1.14.0-0ubuntu1 \
libnginx-mod-stream=1.14.0-0ubuntu1 \
nginx-common=1.14.0-0ubuntu1 \
nginx-core=1.14.0-0ubuntu1 \
nginx=1.14.0-0ubuntu1

You will have to uninstall the new version before trying the command above.

FooBarWidget added a commit to phusion/passenger_apt_automation that referenced this issue Sep 21, 2018

Latest Nginx version detection via Launchpad: fetch from Updates and …
…Security pockets too

phusion/passenger#2122 is caused by the fact that we only
fetch from the Release pocket, which only contains 1.14.0-0ubuntu1. 1.14.0-0ubuntu1
is in the Updates pocket.

FooBarWidget added a commit that referenced this issue Sep 21, 2018

@CamJN CamJN removed the SupportCentral label Oct 17, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment