New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Installation on Ubuntu 18.04 fails #2140

rwky opened this Issue Nov 8, 2018 · 3 comments


None yet
2 participants

rwky commented Nov 8, 2018

This appears to be the same issue as #2122 which is now closed

 libnginx-mod-http-passenger : Depends: nginx-common (= 1.14.0-0ubuntu1.1) but 1.14.0-0ubuntu1.2 is to be installed

Have you thought about using a >= in the control file instead of = ?

rwky added a commit to rwky/phusion-passenger that referenced this issue Nov 8, 2018


This comment has been minimized.


FooBarWidget commented Nov 9, 2018

Nginx has no stable ABI, so >= does not ensure compatibility. Having said that, I'm trying to come up with a way to lock down to a specific minor version of Nginx while ignoring distro-specific patch versions (i.e. locking down to nginx-common >= 1.14.0, < 1.14.1)


This comment has been minimized.

rwky commented Nov 9, 2018

You should be able to do something like this:

nginx-common >= 1.14.0, nginx-common << 1.14.1 that should do the trick

FooBarWidget added a commit to phusion/passenger_apt_automation that referenced this issue Nov 10, 2018

libnginx-mod-http-passenger: allow nginx-common dependency distro upd…

Nginx has no stable ABI, so we used to depend on the exact
nginx-common version that we built the package against,
e.g. nginx-common = 1.14.0-0ubuntu1.
However the distribution could release package updates
without bumping the software version. For example Ubuntu Bionic
has in the past 2 months released two updates:
nginx-common 1.14.0-0ubuntu1.1
nginx-common 1.14.0-0ubuntu1.2
On both cases, those updates broke our libnginx-mod-http-passenger
because they also removed the old nginx-common packages. See

We fix this issue by using two dependency specifiers. For example:
nginx-common >= 1.14.0-0ubuntu1.1 (at least the version we built against),
nginx-common << 1.14.1 (but not the next tiny version)

This comment has been minimized.


FooBarWidget commented Nov 10, 2018

Thanks @rwky. Will release asap.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment