Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Ubuntu 20.04 Focal now ships NGINX 1.18.0 #2291

Closed
excid3 opened this issue Jul 2, 2020 · 9 comments
Closed

Ubuntu 20.04 Focal now ships NGINX 1.18.0 #2291

excid3 opened this issue Jul 2, 2020 · 9 comments

Comments

@excid3
Copy link

excid3 commented Jul 2, 2020

Tried installing Passenger this morning got the following error:

 libnginx-mod-http-passenger : Depends: nginx-common (< 1.17.11) but 1.18.0-0ubuntu1 is to be installed

It seems that nginx-common in Ubuntu has now been updated to 1.18.0.

# apt-cache showpkg nginx-common
Package: nginx-common
Versions:
1.18.0-0ubuntu1 (/var/lib/apt/lists/mirrors.digitalocean.com_ubuntu_dists_focal-updates_main_binary-amd64_Packages)
 Description Language:
                 File: /var/lib/apt/lists/mirrors.digitalocean.com_ubuntu_dists_focal_main_binary-amd64_Packages
                  MD5: 9e23931d84d07adbee5412aefdad8a90
 Description Language: en
                 File: /var/lib/apt/lists/mirrors.digitalocean.com_ubuntu_dists_focal_main_i18n_Translation-en
                  MD5: 9e23931d84d07adbee5412aefdad8a90
 Description Language:
                 File: /var/lib/apt/lists/mirrors.digitalocean.com_ubuntu_dists_focal-updates_main_binary-amd64_Packages
                  MD5: 9e23931d84d07adbee5412aefdad8a90

1.17.10-0ubuntu1 (/var/lib/apt/lists/mirrors.digitalocean.com_ubuntu_dists_focal_main_binary-amd64_Packages)
 Description Language:
                 File: /var/lib/apt/lists/mirrors.digitalocean.com_ubuntu_dists_focal_main_binary-amd64_Packages
                  MD5: 9e23931d84d07adbee5412aefdad8a90
 Description Language: en
                 File: /var/lib/apt/lists/mirrors.digitalocean.com_ubuntu_dists_focal_main_i18n_Translation-en
                  MD5: 9e23931d84d07adbee5412aefdad8a90
 Description Language:
                 File: /var/lib/apt/lists/mirrors.digitalocean.com_ubuntu_dists_focal-updates_main_binary-amd64_Packages
                  MD5: 9e23931d84d07adbee5412aefdad8a90

Will you guys be compiling and releasing an updated package against this version soon?

@CamJN
Copy link
Contributor

CamJN commented Jul 2, 2020

Yes, we will.

@corneverbruggen
Copy link

corneverbruggen commented Jul 6, 2020

In the meantime, is there a known workaround to get nginx and passenger installed on Ubuntu 20.04?

@excid3
Copy link
Author

excid3 commented Jul 6, 2020

@corneverbruggen Yeah, specifically install the old version of nginx.

I'm using nginx-extras so I have to specify quite a few packages.

sudo apt install libnginx-mod-http-passenger nginx-extras=1.17.10-0ubuntu1 libnginx-mod-http-auth-pam=1.17.10-0ubuntu1 libnginx-mod-http-cache-purge=1.17.10-0ubuntu1 libnginx-mod-http-dav-ext=1.17.10-0ubuntu1 libnginx-mod-http-echo=1.17.10-0ubuntu1 libnginx-mod-http-fancyindex=1.17.10-0ubuntu1 libnginx-mod-http-geoip=1.17.10-0ubuntu1 libnginx-mod-http-geoip2=1.17.10-0ubuntu1 libnginx-mod-http-headers-more-filter=1.17.10-0ubuntu1 libnginx-mod-http-image-filter=1.17.10-0ubuntu1 libnginx-mod-http-lua=1.17.10-0ubuntu1 libnginx-mod-http-perl=1.17.10-0ubuntu1 libnginx-mod-http-subs-filter=1.17.10-0ubuntu1 libnginx-mod-http-uploadprogress=1.17.10-0ubuntu1 libnginx-mod-http-upstream-fair=1.17.10-0ubuntu1 libnginx-mod-http-xslt-filter=1.17.10-0ubuntu1 libnginx-mod-mail=1.17.10-0ubuntu1 libnginx-mod-nchan=1.17.10-0ubuntu1 libnginx-mod-stream=1.17.10-0ubuntu1 nginx-common=1.17.10-0ubuntu1 libnginx-mod-http-ndk=1.17.10-0ubuntu1

@corneverbruggen
Copy link

corneverbruggen commented Jul 6, 2020

Thanks, @excid3

@CamJN CamJN mentioned this issue Jul 6, 2020
@raphaelc0elh0
Copy link

raphaelc0elh0 commented Jul 14, 2020

Having the same problem here :(
Any updates yet?

@CamJN
Copy link
Contributor

CamJN commented Jul 14, 2020

6.0.6 released, with nginx 1.18.0 compat.

@Procuria
Copy link

Procuria commented Jul 29, 2020

2020-07-29_23h56_38

Hello, sorry for opening this again.

I'm on Ubuntu 20.04.1 LTS and using the NGINX-Repos (not the Ubuntu ones). As you can see in the screenshot, I'm on NGINX 1.18.0 and encounter the same problem as described above. I triple checked my passenger.list and I am on focal there as well. Would you be so kind to point me the direction ?

@CamJN
Copy link
Contributor

CamJN commented Jul 29, 2020

@Procuria yup: If you want to use our packaged Nginx module, you must use your distro's provided Nginx package. Since you have the repo provided by NGINX setup, you will instead need to compile a dynamic module compatible with that Nginx. Here are instructions to get you started: https://www.phusionpassenger.com/docs/advanced_guides/install_and_upgrade/nginx/install_as_nginx_module.html#dynamic-module

@Procuria
Copy link

Procuria commented Jul 29, 2020

@CamJN thank you very much for your fast, kind, detailed and helpful reply. It opens the possibilty to learn something new, which I like very much. I'd say case closed :)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

No branches or pull requests

6 participants