Rake package fails on rdoc under Ruby 1.9.1 #356

Closed
FooBarWidget opened this Issue May 29, 2014 · 1 comment

1 participant

@FooBarWidget
Phusion B.V. member

From deepjungle.maca on April 18, 2009 00:58:27

What steps will reproduce the problem? 1. install all deps
2. run rake package
3. look at error What is the expected output? What do you see instead? I'm trying to run rake package under Ruby 1.9.1 but without any success. It
seems to fail on rdoc.

deepj@popelnice-desktop:~/src/passenger$ rake package --trace
(in /home/deepj/src/passenger)
** Invoke package (first_time)
** Invoke doc (first_time)
** Invoke rdoc (first_time)
** Invoke doc/rdoc/index.html (first_time)
** Invoke README (first_time, not_needed)
** Invoke DEVELOPERS.TXT (first_time, not_needed)
** Invoke lib/phusion_passenger/admin_tools.rb (first_time, not_needed)
** Invoke lib/phusion_passenger/abstract_request_handler.rb (first_time,
not_needed)
** Invoke lib/phusion_passenger/html_template.rb (first_time, not_needed)
** Invoke lib/phusion_passenger/simple_benchmarking.rb (first_time, not_needed)
** Invoke lib/phusion_passenger/exceptions.rb (first_time, not_needed)
** Invoke lib/phusion_passenger/application.rb (first_time, not_needed)
** Invoke lib/phusion_passenger/platform_info.rb (first_time, not_needed)
** Invoke lib/phusion_passenger/abstract_installer.rb (first_time, not_needed)
** Invoke lib/phusion_passenger/dependencies.rb (first_time, not_needed)
** Invoke lib/phusion_passenger/utils.rb (first_time, not_needed)
** Invoke lib/phusion_passenger/abstract_server.rb (first_time, not_needed)
** Invoke lib/phusion_passenger/packaging.rb (first_time, not_needed)
** Invoke lib/phusion_passenger/constants.rb (first_time, not_needed)
** Invoke lib/phusion_passenger/events.rb (first_time, not_needed)
** Invoke lib/phusion_passenger/console_text_template.rb (first_time,
not_needed)
** Invoke lib/phusion_passenger/spawn_manager.rb (first_time, not_needed)
** Invoke lib/phusion_passenger/message_channel.rb (first_time, not_needed)
** Invoke lib/phusion_passenger/abstract_server_collection.rb (first_time,
not_needed)
** Invoke lib/phusion_passenger/railz/cgi_fixed.rb (first_time, not_needed)
** Invoke lib/phusion_passenger/railz/framework_spawner.rb (first_time,
not_needed)
** Invoke lib/phusion_passenger/railz/request_handler.rb (first_time,
not_needed)
** Invoke lib/phusion_passenger/railz/application_spawner.rb (first_time,
not_needed)
** Invoke lib/phusion_passenger/wsgi/application_spawner.rb (first_time,
not_needed)
** Invoke lib/phusion_passenger/rack/request_handler.rb (first_time,
not_needed)
** Invoke lib/phusion_passenger/rack/application_spawner.rb (first_time,
not_needed)
** Invoke lib/phusion_passenger/admin_tools/control_process.rb (first_time,
not_needed)
** Invoke misc/rake/extensions.rb (first_time, not_needed)
** Invoke ext/phusion_passenger/native_support.c (first_time, not_needed)
** Invoke Rakefile (first_time, not_needed)
** Execute doc/rdoc/index.html
rm -r doc/rdoc

README:
DEVELOPERS.TXT:
lib/phusion_passenger/admin_tools.rb: MMmm
lib/phusion_passenger/abstract_request_handler.rb: MCmmmmmmmmmmmmmmmm
lib/phusion_passenger/html_template.rb: MCmmmmmmmm
lib/phusion_passenger/simple_benchmarking.rb: C
lib/phusion_passenger/exceptions.rb: MCmCmCmCmCmC
lib/phusion_passenger/application.rb: MCmmm
lib/phusion_passenger/platform_info.rb: Mmmmmmmmmmmmmmmmmmmmmmmmmmmmmmm
lib/phusion_passenger/abstract_installer.rb: MCm
lib/phusion_passenger/abstract_installer.rb:38:56: ':' not followed by
identifier or operator
mmmmmmmmmmmmm
lib/phusion_passenger/dependencies.rb: MCM
lib/phusion_passenger/utils.rb: MMmmmmmmmmmmmmmmmmmCmCmmCmmmMmmmMm
lib/phusion_passenger/abstract_server.rb: MCCCCCmmmmmmmmmmmmmmmmm
lib/phusion_passenger/packaging.rb: Mm
lib/phusion_passenger/constants.rb: M
lib/phusion_passenger/events.rb: Mmmm
lib/phusion_passenger/console_text_template.rb: MCmmmm
lib/phusion_passenger/spawn_manager.rb: MCmmmmmmmmmmm
lib/phusion_passenger/message_channel.rb: MCmmmmmmmmmm
lib/phusion_passenger/abstract_server_collection.rb: MCmmmmmmmmmmmmmm
lib/phusion_passenger/railz/cgi_fixed.rb: MMCmmmmm
lib/phusion_passenger/railz/framework_spawner.rb: MMCCmmmmmmmm
lib/phusion_passenger/railz/framework_spawner.rb:254:69: Skipping require
of dynamic string: "#{@vendor}/railties/lib/initializer"
mm
lib/phusion_passenger/railz/request_handler.rb: MMCmmmm
lib/phusion_passenger/railz/application_spawner.rb: MMCCmmmmmmmmmm
lib/phusion_passenger/wsgi/application_spawner.rb: MMCmmm
lib/phusion_passenger/rack/request_handler.rb: MMCmm
lib/phusion_passenger/rack/application_spawner.rb: MMCmmmm
lib/phusion_passenger/admin_tools/control_process.rb: MMCCmmmmmmmm
misc/rake/extensions.rb: MmC
ext/phusion_passenger/native_support.c: MMmmmmmm
Generating HTML...
rake aborted!
wrong constant name ./DOC/TEMPLATE/HORO
/usr/local/lib/ruby/1.9.1/rdoc/generator/html.rb:115:in const_get'
/usr/local/lib/ruby/1.9.1/rdoc/generator/html.rb:115:in
load_html_template'
/usr/local/lib/ruby/1.9.1/rdoc/generator/html.rb:70:in initialize'
/usr/local/lib/ruby/1.9.1/rdoc/generator/html.rb:56:in
new'
/usr/local/lib/ruby/1.9.1/rdoc/generator/html.rb:56:in for'
/usr/local/lib/ruby/1.9.1/rdoc/rdoc.rb:271:in
document'
/home/deepj/src/passenger/misc/rake/rdoctask.rb:140:in block in define'
/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.4/lib/rake.rb:617:in
call'
/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.4/lib/rake.rb:617:in block in
execute'
/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.4/lib/rake.rb:612:in
each'
/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.4/lib/rake.rb:612:in execute'
/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.4/lib/rake.rb:578:in
block in
invoke_with_call_chain'
/usr/local/lib/ruby/1.9.1/monitor.rb:190:in mon_synchronize'
/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.4/lib/rake.rb:571:in
invoke_with_call_chain'
/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.4/lib/rake.rb:588:in block in
invoke_prerequisites'
/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.4/lib/rake.rb:585:in
each'
/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.4/lib/rake.rb:585:in
invoke_prerequisites'
/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.4/lib/rake.rb:577:in
block in
invoke_with_call_chain'
/usr/local/lib/ruby/1.9.1/monitor.rb:190:in mon_synchronize'
/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.4/lib/rake.rb:571:in
invoke_with_call_chain'
/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.4/lib/rake.rb:588:in block in
invoke_prerequisites'
/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.4/lib/rake.rb:585:in
each'
/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.4/lib/rake.rb:585:in
invoke_prerequisites'
/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.4/lib/rake.rb:577:in
block in
invoke_with_call_chain'
/usr/local/lib/ruby/1.9.1/monitor.rb:190:in mon_synchronize'
/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.4/lib/rake.rb:571:in
invoke_with_call_chain'
/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.4/lib/rake.rb:588:in block in
invoke_prerequisites'
/usr/local/lib/ruby/gems/1.9.1/gems/rake-0.8.4/lib/rake.rb:585:in
eac...

Original issue: http://code.google.com/p/phusion-passenger/issues/detail?id=256

@FooBarWidget
Phusion B.V. member

From honglilai on May 24, 2011 00:30:46

Status: Fixed

Labels: Milestone-3.0.8

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment