Permalink
Switch branches/tags
Nothing to show
Commits on Dec 21, 2016
Commits on Dec 12, 2016
  1. Install openssl-devel in the CentOS 7 test box.

    It is necessary for some test to pass.
    FooBarWidget committed Dec 12, 2016
  2. Disable CentOS Continuous Release (CR)

    It is currently not necessary to enable it for RHEL compatibility.
    Besides, CR is broken today because they are on the verge of releasing
    CentOS 7.3.
    FooBarWidget committed Dec 12, 2016
  3. Fix a typo in the README

    FooBarWidget committed Dec 12, 2016
  4. Note: the last commit message has a typo

    It should be: Only support the 'targeted' SELinux policy variant.
    
    In this commit I removed a bunch of unnecessary triggers and
    added some comment reminders.
    FooBarWidget committed Dec 12, 2016
Commits on Dec 8, 2016
  1. Remove kernel 2.6.39 / policy version 25 requirement for CentOS 6

    Passenger now manually relabels files so this is no longer necessary.
    FooBarWidget committed Dec 8, 2016
  2. Update indenting

    FooBarWidget committed Dec 8, 2016
  3. Update SELinux policy variant support and improve installation error …

    …reporting
    
    Removed support for the mls and minimum variants. They don't contain either the
    unconfined_t or httpd_t type so there is no way we can make things work with them.
    
    Ensured that we don't install the Passenger SELinux policy file for any variants
    that we don't support.
    
    Ensured that we build Passenger SELinux policy files for a distro-specific static
    list of variants. The autodetection code was buggy.
    FooBarWidget committed Dec 8, 2016
Commits on Dec 6, 2016
Commits on Dec 5, 2016
  1. Improve SELinux policy installation error reporting

    We used to swallow all errors in order not to print errors
    when SELinux is disabled. We now display error messages,
    but just skip the installation of the policy if SELinux is
    disabled.
    FooBarWidget committed Dec 5, 2016
  2. Reset the package release number

    They only need to be bumped when releasing updates to the same package versions.
    FooBarWidget committed Dec 5, 2016
Commits on Nov 19, 2016
Commits on Nov 18, 2016
  1. Disallow running scripts as any user that conflicts with the user dat…

    …abase inside the container
    FooBarWidget committed Nov 18, 2016
  2. Revert "Disallow running scripts as root"

    This reverts commit 054d62d.
    FooBarWidget committed Nov 18, 2016
Commits on Apr 28, 2016
  1. Compatibility with Nginx 1.10.0

    Replace SPDY module with HTTP 2 module
    FooBarWidget committed Apr 28, 2016
Commits on Apr 26, 2016
Commits on Feb 29, 2016
Commits on Feb 3, 2016
Commits on Jan 25, 2016
  1. Check root certificate instead of leaf certificate, which changes too…

    … often and may even be different among servers
    FooBarWidget committed Jan 25, 2016
Commits on Dec 7, 2015
Commits on Nov 27, 2015
Commits on Nov 25, 2015
Commits on Oct 19, 2015
  1. Use NginxEngineCompiler.configure_script_options instead of STANDALON…

    …E_NGINX_CONFIGURE_OPTIONS
    FooBarWidget committed Oct 19, 2015
Commits on Sep 23, 2015
  1. Fix copying git submodules

    FooBarWidget committed Sep 23, 2015
  2. Fix indentation

    FooBarWidget committed Sep 23, 2015