Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

A convenience C++ wrapper library for JSON-Glib providing friendly syntactic sugar for parsing JSON

tree: cf31405b82

Fetching latest commit…

Cannot retrieve the latest commit at this time

README
This library is a wrapper for the json-glib library that aims tp provide the user with a trivial alternative API to the API provided by the base json-glib library.

This is an early version of the json-me (JSON made easy) project.

It has the following issues that I might fix in a later release. Given that I don't have much time to
work on project like this and given that my priorities lie with different projects, you may consider
it as a wishlist that if you like this library would make me very happy if you could contribute it:

After the 1.0 we may look at the following:

* See if we can get stuff compiling with the -Wold-style-cast flag set.
* I didn't find a list of the Gtype's that json-glib can produce, there are probably some pieces of 
  dead code in gobj/GobjectImplScalar.cpp and there might be one missing.
* The CMakeLists.txt doesn't look for its dependencies and just adds -I flags that happen to be right 
  on Ubuntu 11.4. Should do some real checking.
* I didn't create non of the operator<< stuff for making usage ostream usage easy. Tried to for half 
  an hour and kept getting useless messages from my compiler. Should make the library even more 
  friendly if we could fix this.
* Currently only parsing is supported. We should expand the API to support 'creating' json strings and files.

Seeing the above list, if you feel like fixing any of these issues, please feel free to do so and send  me your patches if you do.

To build jsonme, take the following steps:

 cd build

 cmake ..

 make

 make test

The last step should depend on the platform you are on. If you don't hapen to be on a amd64 ubuntu linux platform, the following step 
should be appropriate:

 sudo make install

For amd64 ubuntu linux you may alternatively run: 

  cd ..
  ./makedepstuff.sh
  dpkg -i jsonme++_0.9.0-1_amd64.deb
Something went wrong with that request. Please try again.