Skip to content
SAP RFC Connector using the SAP NW RFC SDK for Ruby
Ruby C Makefile Shell
Find file
New pull request
Latest commit a15762d @piersharding Merge pull request #6 from GyldendalDigital/fix_utf8_encoding_for_rub…

Fix utf8 encoding for ruby 191 and later
Failed to load latest commit information.
doc removed obsolete cflag - thanks Gregor
ext/nwsaprfc Ensure all strings are marked with UTF-8 encoding.
lib updated C
test removed obsolete cflag - thanks Gregor
tools initial commit
ChangeLog removed obsolete cflag - thanks Gregor
MANIFEST Added library version singleton
README updated C
alternate_sap.yml initial commit
doco initial commit initial commit
metaconfig initial commit removed obsolete cflag - thanks Gregor
run_tests.rb Fix return buffer for 4 byte chars
sap.yml Fix return buffer for 4 byte chars
sapnw-0.01.tar.gz initial commit
sapnw-0.02.tar.gz initial commit
sapnwrfc-0.02.tar.gz initial commit
sapnwrfc-0.03.tar.gz initial commit initial commit
sapnwrfc-0.04.tar.gz initial commit initial commit
sapnwrfc-0.05.tar.gz initial commit initial commit
sapnwrfc-0.06.tar.gz initial commit initial commit
sapnwrfc-0.07.tar.gz initial commit initial commit
sapnwrfc-0.08.tar.gz initial commit initial commit
sapnwrfc-0.09.tar.gz initial commit initial commit
sapnwrfc-0.10.tar.gz initial commit initial commit
sapnwrfc-0.11.tar.gz initial commit initial commit
sapnwrfc-0.12.tar.gz initial commit initial commit
sapnwrfc-0.15.tar.gz initial commit initial commit
sapnwrfc-0.16.tar.gz initial commit initial commit
sapnwrfc-0.17.tar.gz initial commit initial commit
sapnwrfc-0.18.tar.gz initial commit initial commit
sapnwrfc-0.19.tar.gz initial commit initial commit
sapnwrfc-0.20.tar.gz initial commit initial commit
sapnwrfc-0.21.tar.gz initial commit initial commit
sapnwrfc-0.22.tar.gz initial commit initial commit
sapnwrfc-0.23.tar.gz initial commit initial commit
sapnwrfc.linux.gemspec Bugfix missing library required for extension compilation during gem …
sapnwrfc.mswin32.gemspec removed obsolete cflag - thanks Gregor
setup.rb Use RbConfig instead of obsolete and deprecated Config
stfc_connection.rb initial commit
testcall.rb initial commit


= sapnwrfc - SAP Netweaver RFC support for Ruby - the next generation

== Summary

Welcome to the sapnwrfc Ruby package.  This package is intended to facilitate RFC calls to an SAP R/3 system of release NW2004x and above.  It may work for earlier versions but it hasn't been tested.
The fundamental purpose of the production of this package, is to provide a clean object oriented interface to RFC calls from within Ruby.  This will hopefully have a number of effects:
(1) make it really easy to do RFC calls to SAP from Ruby in an object oriented fashion (Doh!)
(2) promote Ruby as the interface/scripting/glue language of choice for interaction with SAP R/3.
(3) make the combination of Linux, Apache, and Ruby the killer app for internet connectivity with SAP.
(4) Establish a small fun open source project that people are more than welcome to contribute to, if they so wish.

== Installation

After you have unpacked your kit, you should have all the files listed
in the MANIFEST.

In brief, the following should work on most systems:
  ruby setup.rb 

if your rfcsdk is not findable in the system search path, then use the command line switches
for mkmf/setup.rb like so:
ruby setup.rb config  --with-nwrfcsdk-dir=/path/to/rfcsdk
ruby setup.rb setup

Now you can either install like so:
ruby setup.rb install

or build the gem and install that like so:
gem build sapnwrfc.linux.gemspec
gem uninstall sapnwrfc
gem install sapnwrfc-<version>-<architecture>.gem 

VERY IMPORTANT - make sure that you add the library path to LD_LIBRARY_PATH
eg - mine is:
 export LD_LIBRARY_PATH=/home/piers/code/sap/nwrfcsdk/lib

== Documents and Tests

   Module Documentation

   Test basic connection, and some rfc call examples

== Credits

== License

sapnwrfc is Copyright (c) 2006-2010 Piers Harding.  It is free software, and
may be redistributed under the terms specified in the README file of
the Ruby distribution.

One last thing - The SAP RFCSDK is a prerequisite for this perl package to work.  The RFCSDK is proprietrary software owned by SAP AG.  For this reason I will not supply ANY component part of the RFCSDK with this perl package, and further more you must obtain it through the normal channels with SAP AG - ie. you must have a licensed SAP R/3 installation at your disposal.

= Other stuff

Author::   Piers Harding <>
Requires:: Ruby 1.8.x or later
License::  Copyright (c) 2006-2010 Piers Harding
           Released under Ruby's License
Something went wrong with that request. Please try again.