Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 48 lines (43 sloc) 1.498 kb
ffac8a6 @tonyg Update licensing to dual MPL/GPL
tonyg authored
1 # ***** BEGIN LICENSE BLOCK *****
2 #
4085f5c @majek Simpify license even more.
majek authored
3 # For copyright and licensing please refer to COPYING.
ffac8a6 @tonyg Update licensing to dual MPL/GPL
tonyg authored
4 #
5 # ***** END LICENSE BLOCK *****
6
f596386 @tonyg Switch from distutils to setuptools, for develop support
tonyg authored
7 from setuptools import setup
d514dce @tonyg Initial revision
tonyg authored
8 import os
9
10 try:
9f79520 @tonyg The great renaming
tonyg authored
11 os.stat("pika/spec.py")
d514dce @tonyg Initial revision
tonyg authored
12 except:
13 import sys
87ebdc1 Update the setup.py to reflect the maintainer and current version, clean...
Gavin M. Roy authored
14 print >> sys.stderr, \
15 'Autogenerated spec.py not found -- run "make sandbox" first!'
d514dce @tonyg Initial revision
tonyg authored
16 sys.exit(1)
17
acb0230 @tonyg Further changes for pypi
tonyg authored
18 long_description = """\
d46c10a Add the adapters package
Gavin M. Roy authored
19 Pika is a pure-Python implementation of the AMQP 0-9-1 protocol that
20 tries to stay fairly independent of the underlying network support
21 library. Pika was developed primarily for use with RabbitMQ, but
859b1a7 Update the version number to 0.9a
Gavin M. Roy authored
22 should also work with other AMQP 0-9-1 brokers.
acb0230 @tonyg Further changes for pypi
tonyg authored
23 """
24
9f79520 @tonyg The great renaming
tonyg authored
25 setup(name='pika',
9109379 Add that its zip safe
Gavin M. Roy authored
26 version='0.9.5b',
9f79520 @tonyg The great renaming
tonyg authored
27 description='Pika Python AMQP Client Library',
acb0230 @tonyg Further changes for pypi
tonyg authored
28 long_description=long_description,
d514dce @tonyg Initial revision
tonyg authored
29 author='Tony Garnock-Jones',
acb0230 @tonyg Further changes for pypi
tonyg authored
30 author_email='tonygarnockjones@gmail.com',
87ebdc1 Update the setup.py to reflect the maintainer and current version, clean...
Gavin M. Roy authored
31 maintainer='Gavin M. Roy',
32 maintainer_email='gmr@myyearbook.com',
02d2585 @tonyg Update github.com/tonyg/pika -> github.com/pika/pika
tonyg authored
33 url='http://pika.github.com/',
d46c10a Add the adapters package
Gavin M. Roy authored
34 packages=['pika', 'pika.adapters'],
acb0230 @tonyg Further changes for pypi
tonyg authored
35 license='MPL v1.1 and GPL v2.0 or newer',
36 classifiers=[
175ab49 Update the values in the setup.py file
Gavin M. Roy authored
37 'Development Status :: 3 - Alpha',
acb0230 @tonyg Further changes for pypi
tonyg authored
38 'Intended Audience :: Developers',
39 'License :: OSI Approved :: GNU General Public License (GPL)',
40 'License :: OSI Approved :: Mozilla Public License 1.1 (MPL 1.1)',
41 'Operating System :: OS Independent',
42 'Topic :: Communications',
43 'Topic :: Internet',
44 'Topic :: Software Development :: Libraries',
45 ],
9109379 Add that its zip safe
Gavin M. Roy authored
46 zip_safe=True
d514dce @tonyg Initial revision
tonyg authored
47 )
Something went wrong with that request. Please try again.