New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Python 3.7.0 support #1107

Closed
lukebakken opened this Issue Jul 31, 2018 · 0 comments

Comments

Projects
None yet
1 participant
@lukebakken
Contributor

lukebakken commented Jul 31, 2018

There appear to be non-compatible changes in the ssl module. Travis CI should be updated as well.

@lukebakken lukebakken added this to the 1.0.0 milestone Jul 31, 2018

@lukebakken lukebakken self-assigned this Jul 31, 2018

@lukebakken lukebakken modified the milestones: 1.0.0, 0.13.0 Oct 29, 2018

lukebakken added a commit that referenced this issue Oct 29, 2018

Better parsing of URL parameter "ssl_options"
Due to the fact that `wrap_socket` is deprecated in Python 3.7, we can no longer use the old method of translating URL options to valid SSLContext options.

Fixes #1107

lukebakken added a commit that referenced this issue Nov 5, 2018

Better parsing of URL parameter "ssl_options"
Due to the fact that `wrap_socket` is deprecated in Python 3.7, we can no longer use the old method of translating URL options to valid SSLContext options.

Fixes #1107
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment