Permalink
Browse files

Merge pull request #15 from richardclegg/master

Correction to error in configure script
  • Loading branch information...
2 parents c6bab4c + d6db2e6 commit 76da04134b9eb3a9ca4252e9cb41d412b50a072a @pikatchu committed Nov 9, 2014
Showing with 8 additions and 8 deletions.
  1. +8 −8 configure
View
@@ -238,7 +238,7 @@ if test "$llbindings"; then
if ! test -e $llvm_target_cma; then
echo "Couldn't find: $llvm_target_cma"; exit 2;
fi
-else $llbindings=$(ocamlc -where)
+else llbindings=$(ocamlc -where)
fi
if test -z "$llbindings"; then
@@ -322,55 +322,55 @@ fi
echo ""
llc_version=`$llc -version | grep version` ;
-if [[ "$llc_version" =~ .*version.3.[0|1].* ]]; then
+if [[ "$llc_version" =~ .*version.3.*.* ]]; then
echo -e "Checking llc \t: OK$llc_version"
else
echo "Bad version of llc (expected version 2.8): $version" 2>&1;
exit 2
fi
opt_version=`$opt -version | grep version` ;
-if [[ "$opt_version" =~ .*version.3.[0|1].* ]]; then
+if [[ "$opt_version" =~ .*version.3.*.* ]]; then
echo -e "Checking opt \t: OK$opt_version"
else
echo "Bad version of opt (expected version 3.0): $version" 2>&1;
exit 2
fi
ocamlc_version=`$ocamlc -version` ;
-if [[ "$ocamlc_version" =~ 4.00.* ]]; then
+if [[ "$ocamlc_version" =~ 4.0[0|1].* ]]; then
echo -e "Checking ocamlc \t: OK $ocamlc_version"
else
echo "Bad version of ocamlc (< 3.11): $version" 2>&1;
exit 2
fi
ocamlopt_version=`$ocamlopt -version` ;
-if [[ "$ocamlopt_version" =~ 4.00.* ]]; then
+if [[ "$ocamlopt_version" =~ 4.0[0|1].* ]]; then
echo -e "Checking ocamlopt\t: OK $ocamlopt_version"
else
echo "Bad version of ocamlopt (< 3.11): $version" 2>&1;
exit 2
fi
ocamllex_version=`$ocamllex -version` ;
-if [[ "$ocamllex_version" =~ 4.00.* ]]; then
+if [[ "$ocamllex_version" =~ 4.0[0|1].* ]]; then
echo -e "Checking ocamllex\t: OK $ocamllex_version"
else
echo "Bad version of ocamllex (< 4.00): $version" 2>&1;
exit 2
fi
ocamlyacc_version=`$ocamlyacc -version` ;
-if [[ "$ocamlyacc_version" =~ 4.00.* ]]; then
+if [[ "$ocamlyacc_version" =~ 4.0[0|1].* ]]; then
echo -e "Checking ocamlyacc\t: OK $ocamlyacc_version"
else
echo "Bad version of ocamlyacc (< 3.11): $version" 2>&1;
exit 2
fi
ocamldep_version=`$ocamldep -version` ;
-if [[ "$ocamldep_version" =~ 4.00.* ]]; then
+if [[ "$ocamldep_version" =~ 4.0[0|1].* ]]; then
echo -e "Checking ocamldep\t: OK $ocamldep_version"
else
echo "Bad version of ocamldep (< 3.11): $version" 2>&1;

0 comments on commit 76da041

Please sign in to comment.