Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

is compatible with rails 3.2.1?? #55

Open
ArmandoMendoza opened this Issue · 11 comments

9 participants

@ArmandoMendoza

Hi web-app-theme is compatible with rails 3.2.1 and asset pipeline?? I can't run bundle command. I recived this message:

In Gemfile:
web-app-theme (~> 0.8.0) ruby depends on
rails (~> 3.1.0.rc6) ruby

I use rails 3.2.1 and ruby 1.9.3-p0.

@RobertAudi

I have the same issue...

@bryanrite

Noticed the code has been updated, but not yet released/tagged, you can use this directly by putting this in your Gemfile:

gem 'web-app-theme', git: 'git://github.com/pilu/web-app-theme.git'

@arojoal

The line above is not correct, you have to use this instead:

gem 'web-app-theme', :git =>'git://github.com/pilu/web-app-theme.git'
@spletta

ty

@atejeda

The same issue, still and persists in 3.2.x

@ArmandoMendoza

Putting in the gem file the line submitted by bryanrite... work in rails 3.2.x at least for me.

@sheam

bryanrite's solution allows the gem to be installed, but it is still not really functional. Pages all throw an error because they are unable to find public/javascripts/defaults.js, as well they can't find css files. There doesn't seem to be much activity on the project either...

@viniciuscb

sheam dont worry, you will have to change the <%= javascript_include_tag ..... %> in the newly created layout file, to be

<%= javascript_include_tag "application" %>

my rails is 3.2.3, and it worked wonderfully! For the usual programmer that does not design this gem is essential... I have found no other that worked.

@sheam

Thanks @viniciuscb, will try this tonight.

@mattconnolly

I also had to change the stylesheet tags. I used this:

<%= stylesheet_link_tag :application %>
<%= javascript_include_tag :application %>

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.