New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[pimatic-mobile-fronted] Can't connect / authenticate in webinterface #129

Closed
sweetpi opened this Issue Apr 16, 2014 · 5 comments

Comments

Projects
None yet
4 participants
@sweetpi
Contributor

sweetpi commented Apr 16, 2014

Please first try if it is working in a private / incognito window of your web browser. If its working, it is probably a issue with the cached browser data.

Be sure to clear all cached "hosted application data" in your browser.

Chrome / Firefox / Internet Explorer: Ctrl+shift+delete (Is just working if a website is opened)
Safari: Ctrl+alt+ e
More help about clearing the browser cache

If it is still not working please ask here or open another issue. Please check if there are any errors in your javaScript console and post them with your browser and pimatic version here. See also How to open the JavaScript console

@sweetpi sweetpi added the Q&A label Apr 16, 2014

@sweetpi sweetpi closed this Apr 16, 2014

@Atompfirsich

This comment has been minimized.

Atompfirsich commented Oct 17, 2014

I cannot connect to the webinterface. I tried all your tips you've wrote above. So i looked up the log File and found the Problem. It seems something is missing.

17:10:49.226 [pimatic] info: Starting pimatic version 0.8.21
17:10:51.216 [pimatic] error: Cannot find module '/home/pi/pimatic-app/node_modules/sqlite3/lib/binding/node-v11-linux-arm/node_sqlite3.node'

Maybe you can help me.
Chris

@incmve

This comment has been minimized.

Contributor

incmve commented Oct 17, 2014

Stop pimatic, remove the sqlite3 directory and start pimatic.

@Atompfirsich

This comment has been minimized.

Atompfirsich commented Oct 17, 2014

Thank you!

@wucht

This comment has been minimized.

wucht commented Dec 26, 2014

I can't also not access the webinterface,
do have any idea why it doesn't work?
if i acces the http://ip:80 i see after the login procedure the following message in the browser window:
Cannot GET /

13:59:03.778 2014-12-26 Friday
13:59:14.672 [pimatic] info: Starting pimatic version 0.8.30
13:59:19.144 [pimatic] info: loading plugin: "pimatic-cron" (0.8.3)
13:59:19.973 [pimatic] info: loading plugin: "pimatic-mobile-frontend" (0.8.29)
13:59:24.640 [pimatic] error: Cannot find module 'jqmthemer'
13:59:26.197 [pimatic-cron] info: the time is: Fri Dec 26 2014 13:59:26 GMT+0100 (CET)
13:59:26.384 [pimatic] info: listening for http-request on port 80...

@sweetpi

This comment has been minimized.

Contributor

sweetpi commented Dec 26, 2014

Give it some more time, it is till building the sqlite3 lib.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment