Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Incorrect values of breadcrumb & navigation shown when Full Page Cache is enabled. #5024

Closed
avinashpimcore opened this issue Sep 30, 2019 · 2 comments

Comments

@avinashpimcore
Copy link

commented Sep 30, 2019

Upon enabling full page cache with 3600 sec lifetime, pimcore navigation (pimcore_build_nav) doesn't work properly if it called from any snippet. It is working fine if we place navigation directly in the layout file.

It can be reproduced with demo-twig instance after enabling full page cache and setting the lifetime to any bigger value. Also, need to place the breadcrumb in any snippet.

@avinashpimcore avinashpimcore changed the title Incorrect values of breadcrumb & navigation show when Full Page Cache is enabled. Incorrect values of breadcrumb & navigation shown when Full Page Cache is enabled. Sep 30, 2019
@dvesh3

This comment has been minimized.

Copy link
Contributor

commented Sep 30, 2019

can you please explain "doesn't work properly!" issue in detail? thanks!

@dvesh3

This comment has been minimized.

Copy link
Contributor

commented Oct 10, 2019

Snippets are master for multiple pages so if you using pimcore_inc in your layout file to include snippets please provide extra param for output cache hashing https://pimcore.com/docs/5.x/Development_Documentation/MVC/Template/Templating_Helpers/index.html#page_section_17
e.g.

pimcore_inc(document, {current_document_id: 123});
@dvesh3 dvesh3 closed this Oct 10, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.