Permalink
Browse files

Added libgweather, missing dependency for evolution-data-server, fixes

  • Loading branch information...
1 parent 9a31471 commit 3007d592c7056e1c30f0801ec81330ada73d1c55 @pimvullers committed Sep 28, 2012
Showing with 53 additions and 0 deletions.
  1. +2 −0 dev-libs/libgweather/Manifest
  2. +51 −0 dev-libs/libgweather/libgweather-3.5.92.ebuild
@@ -0,0 +1,2 @@
+DIST libgweather-3.5.92.tar.xz 3892772 SHA256 1f1dc6abf9dcfa38d663a4aadfc91a43bc7a5d1dd12ac68f6412c35bc40622cf SHA512 ba93b5837cb0d0d2038a523d1a06a807f25e5ca71cdd74fdb6604c3ae8dbc3577fbdf34950194de517a6887483c821bb4c2e57dcb9c83123b48acb052a74e306 WHIRLPOOL 89be9e40f9c16b2698bbeabe5cab696e5f35611780f4b619ccfe973b9728595ac5cd50316ce567cafb4d986d8b1b405cb00879ca15b8f0d275138c67d3b6f5f8
+EBUILD libgweather-3.5.92.ebuild 1449 SHA256 30d6c15f6d9475a1fc0cd1773e51981e49b06f27a834112b4f4d9a8c16ece141 SHA512 41c188c9cedc8aee7e8c8c2d4b26dc54e6aa0dd083b6b6f76b11b5577e4f670175c9583a6ba37716b07851c4fe3ede811edd2b2bdda5f97fd189911445f0fc6c WHIRLPOOL 5c70e44fe61d2aeb66bfdcdcfd30db95e4431a1839c92a3abebf8fa9e2729200fbcd0073a012f48eec78db54adca2be109826b9c0bc449d3ceb06e04f59a37d2
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/libgweather-2.30.3.ebuild,v 1.3 2010/11/14 23:05:07 eva Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+fi
+
+DESCRIPTION="Library to access weather information from online services"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="2"
+IUSE="+introspection doc"
+if [[ ${PV} = 9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+fi
+
+# libsoup-gnome is to be used because libsoup[gnome] might not
+# get libsoup-gnome installed by the time ${P} is built
+COMMON_DEPEND=">=x11-libs/gtk+-2.90.0:3[introspection?]
+ >=dev-libs/glib-2.13
+ >=net-libs/libsoup-gnome-2.25.1:2.4
+ >=dev-libs/libxml2-2.6.0
+ >=sys-libs/timezone-data-2010k
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.50
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.9 )"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-base/gnome-applets-2.22.0"
+# eautoreconf requires >=dev-util/gtk-doc-am-1.11
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS"
+ # Do not add --disable-all-translations-in-one-xml : it will enable them
+ G2CONF="${G2CONF}
+ --enable-locations-compression
+ --disable-static
+ $(use_enable introspection)"
+}

0 comments on commit 3007d59

Please sign in to comment.