Skip to content
This repository
Newer
Older
100644 27 lines (21 sloc) 0.834 kb
01b53cf2 »
2008-01-17 Version 0.13
1 #!/usr/bin/env python
cc69c85d »
2008-02-14 Use utf-8 instead of UTF-8 in biscuits
2 # -*- coding: utf-8 -*-
01b53cf2 »
2008-01-17 Version 0.13
3
3fa2a325 »
2010-11-01 New p4 script (Poor Python Pre Processor). Use it!
4 import sys
6a00ffbe »
2010-10-30 Consider case when Distutils is not available
5
6 try:
7 from distutils.core import setup
8 except ImportError:
9 sys.stderr.write("""\
10
11 .------------------------------------------------------------------------.
12 | It seems that the package Distutils is not available for this Python. |
13 | You might fetch and install Distutils and retry your command, or else, |
14 | figure out where the Pymacs/ directory should go, and make that copy. |
15 `------------------------------------------------------------------------'
16
17 """)
18 sys.exit(1)
19
3fa2a325 »
2010-11-01 New p4 script (Poor Python Pre Processor). Use it!
20 package = 'Pymacs'
016b0bc9 »
2010-11-14 Bump version to 0.24-beta2
21 version = '0.24-beta2'
3fa2a325 »
2010-11-01 New p4 script (Poor Python Pre Processor). Use it!
22
b7ad9007 »
2008-02-09 Drive version from setup.py instead of from Makefile
23 setup(name=package, version=version,
8c1972db »
2009-07-05 setup.py: No period at end of description
24 description="Interface between Emacs Lisp and Python",
add81b65 »
2008-01-21 Switch to UTF-8
25 author='François Pinard', author_email='pinard@iro.umontreal.ca',
5d291864 »
2008-01-21 Bump protocol to 0.23, typo in URL
26 url='http://pymacs.progiciels-bpi.ca',
9cc68f76 »
2012-01-24 Pymacs.py.in replaces all of Pymacs/.
27 py_modules=['Pymacs'])
Something went wrong with that request. Please try again.