Permalink
Commits on Jul 5, 2013
  1. Merge branch 'quattor-13.6'

    piojo committed Jul 5, 2013
    Merge release branch
Commits on Jul 4, 2013
  1. Merge pull request #25 from piojo/fix-ksinstall

    Luis Fernando Muñoz Mejías committed Jul 4, 2013
    Disable some repositories during the %post phase
  2. Fix basic type

    piojo committed Jul 4, 2013
Commits on Jun 19, 2013
  1. Fix the header of the ks generator

    piojo committed Jun 19, 2013
Commits on Jun 15, 2013
  1. Merge pull request #24 from piojo/pom-fixes

    ned21 committed Jun 15, 2013
    Remove references to LAPP repositories.
Commits on Jun 14, 2013
  1. Document the disabled_repos field.

    piojo committed Jun 12, 2013
Commits on Jun 11, 2013
  1. Call ksinstall_rpm with the correct arguments.

    piojo committed Jun 11, 2013
    The first argument (and package) was being consumed as a $config.
    
    The function doesn't use $config anymore, but is exported by hooks and
    we mustn't change the API.
Commits on Jun 5, 2013
  1. Merge pull request #22 from piojo/more-diags

    jrha committed Jun 5, 2013
    Display why the profiles-info fails to download.
  2. Untabify.

    piojo committed Jun 5, 2013
Commits on May 14, 2013
  1. perl-Compress-Zlib is not needed

    dzila committed May 14, 2013
    perl-Compress-Zlib causes conflicts during installation if a new errata is also applied. Quoting Orlin:
    I'm having a problem installing WNs with SL 6.4 when the latest errata is used.
    
    Basically the default version of perl-Compress-Zlib for SL6.4 which is used by Quattor during installation is 129.el6.x86_64.
    
    The problem is that if errata 20130426 is used the kickstart tries to force installation of:
    
    perl-Compress-Zlib-0:2.020-130.el6_4.x86_64
    
    As other version of Perl is already installed on the WNs there are dependency issues & conflicts:
    
    error: Failed dependencies:
    >         perl = 4:5.10.1-130.el6_4 is needed by
    > perl-Compress-Zlib-0:2.020-130.el6_4.x86_64
    > Quattor installation on  failed: Failed to install
    > perl-Compress-Zlib-2.020-130.el6_4.x86_64.rpm: 1
    
    The workaround which fixes this issue is removing
    perl-Compress-Zlib-0:2.020-130.el6_4.x86_64 from the kickstart as version 129.el6.x86_64 is already installed with all required dependencies.
    
    SPMA upgrades all Perl packages to version 130.el6_4.x86_64 after the first reboot.
    
    We installed at RAL both SL6 and SL5 systems without it and they worked fine, while SL6 systems were failing before.
Commits on May 8, 2013
Commits on Apr 21, 2013
  1. Merge pull request #21 from piojo/whitespace

    ned21 committed Apr 21, 2013
    Make whitespaces consistent.
  2. Make whitespaces consistent.

    piojo committed Apr 21, 2013
    As requested by @ned21 in #18 and #19.
  3. Merge pull request #20 from piojo/syslog

    ned21 committed Apr 21, 2013
    Support the logging directive in Kickstart
Commits on Apr 17, 2013
  1. Merge pull request #17 from piojo/fix-pkg-base

    ned21 committed Apr 17, 2013
    Ignore repositories unavailable at installation
  2. Skip unavailable Yum repositories

    piojo committed Apr 5, 2013
    Repositories that are down or require credentials we don't have yet
    shouldn't abort the installations.
  3. Fix bug while installing base packages

    piojo committed Apr 5, 2013
    Base packages without the version wouldn't be listed.
  4. Merge pull request #16 from piojo/fix-mtu

    ned21 committed Apr 17, 2013
    Fix bug in MTU declaration.
Commits on Apr 16, 2013
  1. Fix bug in CNAF's requirement

    piojo committed Apr 16, 2013
Commits on Apr 10, 2013
  1. Merge pull request #13 from jouvin/master

    Luis Fernando Muñoz Mejías committed Apr 10, 2013
    Fix for too late execution of AII site config
Commits on Apr 3, 2013
  1. Merge pull request #10 from jouvin/master

    Luis Fernando Muñoz Mejías committed Apr 3, 2013
    Add a property to define if volgroup statement must be added to KS config file
  2. aii-ks: add property 'volgroup_required' to control whether volgroup …

    jouvin committed Apr 3, 2013
    …statement must be added to KS config file
Commits on Mar 30, 2013
  1. Merge pull request #8 from jouvin/master

    Luis Fernando Muñoz Mejías committed Mar 30, 2013
    aii-dhcp fixes for handling conf files without subnet paramaters
  2. Rename remaining .tpl files to .pan.

    jouvin committed Mar 30, 2013
    Remove remaining .cin files
    Add configuration examples to RPM
  3. aii-core: fix typo in config.pan

    jouvin committed Mar 30, 2013
  4. Fix for handling properly a DHCP configuration file without subnet de…

    jouvin committed Mar 30, 2013
    …finitions
    
    (happens if the file managed by AII is only a subset of the whole config)