New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Do not "lock" camera when searching with coordinates in the Sector View #4353

Open
WKFO opened this Issue Jun 20, 2018 · 0 comments

Comments

Projects
None yet
1 participant
@WKFO
Contributor

WKFO commented Jun 20, 2018

Thanks a lot @fluffyfreak for #4341 . :)
Though I just have a minor complaint.

Observed behaviour

When moving the SectorView camera by entering coordinates to the search field, the camera position gets "locked" to the coordinates and you can't move it. I think it might be caused by the camera position being updated every frame. If you delete the coordinates in the search field the camera "unlocks" and you are free to move again.

But, while deleting (or writing) coordinates, if the z coordinate has more than one digits, the camera parses every string and bounces around trying to go everywhere you write.

For example, if you want to go to (11, -5, -28), the camera first goes to (11, -5, -2) and then bounces to (11, -5, -28). Same while deleting.

Preferable fix

Only try to move the camera ONCE when 'Enter' is pressed. It seemed to work pretty well before.

My pioneer version (and OS):
Latest master, Windows 10 Enterprise

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment