New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[Security] Bump rails from 5.2.1 to 5.2.1.1 in /api #87

Merged
merged 1 commit into from Nov 28, 2018

Conversation

Projects
None yet
3 participants
@greysteil

greysteil commented Nov 27, 2018

Bumps rails from 5.2.1 to 5.2.1.1. This update includes security fixes.

Vulnerabilities fixed

Sourced from The Ruby Advisory Database.

Bypass vulnerability in Active Storage
There is a vulnerability in Active Storage. This vulnerability has been assigned the CVE identifier CVE-2018-16477.

Impact

Signed download URLs generated by ActiveStorage for Google Cloud Storage service and Disk service include content-disposition and content-type parameters that an attacker can modify. This can be used to upload specially crafted HTML files and have them served and executed inline. Combined with other techniques such as cookie bombing and specially crafted AppCache manifests, an attacker can gain access to private signed URLs within a specific storage path.

Vulnerable apps are those using either GCS or the Disk service in production. Other storage services such as S3 or Azure aren't affected.

All users running an affected release should either upgrade or use one of the workarounds immediately. For those using GCS, it's also recommended to run the following to update existing blobs:

ActiveStorage::Blob.find_each do |blob|
  blob.send :update_service_metadata
end

Patched versions: >=5.2.1.1
Unaffected versions: < 5.2.0

Sourced from The Ruby Advisory Database.

Broken Access Control vulnerability in Active Job
There is a vulnerability in Active Job. This vulnerability has been assigned the CVE identifier CVE-2018-16476.

Impact

Carefully crafted user input can cause Active Job to deserialize it using GlobalId and allow an attacker to have access to information that they should not have.

Vulnerable code will look something like this:

MyJob.perform_later(user_input)

All users running an affected release should either upgrade or use one of the workarounds immediately.

Patched versions: >= 4.2.11, < 5.0.0; >= 5.0.7.1, < 5.1.0; >= 5.1.6.1, < 5.2.0; >= 5.2.1.1
Unaffected versions: < 4.2.0

Commits
  • 96dee0e Preparing for 5.2.1.1 release
  • 54ed6ad Prevent content type and disposition bypass in storage service URLs
  • 970b0d7 Do not deserialize GlobalID objects that were not generated by Active Job
  • See full diff in compare view

Dependabot compatibility score

[Security] Bump rails from 5.2.1 to 5.2.1.1 in /api
Bumps [rails](https://github.com/rails/rails) from 5.2.1 to 5.2.1.1. **This update includes security fixes.**
- [Release notes](https://github.com/rails/rails/releases)
- [Commits](rails/rails@v5.2.1...v5.2.1.1)

Signed-off-by: dependabot[bot] <support@dependabot.com>

@seadowg seadowg merged commit 7d19bec into pivotal:master Nov 28, 2018

1 check passed

ci/pivotal-cla Thank you for signing the Contributor License Agreement!
Details
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment