Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Wrong device detection #3971

Closed
anonymous-piwik-user opened this Issue · 4 comments

3 participants

@anonymous-piwik-user

piwik detects my N9 with Meego/Harmattan using the default browser as 'Symbian' under 'Operating System families' and shows 'Nokia Browser' under browser.

Meego is not Symbian, this should appear under Meego or Other.

This occurs with Piwik 1.12 with the new Devices Plugin.
I am guessing the code responsible is plugins/DevicesDetection/UserAgentParserEnhanced/UserAgentParserEnhanced.php Line 154 and 205:227 when looking at commit 6804733ddcb9fcf72b2df3f796a0d5b228bb0ab2

@mattab
Owner

Thanks for the report. we keep track of improvements to DevicesDetection in #3962 - please add further feedback there (already added yours)

@mattab
Owner

Thanks for report. Could you post user agent that was detected wrongly?

We now have hundreds of unit tests and so would be able to make this fix if you provide a bit more info.

@sgiehl
Owner

In 6ff015e113ce56061387428e50429192ba8c5b4d: refs #3971 - detect Meego as 'Other Mobile' instead of 'Symbian'

@sgiehl
Owner

We now have some tests covering Nokia N9 with Meego. See https://github.com/piwik/piwik/blob/master/tests/PHPUnit/Fixtures/userAgentParserEnhancedFixtures.yml#L15570
I'll close this ticket for now. If there is still something wrong, please reopen the ticket.

@anonymous-piwik-user anonymous-piwik-user added this to the Version 2.2 milestone
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.