Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Installation failed on step 7 #1326

Closed
anonymous-piwik-user opened this Issue · 7 comments

3 participants

Anonymous Piwik user Anthon Pang Matthieu Aubry
Anonymous Piwik user

On 7 step I've got following error message "- You can't access this resource as it requires an 'admin' access for at least one website."

Even if I try to use "example.org" or my own domain.
Tried to use svn version and lates.zip without result, same error.

Anthon Pang
Collaborator

This appears to be the problem behind the failing webtest.

Matthieu Aubry
Owner

I broke that.. let me fix it

Matthieu Aubry
Owner

(In [2138]) Fixes #1326
checkUserHasSomeAdminAccess() fails when there is no website yet. Making it work if user is super user.

Matthieu Aubry
Owner

(In [2140]) 0.6 with fix #1326

Matthieu Aubry
Owner

This was introduced in [2124]

I republished 0.6 with the fix in it, hopefully not many users did have time to download 0.6

Anthon Pang
Collaborator

Thanks Matt.

For consistency, can we similarly patch checkUserHasAdminAccess()?

Matthieu Aubry
Owner

checkUserHasAdminAccess is slightly different as it is used to actually check also that the idsites provided are correct and exist (eg. in SitesManager.updateSite).

If we change checkUserHasAdminAccess we would need to check that all methods would not fail or misbehave when give one or a list of fake website IDs. but agreed, this would be consistent and good todo :)

Anonymous Piwik user anonymous-piwik-user added this to the Piwik 0.6 milestone
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.