Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

endless HTTP 302 Moved Temporarily loop instead of login form #1357

Closed
anonymous-piwik-user opened this Issue · 1 comment

2 participants

@anonymous-piwik-user

On a relatively new installation of Piwik 0.6.1, I had configured "For anonymous users, report date to load by default" to be "Current Week". This resulted in all visitors attempting to access Piwik (login form) receiving an endless loop of HTTP 302 redirects. The login form does not even appear.

I do not have any web sites configured to allow viewing by anonymous users; this setting remained from previous testing when I had a web site with anonymous viewing enabled. I didn't think this setting should matter because of the note "Note: You do not have any website that the anonymous user can access, the following settings won't be used." above the Anonymous user settings area.

However, switching it back to make "Today" the default anonymous destination fixed the issue and allowed the login form to appear.

@mattab
Owner

(In [2498]) Fixes #1357 - when the request is invalid, users are now redirected to the Login form. Relogging will ensure that the right website is selected.

Thanks for the report dysolution

@anonymous-piwik-user anonymous-piwik-user added this to the Piwik 0.6.4 milestone
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.