PHP 5.1.6 errors if EXPERIMENTAL_DATE_SUPPORT enabled #1359

Closed
robocoder opened this Issue May 13, 2010 · 2 comments

1 participant

@robocoder

Installer:

  • detect whether or not DateTime classes available; otherwise
Fatal error: Class 'DateTimeZone' not found in /home/apang/work/piwik/dev/trunk/core/Date.php on line 207

Note: I have some more testing to do and may expand on this ticket...

@robocoder

Hmm... the DateTime and DateTimeZone classes aren't in the 5.1.6 sources (but the timezone functions are). I'm guessing some distros either backported this feature or used a post-5.1.6 SVN shapshot.

Options:

  • raise minimum php requirement to 5.2, or
  • modify core/Date.php to not depend on DateTime & DateTimeZone
@robocoder

(In [2186]) fixes #1359 - use procedural interface instead of DateTime & DateTimeZone classes to support php 5.1.6 with experimental date support enabled

@robocoder robocoder added this to the Piwik 0.6.2 milestone Jul 8, 2014
@robocoder robocoder self-assigned this Jul 8, 2014
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment