Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Exception: Requested website was not loaded. in ../webstat/core/Site.php on line 62 #1520

Closed
anonymous-piwik-user opened this Issue · 6 comments

2 participants

@anonymous-piwik-user

Yesterday, I updated PHP from 5.2 to 5.3(.3), and updated piwik too. Piwik updated database and everything looked like good, I logged in, checked settings.. everything was fine.

Today, everything is wrong. If I have a session (I didn't logged out) I have an error in title. The full error message you can find here: [http://letolt.lacyc3.eu/bugreports/piwik_20100728/errors_with_session.log]

Without session, it looks like different error (You can't access this resource as it requires an 'view' access for the website id = 0 ...).

MySQL database works fine, database user name, password and anything else should be fine, because there wasn't any problem before the PHP upgrade.

@anonymous-piwik-user

typo: Exception

@robocoder

Which Piwik version are you running?

When the error occurs, what's the URL in the address bar?

Can you provide the contents of your piwik_site table (assuming "piwik_" is the table prefix)?

@robocoder

Sorry, I should have recognized this earlier. You'll have to either set:

xdebug.show_exception_trace=0
display_errors=Off

because xdebug will log a stack trace whenever an exception is thrown, whether or not it caught in a try...catch block.

@robocoder

(In [2763]) fixes #1520 - disable xdebug stacktraces

@anonymous-piwik-user

Sorry for the slow reply, gmail marked spam the notify mail.

Thanks for the fix.

@robocoder

(In [3039]) refs #1520

@anonymous-piwik-user anonymous-piwik-user added this to the Piwik 0.6.5 milestone
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.