Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Stay on "Email Reports" page after switching website #1648

Closed
anonymous-piwik-user opened this Issue · 9 comments

4 participants

@anonymous-piwik-user

after switching the website report page should be shown again.

@robocoder
Collaborator

For consistency, perhaps it should always reload the current form when changing the website. (Similarly for language.)

@sgiehl
Collaborator

has anyone already worked on this ticket? works for me with current trunk.

@anonymous-piwik-user

I am very pleased to hear that it works with the trunk. With 1.0 I am confronted with this issue.

@mattab
Owner

on trunk, it works for anonymous (redirect to same page again after changing website), but doesn't work when logged in (redirect to dashboard after changing website).

@sgiehl
Collaborator

Works for me for the superuser, too. Will have to test it with another user...

@sgiehl
Collaborator

Ok. checked that again. This behaviour seems to occure ONLY if autocomplete is enabled in website selection (more than 10 websites). I will have a closer look a this.

@sgiehl
Collaborator

(In [3030]) fixes #1648 stay on current page (with new siteid) on selection in autocomplete

@sgiehl
Collaborator

Is there a bug in autocomplete? when I type something into the searchbox, there are html-tags outputed within the results. seems to be the response is escaped before it is inserted to dom.

@mattab
Owner

Steve, autocomplete seems to work OK for me. Can you maybe try again and create a new ticket if you see errors?

@anonymous-piwik-user anonymous-piwik-user added this to the Piwik 1.1 milestone
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.