Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

MultiSites Plugin Error #1904

Closed
anonymous-piwik-user opened this Issue · 7 comments

3 participants

@anonymous-piwik-user

Every time when I run http://analytics.mysite.com/index.php?module=MultiSites&action=index&idSite=1&period=day&date=today, I found a lot of errors in my log file (see one example in the attachment). I was trying to debug the code (all errors are related to lines 78 - 83 in plugins/MultiSites/Controller.php), but don't have the time luxury, so please help me understand this issue and potentially solve it.

@mattab
Owner

what version of Piwik are you using?

@robocoder
Collaborator

What about your PHP version? I have E_STRICT (2048) here, and I'm not seeing those error messages.

@robocoder
Collaborator

What if you change array_shift() to reset() ?

@robocoder
Collaborator

or current() ?

@robocoder
Collaborator

(In [3516]) fixes #1904 - worksforme (must be php version specific); modify code to use a temporary variable

@anonymous-piwik-user anonymous-piwik-user added this to the Piwik 1.1.1 milestone
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.