Compressed assets not being removed on update #1950

Closed
anonymous-piwik-user opened this Issue Jan 5, 2011 · 7 comments

3 participants

@anonymous-piwik-user

I've just updated piwik to 1.1.1 version and now I can't access to statistics. I see only the upper part of the screen (from the top to the date selector) and then all is white. If I look to the html I see a message that says something like "there was an error during request, please retry".

The same happens in multisites view. The page is generated from the top to the table header.

This seems to be a chromium browser issue, with firefox I can see everything well.

I'm using chromium 8.0 on Linux.

@mattab
Piwik Open Source Analytics member

Can you try and delete your browser cache ? Apparently, users are having problems but it is fixed after logging out, clearing the cache and logging in again

See comments in http://piwik.org/blog/2011/01/piwik-1-1-1/

@anonymous-piwik-user

Clearing cache and re-logging solved the problem, sorry for duplicating bug.

@robocoder

This should be in the FAQ. Chromium has a number of cache bugs that we can't workaround via the cachebuster string. After an update, Chromium users must manually clear the cache and restart the browser.

@robocoder

In the forum, we're seeing this reported for other browsers.

The cachebuster string is there. Must be something else. Taking a look...

@robocoder

(In [3645]) fixes #1950 - wasn't removing compressed assets on update; merged assets in tmp are relative to PIWIK_USER_PATH

@robocoder

(In [3771]) refs #1438, refs #1950 - clearCompiledTemplated() is static

@robocoder

(In [4002]) fixes #2124, refs #660, refs #1950 - remove assets here too

@anonymous-piwik-user anonymous-piwik-user added this to the 1.x - Piwik 1.x milestone Jul 8, 2014
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment