Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Automatic PDF email report not working when PDF report is linked to deleted site #2155

Closed
mattab opened this Issue · 3 comments

1 participant

@mattab
Owner

A few users in the forums are having issues with Emails with PDF reports not sent automatically, when cron is not setup.

http://forum.piwik.org/read.php?2,72692

Piwik tries to trigger the PDF emails automatically in the Task Scheduler.

We should make it easy to enable Debug information, and log it in a file with the current date in the filename, in piwik/tmp/

Then users could send us their log files when having specific problems like this one.

Logging might have to be customized by module to limit noise. For example, enable debug logging only for "TaskShedule" hook, or class.

THis ticket is about

  • implementing better log in file feature
  • add logging for at least the PDF emails to find the bug
  • fix an issue or find out about a possible webhost limitation
@mattab
Owner

another report (there are many like this one...) http://forum.piwik.org/read.php?2,73622

@mattab
Owner

I'm pretty sure this is the bug caused by #2314. Fixing #2314 is fine, but won't solve it for existing users that have reports for deleted sites, so let's fix this issue separately here

@mattab
Owner

(In [4458]) Fixes #2155 by joining PDF and website table

@mattab mattab added this to the Piwik 1.3 milestone
@mattab mattab self-assigned this
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.