Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Encoding errors in language files #2202

Closed
mattab opened this Issue · 4 comments

2 participants

@mattab
Owner

The French language file in 1.2.1 contains encoded entities:

 d'entrer ```

It might be because on my windows box (which I use to grab the cleaned translation files after the unit test languagesManager.test.php has ran) the addcslashes or something else encodes these entities.


The other problem is the failing test, which doesn't fail on my box 
http://qa.piwik.org:8080/webtest/003_UnitTests/001_response_invoke.html

Proposed solution: the languages manager test should remove entities from the language files when cleaning them up before the release.



@robocoder

The first problem: a change in TranslationsAdmin or how you get the original translation files from Noah?

The second problem: I didn't figure out the cause but I'll merge my "tidy" code into the LanguagesManager and TranslationsAdmin.

@mattab
Owner

(In [4149]) Fixes #2202 Now converting all entities to their characters when cleaning up translation files before release

One side effect is that & is now & only (which I rememberr fails W3C recommendations... but hey at least it's working!

@robocoder

(In [4154]) refs #2202 - debug failing unit test

@robocoder

(In [4155]) refs #2202 - more debug

@mattab mattab added this to the Piwik 1.3 milestone
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.