Skip to content


Subversion checkout URL

You can clone with
Download ZIP


SEO Widget - incomplete results if URL isn't simply the domain name #2559

anonymous-piwik-user opened this Issue · 2 comments

2 participants


Piwik Version 1.5.1

Directory Structure:
http - (I question why the javascript shows //pwk)

Under Website Management

ID Name URL's

The report to load by default

The javascript code I paste shows the URL of**//pwk**

Issue with active SEO plugin:

I know my website has a decent page rank, and well over 1,000 back-links to my site on Google, and the other SE's, but when I load the SEO widget it is not picking up all stats with**//pwk**

It states PR 0/10
Black-links from Google 0, Yahoo 0, and blah blah.
It only picks up the Alexa rank.

Steps I've taken

I tested it with (removed //pwk) and it worked as I did get the results. It seems having //pwk is causing issue.

If it is causing other issues within areas of the program I am not yet aware of it.

The Admin reply in the forum for my post

July 09, 2011 10:26PM

"Create a ticket in trac. Looks like we need to strip off the path when querying those services."

Thank you,
EvilMishMash (Michele)


The Javascript code displayed is generated using the browser's current url. If you don't believe that's the case, open a separate ticket and include a screen shot.

I'm only going to address the SEO widget. Hmm... with FF5, the input box isn't updating the URL used in the getrankings query.


(In [5063]) fixes #2559

@anonymous-piwik-user anonymous-piwik-user added this to the 1.6 Piwik 1.6 milestone
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.