Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Middle click (open in a new tab) should work as expected for menus, website selector #2663

Closed
mattab opened this Issue · 8 comments

2 participants

Matthieu Aubry Stefan Giehl
Matthieu Aubry
Owner

Usability improvement: the middle click button (open in new tab) should work nicely on the website selector, and the main menu.

  • Currently, middle click on website selector opens in a new table for example "javascript:broadcast.propagateNewPage(%20'idSite=13');"
  • Middle click on the menu opens the dashboard in a new tab, instead of clicked menu

I'm not sure the best way to handle this, hopefully we can refactor the javascript code to generate the URL and have it returned onclick?

Stefan Giehl
Collaborator

(In [5173]) fixes #2663 middle click for open in new tab didn't work because of incorrect href attributes and javascript events bound with jquery. now working in most browsers except of IE 9 (seems to be a known bug)

Matthieu Aubry
Owner

Reopening for small feedback: when opening "website selector" in new tab, can it also restore 'date' 'period' parameters? I'm thinking use case: website 1 is decreasing for this custom range, check other websites in a new tab for same pattern .

thanks!

Stefan Giehl
Collaborator

Should it also restore the current view? atm it always switches back to dashboard...

Stefan Giehl
Collaborator

(In [5174]) refs #2663 fixed urls in site selection, now date und period is restored on middle click

Matthieu Aubry
Owner

Agreed, should set the same view again, I think most users will click on other views and it is less tiring for the brain :)

Stefan Giehl
Collaborator

(In [5175]) refs #2663 update links in site selection with current view, date and period params

Matthieu Aubry
Owner

Reopening as I found a bug. When visiting the API page: http://localhost/trunk/index.php?module=API&action=listAllAPI&period=week&date=today&idSite=3

a left click on the website selector now reloads the page AND shows the selector, instead it should not reload the page but only show the selector as before. I thought the regression was maybe linked to these changes?

Stefan Giehl
Collaborator

(In [5201]) fixes #2663 fixes problem on api page

Matthieu Aubry mattab added this to the 1.6 Piwik 1.6 milestone
Stefan Giehl sgiehl was assigned by mattab
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.