Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

One single campaign appearing twice in campaigns report #2795

Closed
anonymous-piwik-user opened this Issue · 5 comments

2 participants

@anonymous-piwik-user

I have a campaign running. On a website there a - basically - four different links to my site, all using the same campaign-parameters, but different keyword-parameters.

The problem is that all links, that direct to the landing-page as

index.php?utm_campaign=campaign&utm_term=keyword

are counted as one single campagin. And all deep-links to my shop, where the landing page-url is something like

index.php?option=com_virtuemart&category_id=1234&page=
shop.browse&utm_campaign=campaign&utm_term=keyword

are counted as a different campaign that has the same name as the first one. See the screenshot.

API output to these campaigns is:

- <result date="2011-11-19">
- <row>
  <label>Zubehrshop Homepage Link-Building</label> 
  <nb_uniq_visitors>49</nb_uniq_visitors> 
  <nb_visits>49</nb_visits> 
  <nb_actions>297</nb_actions> 
  <max_actions>32</max_actions> 
  <sum_visit_length>11597</sum_visit_length> 
  <bounce_count>14</bounce_count> 
  <nb_visits_converted>0</nb_visits_converted> 
  <idsubdatatable>131</idsubdatatable> 
  </row>
- <row>
  <label>Zubehrshop Homepage Link-Building</label> 
  <nb_uniq_visitors>7</nb_uniq_visitors> 
  <nb_visits>7</nb_visits> 
  <nb_actions>42</nb_actions> 
  <max_actions>18</max_actions> 
  <sum_visit_length>782</sum_visit_length> 
  <bounce_count>2</bounce_count> 
  <nb_visits_converted>0</nb_visits_converted> 
  <idsubdatatable>132</idsubdatatable> 
  </row>
  &lt;/result>```
@anonymous-piwik-user

Attachment: a single campaign appears twice
piwik_campaign-tracking_bug.png

@mattab
Owner

Thanks for the report. Have you experienced this bug in several days?

Could you send me the full DB dump (or the table piwik_log_visit for these days)?
matt att piwik.org

Thanks!

@mattab
Owner

(In [5498]) Fixes #2795 The campaign name and keywords were not URL decoded and trimmed, before recorded in the log table (as opposed to search engine keywords which were correctly decoded and trimmed)
This caused the same keyword to be recorded as Hello%20World and Hello+World
This fix will only fix reports for new data AFTER applying the patch

@mattab
Owner

(In [5499]) Ensuring consistent output (on my box plugins load in different orders causing Xml comparison to fail) + adding test refs #2795

@anonymous-piwik-user

To report back: the fix seems to work.

@anonymous-piwik-user anonymous-piwik-user added this to the 1.7 Piwik 1.7 milestone
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.