Skip to content


Subversion checkout URL

You can clone with
Download ZIP


&segment= parameter should be forwarded to the hashtag when clicking on menus #3060

mattab opened this Issue · 3 comments

2 participants


currently &segment=country==fr is not forwarded to other menus clicked (it disappears). We should forward it as well as date/period/idGoal/etc. so that at least segmentation works when we manually add it to URL, while we're waiting for #2135



I regularly filter stats based on a custom variable (user login) and I always need to edit the URL to reapply the filter.


More complicated than I thought. I think there is a bug in the menu actually.

What I did:

  • Go to index.php?module=CoreHome&action=index&idSite=1&period=day&date=yesterday#module=Actions&action=indexPageUrls&idSite=1&period=day&date=yesterday&segment=country==xx
    • It loads the content as expected with the segment applied
  • OPen firebug > Net panel
  • Click on the same submenu (or any other)
  • You will notice 2 http requests made instead of one:

    • Expected: index.php?module=CoreHome&action=index&idSite=1&period=day&date=yesterday#module=Actions&action=indexPageUrls&idSite=1&period=day&date=yesterday&segment=country==xx

    • But then it also triggers (it seems at the same time) another request this time to the page without the segment: index.php?module=CoreHome&action=index&idSite=1&period=day&date=yesterday#module=Actions&action=indexPageUrls&idSite=1&period=day&date=yesterday

I have tried looking for the bug but couldn't pin point it...


(In [6090]) Fixes #3060 How to spend 2 hours fixing some annoying bug ;)

@mattab mattab added this to the 1.12.x - Piwik 1.12.x milestone
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.