Message: Notice: Undefined offset: 0 in /homeDataTable.php on line 470 #3180

Closed
mattab opened this Issue Jun 3, 2012 · 2 comments

1 participant

@mattab
Piwik Open Source Analytics member

Reported in forum

Notice: Undefined offset: 0 in /home/matrix/domains/piwik.matr**.*/public_html/core/DataTable.php on line 470 

Backtrace -->
#0 Piwik_ErrorHandler(...) called at [/home/matrix/domains/piwik.matr**.*/public_html/core/DataTable.php:470]#1 Piwik_DataTable->getRowFromLabel(...) called at [/home/matrix/domains/piwik.matr**.*/public_html/core/DataTable.php:513]#2 Piwik_DataTable->getFilteredTableFromLabel(...) called at [/home/matrix/domains/piwik.matr**.*/public_html/core/DataTable/Array.php:252]#3 Piwik_DataTable_Array->getFilteredTableFromLabel(...) called at [/home/matrix/domains/piwik.matr**.*/public_html/core/API/DataTableManipulator/LabelFilter.php:72]#4 Piwik_API_DataTableManipulator_LabelFilter->filter(...) called at [/home/matrix/domains/piwik.matr**.*/public_html/core/API/ResponseBuilder.php:323]#5 Piwik_API_ResponseBuilder->handleDataTable(...) called at [/home/matrix/domains/piwik.matr**.*/public_html/core/API/ResponseBuilder.php:79]#6 Piwik_API_ResponseBuilder->getResponse(...) called at [/home/matrix/domains/piwik.matr**.*/public_html/core/API/Request.php:130]#7 Piwik_API_Request->process(...) called at [/home/matrix/domains/piwik.matr**.*/public_html/plugins/API/API.php:1195]#8 Piwik_API_API->loadRowEvolutionDataFromAPI(...) called at [/home/matrix/domains/piwik.matr**.*/public_html/plugins/API/API.php:1092]#9 Piwik_API_API->getSingleRowEvolution(...) called at [/home/matrix/domains/piwik.matr**.*/public_html/plugins/API/API.php:1078]#10 Piwik_API_API->getRowEvolution(...) called at [:]#11 call_user_func_array(...) called at [/home/matrix/domains/piwik.matr**.*/public_html/core/API/Proxy.php:190]#12 Piwik_API_Proxy->call(...) called at [/home/matrix/domains/piwik.matr**.*/public_html/core/API/Request.php:128]#13 Piwik_API_Request->process(...) called at [/home/matrix/domains/piwik.matr**.*/public_html/plugins/CoreHome/DataTableRowAction/RowEvolution.php:162]#14 Piwik_CoreHome_DataTableRowAction_RowEvolution->loadEvolutionReport(...) called at [/home/matrix/domains/piwik.matr**.*/public_html/plugins/CoreHome/DataTableRowAction/RowEvolution.php:99]#15 Piwik_CoreHome_DataTableRowAction_RowEvolution->__construct(...) called at [/home/matrix/domains/piwik.matr**.*/public_html/plugins/CoreHome/Controller.php:138]#16 Piwik_CoreHome_Controller->getRowEvolutionPopover(...) called at [:]#17 call_user_func_array(...) called at [/home/matrix/domains/piwik.matr**.*/public_html/core/FrontController.php:138]#18 Piwik_FrontController->dispatch(...) called at [/home/matrix/domains/piwik.matr**.*/public_html/index.php:53]

@mattab
Piwik Open Source Analytics member

(In [6548]) Refs #3180 Maybe fixes the issue but maybe we should look for the original problem?

@mattab
Piwik Open Source Analytics member

(In [6599]) Fixes #3180 Found the bug!

@mattab mattab added this to the 1.8.3 - Piwik 1.8.3 milestone Jul 8, 2014
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment