Skip to content


Subversion checkout URL

You can clone with
Download ZIP


Detecting site search via URL parameter with square brackets does not work #3454

anonymous-piwik-user opened this Issue · 5 comments

2 participants


When detecting site search via URL, we have a similar problem as mentioned in #3201 and fixed with #3187. If the site search query parameter contains square brackets (e.g. search[q]), it is not recognized if the URL is urlescaped. The patch (similar to #3187) I attached fixes the problem for me. But I am not sure if there isn't a better place to take care of the square brackets. Thanks for having a look!
Keywords: sitesearch


Thanks for report


can you please try with 1.9.2-beta from:

For me it is working by specifying the parameter "s" which will track &s[]=search

what exactly is not working for you & that your patch fixes?


Thanks for getting back to this. The problem still exists in the trunk. To reproduce, please use a url-encoded parameter name (sorry I didn't mention this before), e.g. ?param%5Bsearch%5D=test. It's the same problem as in #3201.


(In [7521]) Site search improvements

  • Support &kwd[]= notation fixes #3454
  • Support random text case fixes #3539
  • Fixes umlauts regression with non utf8 encoding: Fixes #3450
  • Adding setPageCharset() method to Tracking API FIxes #3565
@anonymous-piwik-user anonymous-piwik-user added this to the 1.10 - Piwik 1.10 milestone
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.