Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

UserSettings.getMobileVsDesktop error with period=month, date=previous1, idSite=all #3972

Closed
anonymous-piwik-user opened this Issue · 1 comment

2 participants

Anonymous Piwik user Matthieu Aubry
Anonymous Piwik user

Piwik v1.12 with almost 800 sites.

The following API request

module=API&token_auth=OURTOKEN&method=UserSettings.getMobileVsDesktop&period=month&date=previous1&idSite=all

results in this error:

Fatal error: Call to undefined method Piwik_DataTable_Array::getRowFromLabel() in /var/www/html/piwik/plugins/UserSettings/API.php on line 108

It is strange because the following request is successful, which should be the same report as above:

module=API&token_auth=OURTOKEN&method=UserSettings.getMobileVsDesktop&period=month&date=2013-05&idSite=all

And I get a successful result with period=month&date=previous1 if idSite != all:

module=API&token_auth=OURTOKEN&method=UserSettings.getMobileVsDesktop&period=month&date=previous1&idSite=846

This seems like a bug with the previous keyword, because specifying period=month&date=2013-05 should be the same report as period=month&date=previous1, right? And it seems like it may be specific to getMobileVsDesktop, as none of my other monthly reports have trouble using the previous1 keyword.

Matthieu Aubry
Owner

Works for me in Piwik 2.0.4

This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.