Problem with API method Live.getLastVisitDetails and filter_offset #4044

Closed
tsteur opened this Issue Jul 10, 2013 · 2 comments

1 participant

@tsteur
Piwik Open Source Analytics member

When executing this request I'm getting visitors from 23:50 - 22:50o'clock.

http://demo.piwik.org/index.php?filter_limit=15&period=day&date=2012-07-08&idSite=7&module=API&token_auth=anonymous&format=json&method=Live.getLastVisitsDetails&language=en&

When executing a follow up request to fetch the previous visitors I'm getting visitors from 22:00 - 20:45o'clock

http://demo.piwik.org/index.php?filter_limit=45&filter_offset=15&period=day&date=2012-07-08&idSite=7&module=API&token_auth=anonymous&format=json&method=Live.getLastVisitsDetails&language=en&

When executing another follow up request to fetch the previous visitors I'm getting visitors from 19:35 - 18:00o'clock

http://demo.piwik.org/index.php?filter_limit=75&filter_offset=45&period=day&date=2012-07-08&idSite=7&module=API&token_auth=anonymous&format=json&method=Live.getLastVisitsDetails&language=en&

It looks like I always miss a page or 30-60minutes. Am I doing something wrong? Doesn't look like a coincidence as this happens on all "pages" thoughout all days

At first, I expected when calling filter_offset=45 & filter_limit=30 I will get 30 visitors starting from 45. But this is also not the case.

@tsteur
Piwik Open Source Analytics member

In ba84d89: refs #4044 this could fix the filter_limit and filter_offset is applied twice. Once in Live.getLastVisitDetails and once in ResponseBuilder. Unfortunately, cannot run all tests on my local machine to make sure everything still works.

@tsteur
Piwik Open Source Analytics member

In e8ab9c9: refs #4044 fix visitor profile is not working

@tsteur tsteur added this to the 2.0 - Piwik 2.0 milestone Jul 8, 2014
@sabl0r sabl0r pushed a commit to sabl0r/piwik that referenced this issue Sep 23, 2014
@tsteur tsteur refs #4044 this could fix the filter_limit and filter_offset is appli…
…ed twice. Once in Live.getLastVisitDetails and once in ResponseBuilder. Unfortunately, cannot run all tests on my local machine to make sure everything still works.
ba84d89
@sabl0r sabl0r pushed a commit to sabl0r/piwik that referenced this issue Sep 23, 2014
@tsteur tsteur refs #4044 fix visitor profile is not working e8ab9c9
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment