Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Segment attribute not kept during live widget updates #4237

Closed
anonymous-piwik-user opened this Issue · 1 comment

2 participants

@anonymous-piwik-user

I have a Live:Real Time Visitor Count embedded on another webpage, I wanted to be able to have a live view of the sessions in a specific portion of the page - but the "&segment=pageUrl=@subsite" only works for the initial count - the autorefresh ignores the segment setting.

I am using the current live build.
To recreate the issue:
open http://demo.piwik.org/
select Widgets,Live!,Real Time Visitor Count
append the embed url with :
&segment=pageUrl=@demo
(this should show the live visitors on the demo site)
after 30 seconds or so it refreshes and defaults back to all users (for the demo site the change in numbers is normally from 0-1 to 5-10)

I believe this is a bug as the segment attribute does not look like it is being passed on in the refresh.

regards,
Richard.

Keywords: widget segment

@mattab
Owner

In ecde5ea: Fixes #4237 Forwarding segment parameter on refresh

@anonymous-piwik-user anonymous-piwik-user added this to the 2.0 - Piwik 2.0 milestone
@sabl0r sabl0r referenced this issue from a commit in sabl0r/piwik
@mattab mattab Fixes #4237 Forwarding segment parameter on refresh ecde5ea
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.