Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

If server is not using at least PHP 5.3, make sure Piwik displays a useful error message #4653

Closed
mattab opened this Issue · 1 comment

1 participant

Matthieu Aubry
Matthieu Aubry
Owner

Our index.php should be compatible with older PHP versions such as PHP 4 and PHP 5.1 and PHP 5.2.

Currently it spits out a PARSE error when it hits the "use" statement. Instead, let's rewrite the index.php so that is is parsable by Php4 and early php5. This will prevent a lot of user frustration and support requests. See faq and Piwik requirements.

Matthieu Aubry
Owner

Fixed in 0a04031

Matthieu Aubry mattab added this to the 2.1 - Piwik 2.1 milestone
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.