Piwik will now use Semantic Versioning 2.0.0 #4796

Closed
mattab opened this Issue Mar 4, 2014 · 0 comments

2 participants

@mattab
Piwik Open Source Analytics member

From Piwik 2.1.0 Piwik will exclusively use Semantic Versioning for our version numbers.

For Piwik Core

That means that our new version will be Piwik 2.1.0 and not Piwik 2.1. We will always use 3 numbers in the version string.

For Piwik Plugins

All plugins in the marketplace are using Semantic Versioning. When a new plugin version is released, the marketplace will check that the version number is a valid Semantic Version.

Why Use Semantic Versioning?

Without compliance to some sort of formal specification, version numbers are essentially useless for dependency management. By giving a name and clear definition to the above ideas, it becomes easy to communicate your intentions to the users of your software. Once these intentions are clear, flexible (but not too flexible) dependency specifications can finally be made.

More info http://semver.org/

Note: we may not increase MAJOR number when introducing backward incompatible platform changes (such as in Piwik 2.1.0) because we are in a fast iterating cycle and this may happen often as we improve the platform and architecture of Piwik.

@mattab mattab added this to the 2.2.1 - Piwik 2.2.1 milestone Jul 8, 2014
@tsteur tsteur was assigned by mattab Jul 8, 2014
@sabl0r sabl0r pushed a commit to sabl0r/piwik that referenced this issue Sep 23, 2014
@tsteur tsteur fix #4796 anchor links do not work after merging AngularJS 37de7c8
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment